<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<link rel="pingback" href="http://www.backsportspage.com/xmlrpc.php" />
<meta property="og:image" content="http://www.backsportspage.com/wp-content/uploads/2021/07/Joel-Embiid-12-1000x576.jpg" />
<meta name="twitter:image" content="http://www.backsportspage.com/wp-content/uploads/2021/07/Joel-Embiid-12-1000x576.jpg" />
<meta property="og:type" content="article" />
<meta property="og:description" content="The final part of a series looking at the Philadelphia 76ers future. The first part talked about Ben Simmons and the fact that they need to move on from him. The second part was on Doc Rivers, who’s propensity to choke in playoff games is concerning, but ultimately the improvements the players made and the [&hellip;]" />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/">
<meta name="twitter:title" content="Where Do the 76ers Go From Here? Part 4: Joel Embiid">
<meta name="twitter:description" content="The final part of a series looking at the Philadelphia 76ers future. The first part talked about Ben Simmons and the fact that they need to move on from him. The second part was on Doc Rivers, who’s propensity to choke in playoff games is concerning, but ultimately the improvements the players made and the [&hellip;]">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- Jetpack Site Verification Tags -->

	<!-- This site is optimized with the Yoast SEO plugin v16.6.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Where Do the 76ers Go From Here? Part 4: Joel Embiid - Back Sports Page</title>
	<meta name="description" content="Joel Embiid is a young MVP level player, coming off his best season. It would be ridiculous for the Philadelphia 76ers to move on from him...right?" />
	<link rel="canonical" href="http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Where Do the 76ers Go From Here? Part 4: Joel Embiid - Back Sports Page" />
	<meta property="og:description" content="Joel Embiid is a young MVP level player, coming off his best season. It would be ridiculous for the Philadelphia 76ers to move on from him...right?" />
	<meta property="og:url" content="http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/" />
	<meta property="og:site_name" content="Back Sports Page" />
	<meta property="article:published_time" content="2021-07-09T11:30:55+00:00" />
	<meta property="article:modified_time" content="2021-07-11T18:09:49+00:00" />
	<meta property="og:image" content="http://www.backsportspage.com/wp-content/uploads/2021/07/Joel-Embiid-12.jpg" />
	<meta property="og:image:width" content="1024" />
	<meta property="og:image:height" content="576" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Patrick Yen" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="8 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"http://www.backsportspage.com/#website","url":"http://www.backsportspage.com/","name":"Back Sports Page","description":"Sports Beyond the Game","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"http://www.backsportspage.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en"},{"@type":"ImageObject","@id":"http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/#primaryimage","inLanguage":"en","url":"http://www.backsportspage.com/wp-content/uploads/2021/07/Joel-Embiid-12.jpg","contentUrl":"http://www.backsportspage.com/wp-content/uploads/2021/07/Joel-Embiid-12.jpg","width":1024,"height":576,"caption":"Philadelphia 76ers' Joel Embiid looks to shoot during the second half of an NBA basketball game against the Chicago Bulls Monday, May 3, 2021, in Chicago. The 76ers won 106-94. (AP Photo/Charles Rex Arbogast)"},{"@type":"WebPage","@id":"http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/#webpage","url":"http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/","name":"Where Do the 76ers Go From Here? Part 4: Joel Embiid - Back Sports Page","isPartOf":{"@id":"http://www.backsportspage.com/#website"},"primaryImageOfPage":{"@id":"http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/#primaryimage"},"datePublished":"2021-07-09T11:30:55+00:00","dateModified":"2021-07-11T18:09:49+00:00","author":{"@id":"http://www.backsportspage.com/#/schema/person/7c5e0045d6f5cade139469b8a0101328"},"description":"Joel Embiid is a young MVP level player, coming off his best season. It would be ridiculous for the Philadelphia 76ers to move on from him...right?","breadcrumb":{"@id":"http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/#breadcrumb"},"inLanguage":"en","potentialAction":[{"@type":"ReadAction","target":["http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/"]}]},{"@type":"BreadcrumbList","@id":"http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"http://www.backsportspage.com/"},{"@type":"ListItem","position":2,"name":"Where Do the 76ers Go From Here? Part 4: Joel Embiid"}]},{"@type":"Person","@id":"http://www.backsportspage.com/#/schema/person/7c5e0045d6f5cade139469b8a0101328","name":"Patrick Yen","image":{"@type":"ImageObject","@id":"http://www.backsportspage.com/#personlogo","inLanguage":"en","url":"http://0.gravatar.com/avatar/3d22fbedaeedac2d1b0e37d3e2ba3ff2?s=96&d=mm&r=pg","contentUrl":"http://0.gravatar.com/avatar/3d22fbedaeedac2d1b0e37d3e2ba3ff2?s=96&d=mm&r=pg","caption":"Patrick Yen"},"sameAs":["http://www.backsportspage.com"],"url":"http://www.backsportspage.com/author/py_bsp/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Back Sports Page &raquo; Feed" href="http://www.backsportspage.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Back Sports Page &raquo; Comments Feed" href="http://www.backsportspage.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Back Sports Page &raquo; Where Do the 76ers Go From Here? Part 4: Joel Embiid Comments Feed" href="http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.backsportspage.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='sby_styles-css'  href='http://www.backsportspage.com/wp-content/plugins/feeds-for-youtube/css/sb-youtube.min.css?ver=1.4' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='http://www.backsportspage.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='liveblog24_live_blogging_tool-cgb-style-css-css'  href='http://www.backsportspage.com/wp-content/plugins/24liveblog/dist/blocks.style.build.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='http://www.backsportspage.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='http://www.backsportspage.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-components-css'  href='http://www.backsportspage.com/wp-includes/css/dist/components/style.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-editor-css'  href='http://www.backsportspage.com/wp-includes/css/dist/block-editor/style.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-nux-css'  href='http://www.backsportspage.com/wp-includes/css/dist/nux/style.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-editor-css'  href='http://www.backsportspage.com/wp-includes/css/dist/editor/style.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='blocks-ape-gallery-style-css-css'  href='http://www.backsportspage.com/wp-content/plugins/gallery-images-ape/modules/block/dist/blocks.style.build.css?ver=2.2.6' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://www.backsportspage.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/font-awesome.min.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='ctf_styles-css'  href='http://www.backsportspage.com/wp-content/plugins/custom-twitter-feeds/css/ctf-styles.min.css?ver=1.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='photoblocks-css'  href='http://www.backsportspage.com/wp-content/plugins/photoblocks-grid-gallery/public/css/photoblocks-public.css?ver=1.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='tp_twitter_plugin_css-css'  href='http://www.backsportspage.com/wp-content/plugins/recent-tweets-widget/tp_twitter_plugin.css?ver=1.0' type='text/css' media='screen' />
<link rel='stylesheet' id='theiaPostSlider-css'  href='http://www.backsportspage.com/wp-content/plugins/theia-post-slider/css/font-theme.css?ver=1.14.0' type='text/css' media='all' />
<style id='theiaPostSlider-inline-css' type='text/css'>


				.theiaPostSlider_nav.fontTheme ._title,
				.theiaPostSlider_nav.fontTheme ._text {
					line-height: 48px;
				}
	
				.theiaPostSlider_nav.fontTheme ._button {
					color: #f08100;
				}
	
				.theiaPostSlider_nav.fontTheme ._button ._2 span {
					font-size: 48px;
					line-height: 48px;
				}
	
				.theiaPostSlider_nav.fontTheme ._button:hover,
				.theiaPostSlider_nav.fontTheme ._button:focus {
					color: #ffa338;
				}
	
				.theiaPostSlider_nav.fontTheme ._disabled {
					color: #777777 !important;
				}
			
</style>
<link rel='stylesheet' id='theiaPostSlider-font-css'  href='http://www.backsportspage.com/wp-content/plugins/theia-post-slider/fonts/style.css?ver=1.14.0' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-custom-style-css'  href='http://www.backsportspage.com/wp-content/themes/the-league/style.css?ver=5.7.2' type='text/css' media='all' />
<style id='mvp-custom-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='mvp-reset-css'  href='http://www.backsportspage.com/wp-content/themes/the-league/css/reset.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='http://www.backsportspage.com/wp-content/themes/the-league/font-awesome/css/font-awesome.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-fonts-css'  href='//fonts.googleapis.com/css?family=Advent+Pro%3A700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7COswald%3A300%2C400%2C700%7CLato%3A300%2C400%2C700%7CWork+Sans%3A200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COpen+Sans%3A400%2C700%2C800%7CRoboto+Condensed%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-media-queries-css'  href='http://www.backsportspage.com/wp-content/themes/the-league/css/media-queries.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.backsportspage.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.9' type='text/css' media='all' />
<script type='text/javascript' src='http://www.backsportspage.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/plugins/photoblocks-grid-gallery/public/js/anime.min.js?ver=1.2.3' id='anime-js'></script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/plugins/photoblocks-grid-gallery/public/js/packery.pkgd.js?ver=5.7.2' id='packery-js'></script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/plugins/photoblocks-grid-gallery/public/js/photoblocks.public.js?ver=1.2.3' id='photoblocks-js'></script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/plugins/theia-post-slider/js/balupton-history.js/jquery.history.js?ver=1.7.1' id='history.js-js'></script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/plugins/theia-post-slider/js/async.min.js?ver=14.09.2014' id='async.js-js'></script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/plugins/theia-post-slider/js/tps.js?ver=1.14.0' id='theiaPostSlider/theiaPostSlider.js-js'></script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/plugins/theia-post-slider/js/main.js?ver=1.14.0' id='theiaPostSlider/main.js-js'></script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/plugins/theia-post-slider/js/tps-transition-slide.js?ver=1.14.0' id='theiaPostSlider/transition.js-js'></script>
<link rel="https://api.w.org/" href="http://www.backsportspage.com/wp-json/" /><link rel="alternate" type="application/json" href="http://www.backsportspage.com/wp-json/wp/v2/posts/22993" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.backsportspage.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.backsportspage.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel='shortlink' href='https://wp.me/paUou5-5YR' />
<link rel="alternate" type="application/json+oembed" href="http://www.backsportspage.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.backsportspage.com%2Fwhere-do-the-76ers-go-from-here-part-4-joel-embiid%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.backsportspage.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.backsportspage.com%2Fwhere-do-the-76ers-go-from-here-part-4-joel-embiid%2F&#038;format=xml" />
<script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":22993,"post_name":"where-do-the-76ers-go-from-here-part-4-joel-embiid","post_title":"Where Do the 76ers Go From Here? Part 4: Joel Embiid","post_type":"post","post_author":"124","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":4,"name":"Features","slug":"features","term_group":0,"term_taxonomy_id":4,"taxonomy":"category","description":"","parent":0,"count":956,"filter":"raw","cat_ID":4,"category_count":956,"category_description":"","cat_name":"Features","category_nicename":"features","category_parent":0},{"term_id":19,"name":"NBA","slug":"nba","term_group":0,"term_taxonomy_id":19,"taxonomy":"category","description":"","parent":0,"count":890,"filter":"raw","cat_ID":19,"category_count":890,"category_description":"","cat_name":"NBA","category_nicename":"nba","category_parent":0}]; _mmunch['postTags'] = [{"term_id":453,"name":"Ben Simmons","slug":"ben-simmons","term_group":0,"term_taxonomy_id":453,"taxonomy":"post_tag","description":"","parent":0,"count":21,"filter":"raw"},{"term_id":2664,"name":"Doc Rivers","slug":"doc-rivers","term_group":0,"term_taxonomy_id":2664,"taxonomy":"post_tag","description":"","parent":0,"count":6,"filter":"raw"},{"term_id":1094,"name":"Joel Embiid","slug":"joel-embiid","term_group":0,"term_taxonomy_id":1094,"taxonomy":"post_tag","description":"","parent":0,"count":15,"filter":"raw"},{"term_id":454,"name":"Philadelphia 76ers","slug":"philadelphia-76ers","term_group":0,"term_taxonomy_id":454,"taxonomy":"post_tag","description":"","parent":0,"count":91,"filter":"raw"}]; _mmunch['postAuthor'] = {"name":"Patrick Yen","ID":124};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="mailmunch" data-mailmunch-site-id="390713" async></script><style>.post-thumbnail img[src$='.svg'] { width: 100%; height: auto; }</style><script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//www.backsportspage.com/?wordfence_lh=1&hid=BA106D99BD48EC1E6764828FDBB5C651');
</script><style type='text/css'>img#wpstats{display:none}</style>
		<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://www.backsportspage.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #dcdcdc; }
</style>
	<link rel="icon" href="http://www.backsportspage.com/wp-content/uploads/2021/05/cropped-101544802_665833630930121_1884955670407544832_n-32x32.jpg" sizes="32x32" />
<link rel="icon" href="http://www.backsportspage.com/wp-content/uploads/2021/05/cropped-101544802_665833630930121_1884955670407544832_n-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="http://www.backsportspage.com/wp-content/uploads/2021/05/cropped-101544802_665833630930121_1884955670407544832_n-180x180.jpg" />
<meta name="msapplication-TileImage" content="http://www.backsportspage.com/wp-content/uploads/2021/05/cropped-101544802_665833630930121_1884955670407544832_n-270x270.jpg" />
			<link rel="stylesheet" type="text/css" id="wp-custom-css" href="http://www.backsportspage.com/?custom-css=de2c845fc6" />
		<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/plugins/wp-spamshield/js/jscripts.php'></script> 
</head>
<body class="post-template-default single single-post postid-22993 single-format-standard custom-background theiaPostSlider_body wpb-js-composer js-comp-ver-5.1.1 vc_responsive">
	<div id="mvp-fly-wrap">
	<div id="mvp-fly-menu-top" class="left relative">
		<div class="mvp-fly-top-out left relative">
			<div class="mvp-fly-top-in">
				<div id="mvp-fly-logo" class="left relative">
											<a href="http://www.backsportspage.com/"><img src="http://www.backsportspage.com/wp-content/uploads/2017/06/logo-nav.png" alt="Back Sports Page" data-rjs="2" /></a>
									</div><!--mvp-fly-logo-->
			</div><!--mvp-fly-top-in-->
			<div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click">
				<span></span>
				<span></span>
				<span></span>
				<span></span>
			</div><!--mvp-fly-but-wrap-->
		</div><!--mvp-fly-top-out-->
	</div><!--mvp-fly-menu-top-->
	<div id="mvp-fly-menu-wrap">
		<nav class="mvp-fly-nav-menu left relative">
			<div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li id="menu-item-389" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-389"><a href="http://www.backsportspage.com/">Home</a></li>
<li id="menu-item-333" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-333"><a href="http://www.backsportspage.com/category/web-shows/">Web Shows</a>
<ul class="sub-menu">
	<li id="menu-item-337" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-337"><a href="http://www.backsportspage.com/category/web-shows/seth-and-sean-sports/">Seth and Sean Sports</a></li>
	<li id="menu-item-336" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-336"><a href="http://www.backsportspage.com/category/web-shows/off-topic/">Off Topic</a></li>
	<li id="menu-item-5143" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5143"><a href="http://www.backsportspage.com/category/web-shows/hardwood-huddle/">Hardwood Huddle</a></li>
	<li id="menu-item-13815" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13815"><a href="http://www.backsportspage.com/category/web-shows/4th-and-long/">4th And Long</a></li>
	<li id="menu-item-13485" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13485"><a href="http://www.backsportspage.com/category/web-shows/the-cut/">The Cut</a></li>
	<li id="menu-item-8917" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8917"><a href="http://www.backsportspage.com/category/web-shows/exit-velo/">Exit Velo</a></li>
	<li id="menu-item-8919" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8919"><a href="http://www.backsportspage.com/category/web-shows/ear-to-canvas/">Ear To Canvas</a></li>
	<li id="menu-item-5144" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5144"><a href="http://www.backsportspage.com/category/web-shows/zero-technique-podcast/">Zero Technique Podcast</a></li>
	<li id="menu-item-8926" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8926"><a href="http://www.backsportspage.com/category/web-shows/the-trifecta/">The Trifecta</a></li>
	<li id="menu-item-20325" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20325"><a href="http://www.backsportspage.com/category/web-shows/man-to-man-podcast/">Man To Man Podcast</a></li>
	<li id="menu-item-8558" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8558"><a href="http://www.backsportspage.com/category/web-shows/deep-6-podcast/">Deep 6 Podcast</a></li>
	<li id="menu-item-20326" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20326"><a href="http://www.backsportspage.com/category/web-shows/under-the-hoodies/">Under The Hoodies</a></li>
</ul>
</li>
<li id="menu-item-320" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-320"><a href="http://www.backsportspage.com/category/features/">Features</a>
<ul class="sub-menu">
	<li id="menu-item-321" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-321"><a href="http://www.backsportspage.com/category/features/beyond-the-athlete/">Beyond the Athlete</a></li>
	<li id="menu-item-322" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-322"><a href="http://www.backsportspage.com/category/features/book-reviews/">Book Reviews</a></li>
	<li id="menu-item-323" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-323"><a href="http://www.backsportspage.com/category/features/in-the-business/">In the Business</a></li>
	<li id="menu-item-324" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-324"><a href="http://www.backsportspage.com/category/features/in-the-community/">In the Community</a></li>
	<li id="menu-item-3939" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3939"><a href="http://www.backsportspage.com/category/features/community-events/">Community Events</a></li>
	<li id="menu-item-698" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-698"><a href="http://www.backsportspage.com/category/features/question-of-the-day/">Question of the Day</a></li>
	<li id="menu-item-5726" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5726"><a href="http://www.backsportspage.com/category/features/the-rundown-with-tmoney/">The Rundown w/T-Money</a></li>
	<li id="menu-item-325" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-325"><a href="http://www.backsportspage.com/category/features/the-transition/">The Transition</a></li>
</ul>
</li>
<li id="menu-item-330" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-330"><a href="http://www.backsportspage.com/category/nfl/">NFL</a>
<ul class="sub-menu">
	<li id="menu-item-770" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-770"><a href="http://www.backsportspage.com/category/features/big-blue-report/">Big Blue Report</a></li>
</ul>
</li>
<li id="menu-item-326" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-326"><a href="http://www.backsportspage.com/category/mlb/">MLB</a></li>
<li id="menu-item-328" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-328"><a href="http://www.backsportspage.com/category/nba/">NBA</a></li>
<li id="menu-item-331" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-331"><a href="http://www.backsportspage.com/category/nhl/">NHL</a>
<ul class="sub-menu">
	<li id="menu-item-4469" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4469"><a href="http://www.backsportspage.com/category/features/breaking-the-ice/">Breaking The Ice</a></li>
</ul>
</li>
<li id="menu-item-316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="http://www.backsportspage.com/category/other-sports/">•••</a>
<ul class="sub-menu">
	<li id="menu-item-327" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-327"><a href="http://www.backsportspage.com/category/mma/">MMA</a></li>
	<li id="menu-item-318" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-318"><a href="http://www.backsportspage.com/category/other-sports/soccer/">Soccer</a></li>
	<li id="menu-item-317" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317"><a href="http://www.backsportspage.com/category/other-sports/golf/">Golf</a></li>
	<li id="menu-item-319" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-319"><a href="http://www.backsportspage.com/category/other-sports/wwe/">WWE</a></li>
	<li id="menu-item-13816" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13816"><a href="http://www.backsportspage.com/category/features/wrestling/">Wrestling</a></li>
	<li id="menu-item-8497" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8497"><a href="http://www.backsportspage.com/category/features/wnba/">WNBA</a></li>
	<li id="menu-item-10684" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10684"><a href="http://www.backsportspage.com/category/features/aew-wrestling/">AEW Wrestling</a></li>
	<li id="menu-item-329" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-329"><a href="http://www.backsportspage.com/category/ncaa/">NCAA</a></li>
	<li id="menu-item-7221" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7221"><a href="http://www.backsportspage.com/category/other-sports/xfl/">XFL</a></li>
</ul>
</li>
<li id="menu-item-1098" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1098"><a href="http://www.backsportspage.com/category/photos/">BSP Photos</a></li>
<li id="menu-item-346" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-346"><a href="http://www.backsportspage.com/bsp-writers/">BSP Writers</a></li>
<li id="menu-item-341" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-341"><a href="#mailmunch-pop-509941">Subscribe</a></li>
</ul></div>		</nav>
	</div><!--mvp-fly-menu-wrap-->
	<div id="mvp-fly-soc-wrap">
		<span class="mvp-fly-soc-head">Connect with us</span>
		<ul class="mvp-fly-soc-list left relative">
							<li><a href="https://www.facebook.com/backsportspage" target="_blank" class="fa fa-facebook-official fa-2"></a></li>
										<li><a href="https://twitter.com/BackSportsPage" target="_blank" class="fa fa-twitter fa-2"></a></li>
													<li><a href="https://www.instagram.com/backsportspage/" target="_blank" class="fa fa-instagram fa-2"></a></li>
													<li><a href="https://www.youtube.com/user/BackSportsPage" target="_blank" class="fa fa-youtube-play fa-2"></a></li>
											</ul>
	</div><!--mvp-fly-soc-wrap-->
</div><!--mvp-fly-wrap-->				<div id="mvp-site" class="left relative">
		<div id="mvp-search-wrap">
			<div id="mvp-search-box">
				<form method="get" id="searchform" action="http://www.backsportspage.com/">
	<input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>			</div><!--mvp-search-box-->
			<div class="mvp-search-but-wrap mvp-search-click">
				<span></span>
				<span></span>
			</div><!--mvp-search-but-wrap-->
		</div><!--mvp-search-wrap-->
		<header id="mvp-top-head-wrap">
													<nav id="mvp-main-nav-wrap">
				<div id="mvp-top-nav-wrap" class="left relative">
					<div class="mvp-main-box-cont">
						<div id="mvp-top-nav-cont" class="left relative">
							<div class="mvp-top-nav-right-out relative">
								<div class="mvp-top-nav-right-in">
									<div id="mvp-top-nav-left" class="left relative">
										<div class="mvp-top-nav-left-out relative">
											<div class="mvp-top-nav-menu-but left relative">
												<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
													<span></span>
													<span></span>
													<span></span>
													<span></span>
												</div><!--mvp-fly-but-wrap-->
											</div><!--mvp-top-nav-menu-but-->
											<div class="mvp-top-nav-left-in">
												<div id="mvp-top-nav-logo" class="left relative" itemscope itemtype="http://schema.org/Organization">
																											<a itemprop="url" href="http://www.backsportspage.com/"><img itemprop="logo" src="http://www.backsportspage.com/wp-content/uploads/2017/06/logo-nav.png" alt="Back Sports Page" data-rjs="2" /></a>
																																								<h2 class="mvp-logo-title">Back Sports Page</h2>
																									</div><!--mvp-top-nav-logo-->
																							</div><!--mvp-top-nav-left-in-->
										</div><!--mvp-top-nav-left-out-->
									</div><!--mvp-top-nav-left-->
								</div><!--mvp-top-nav-right-in-->
								<div id="mvp-top-nav-right" class="right relative">
																		<div id="mvp-top-nav-soc" class="left relative">
																					<a href="https://www.youtube.com/user/BackSportsPage" target="_blank"><span class="mvp-nav-soc-but fa fa-youtube fa-2"></span></a>
																															<a href="https://www.instagram.com/backsportspage/" target="_blank"><span class="mvp-nav-soc-but fa fa-instagram fa-2"></span></a>
																															<a href="https://twitter.com/BackSportsPage" target="_blank"><span class="mvp-nav-soc-but fa fa-twitter fa-2"></span></a>
																															<a href="https://www.facebook.com/backsportspage" target="_blank"><span class="mvp-nav-soc-but fa fa-facebook-official fa-2"></span></a>
																				<span class="mvp-nav-soc-head">Connect with us</span>
									</div><!--mvp-top-nav-soc-->
																		<span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span>
								</div><!--mvp-top-nav-right-->
							</div><!--mvp-top-nav-right-out-->
						</div><!--mvp-top-nav-cont-->
					</div><!--mvp-main-box-cont-->
				</div><!--mvp-top-nav-wrap-->
				<div id="mvp-bot-nav-wrap" class="left relative">
					<div class="mvp-main-box-cont">
						<div id="mvp-bot-nav-cont" class="left">
							<div class="mvp-bot-nav-out">
								<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
									<span></span>
									<span></span>
									<span></span>
									<span></span>
								</div><!--mvp-fly-but-wrap-->
								<div class="mvp-bot-nav-in">
									<div id="mvp-nav-menu" class="left">
										<div class="menu-primary-menu-container"><ul id="menu-primary-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-389"><a href="http://www.backsportspage.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-333"><a href="http://www.backsportspage.com/category/web-shows/">Web Shows</a>
<ul class="sub-menu">
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-337"><a href="http://www.backsportspage.com/category/web-shows/seth-and-sean-sports/">Seth and Sean Sports</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="http://www.backsportspage.com/seth-and-sean-sports-6-23/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/06/gym-logo-template-featuring-stencil-like-typeface-2996g-1-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/06/gym-logo-template-featuring-stencil-like-typeface-2996g-1-400x240.png 400w, http://www.backsportspage.com/wp-content/uploads/2021/06/gym-logo-template-featuring-stencil-like-typeface-2996g-1-1000x600.png 1000w" sizes="(max-width: 400px) 100vw, 400px" /><div class="mvp-vid-box-wrap"><i class="fa fa-play fa-3"></i></div></div>Seth And Sean Sports 6/23</a></li><li><a href="http://www.backsportspage.com/seth-and-sean-6-16/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/06/gym-logo-template-featuring-stencil-like-typeface-2996g-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/06/gym-logo-template-featuring-stencil-like-typeface-2996g-400x240.png 400w, http://www.backsportspage.com/wp-content/uploads/2021/06/gym-logo-template-featuring-stencil-like-typeface-2996g-1000x600.png 1000w" sizes="(max-width: 400px) 100vw, 400px" /><div class="mvp-vid-box-wrap"><i class="fa fa-play fa-3"></i></div></div>Seth And Sean: 6/16</a></li><li><a href="http://www.backsportspage.com/seth-and-sean-sports-together-again/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/05/gym-logo-template-featuring-stencil-like-typeface-2996g-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/05/gym-logo-template-featuring-stencil-like-typeface-2996g-400x240.png 400w, http://www.backsportspage.com/wp-content/uploads/2021/05/gym-logo-template-featuring-stencil-like-typeface-2996g-1000x600.png 1000w" sizes="(max-width: 400px) 100vw, 400px" /><div class="mvp-vid-box-wrap"><i class="fa fa-play fa-3"></i></div></div>Seth And Sean Sports: Together Again</a></li><li><a href="http://www.backsportspage.com/seth-sean-sports-4-6-21/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/04/logo-maker-for-a-shooting-games-team-with-an-illustration-of-a-woman-3707f-el1-1-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/04/logo-maker-for-a-shooting-games-team-with-an-illustration-of-a-woman-3707f-el1-1-400x240.png 400w, http://www.backsportspage.com/wp-content/uploads/2021/04/logo-maker-for-a-shooting-games-team-with-an-illustration-of-a-woman-3707f-el1-1-1000x600.png 1000w" sizes="(max-width: 400px) 100vw, 400px" /><div class="mvp-vid-box-wrap"><i class="fa fa-play fa-3"></i></div></div>Seth &#038; Sean Sports: 4/6/21</a></li><li><a href="http://www.backsportspage.com/seth-and-sean-sports-3-23/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/03/new-logo-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/03/new-logo-400x240.png 400w, http://www.backsportspage.com/wp-content/uploads/2021/03/new-logo-1000x600.png 1000w" sizes="(max-width: 400px) 100vw, 400px" /><div class="mvp-vid-box-wrap"><i class="fa fa-play fa-3"></i></div></div>Seth And Sean Sports 3/23</a></li></ul></div></div></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-336"><a href="http://www.backsportspage.com/category/web-shows/off-topic/">Off Topic</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="http://www.backsportspage.com/off-topic-jonathan-casillias-season-premiere/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/06/boxing-quotes-post-maker-for-twitter-621d-3-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /><div class="mvp-vid-box-wrap"><i class="fa fa-play fa-3"></i></div></div>Off Topic: Jonathan Casillias (Season Premiere)</a></li><li><a href="http://www.backsportspage.com/off-topic-ryan-truland/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/01/tech-company-logo-generator-with-an-abstract-shape-illustration-2174i-2585-1-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/01/tech-company-logo-generator-with-an-abstract-shape-illustration-2174i-2585-1-400x240.png 400w, http://www.backsportspage.com/wp-content/uploads/2021/01/tech-company-logo-generator-with-an-abstract-shape-illustration-2174i-2585-1-1000x600.png 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Off Topic: Ryan Truland</a></li><li><a href="http://www.backsportspage.com/off-topic-adam-cohen/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/01/tech-company-logo-generator-with-an-abstract-shape-illustration-2174i-2585-1-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/01/tech-company-logo-generator-with-an-abstract-shape-illustration-2174i-2585-1-400x240.png 400w, http://www.backsportspage.com/wp-content/uploads/2021/01/tech-company-logo-generator-with-an-abstract-shape-illustration-2174i-2585-1-1000x600.png 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Off Topic: Adam Cohen</a></li><li><a href="http://www.backsportspage.com/off-topic-lost-episode-nabate-isles/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/01/tech-company-logo-generator-with-an-abstract-shape-illustration-2174i-2585-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/01/tech-company-logo-generator-with-an-abstract-shape-illustration-2174i-2585-400x240.png 400w, http://www.backsportspage.com/wp-content/uploads/2021/01/tech-company-logo-generator-with-an-abstract-shape-illustration-2174i-2585-1000x600.png 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Off Topic: &#8220;Lost Episode&#8221; Nabate Isles</a></li><li><a href="http://www.backsportspage.com/off-topic-talkin-giants-with-newsdays-tom-rock/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/01/twitter-post-template-for-inspirational-sports-quote-621c-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>OFF TOPIC: Talkin&#8217; Giants With Newsday&#8217;s Tom Rock</a></li></ul></div></div></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5143"><a href="http://www.backsportspage.com/category/web-shows/hardwood-huddle/">Hardwood Huddle</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13815"><a href="http://www.backsportspage.com/category/web-shows/4th-and-long/">4th And Long</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13485"><a href="http://www.backsportspage.com/category/web-shows/the-cut/">The Cut</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8917"><a href="http://www.backsportspage.com/category/web-shows/exit-velo/">Exit Velo</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8919"><a href="http://www.backsportspage.com/category/web-shows/ear-to-canvas/">Ear To Canvas</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5144"><a href="http://www.backsportspage.com/category/web-shows/zero-technique-podcast/">Zero Technique Podcast</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8926"><a href="http://www.backsportspage.com/category/web-shows/the-trifecta/">The Trifecta</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20325"><a href="http://www.backsportspage.com/category/web-shows/man-to-man-podcast/">Man To Man Podcast</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8558"><a href="http://www.backsportspage.com/category/web-shows/deep-6-podcast/">Deep 6 Podcast</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20326"><a href="http://www.backsportspage.com/category/web-shows/under-the-hoodies/">Under The Hoodies</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-320"><a href="http://www.backsportspage.com/category/features/">Features</a>
<ul class="sub-menu">
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-321"><a href="http://www.backsportspage.com/category/features/beyond-the-athlete/">Beyond the Athlete</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="http://www.backsportspage.com/culture-jam-mambacita-x-dannijo-benefiting-mamba-mambacita-foundation/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/05/182332582_5488654207842991_544898309744253384_n-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/05/182332582_5488654207842991_544898309744253384_n-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/05/182332582_5488654207842991_544898309744253384_n-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Culture Jam, &#8220;Mambacita x Dannijo,&#8221; Benefiting Mamba &amp; Mambacita Foundation</a></li><li><a href="http://www.backsportspage.com/larry-nance-jr-helps-cleveland/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/01/usa_today_11313501.0-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/01/usa_today_11313501.0-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/01/usa_today_11313501.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Larry Nance Jr. Helps Cleveland</a></li><li><a href="http://www.backsportspage.com/minnesota-athletes-react-to-george-floyds-murder/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2020/06/towns-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2020/06/towns-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2020/06/towns-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Minnesota Athletes React to George Floyd’s Murder</a></li><li><a href="http://www.backsportspage.com/wnba-star-takes-off-season-to-support-prison-reform/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2020/03/maya_moore-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2020/03/maya_moore-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2020/03/maya_moore-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>WNBA Star Takes Off Season to Support Prison Reform</a></li><li><a href="http://www.backsportspage.com/an-athlete-a-father-a-legend-kobe-bryant/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2020/01/thumbnail_Gianna-and-Kobe-1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>An Athlete, A Father, A Legend: Kobe Bryant</a></li></ul></div></div></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-322"><a href="http://www.backsportspage.com/category/features/book-reviews/">Book Reviews</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="http://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Rod Carew Shares Triumphs And Adversities In His Autobiography</a></li><li><a href="http://www.backsportspage.com/book-review-doc-the-life-of-roy-halladay-perfectly-encapsulates-the-hall-of-famers-legacy/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2020/12/Roy-halladay-hall-of-fame-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>Book Review: &#8220;Doc: The Life of Roy Halladay&#8221; perfectly encapsulates the Hall of Famer&#8217;s legacy</a></li><li><a href="http://www.backsportspage.com/young-bucks-killing-the-business-from-backyards-to-the-big-leagues/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2020/11/1574779885_396_young-bucks-696x392-1-scaled-1280x720-1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2020/11/1574779885_396_young-bucks-696x392-1-scaled-1280x720-1-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2020/11/1574779885_396_young-bucks-696x392-1-scaled-1280x720-1-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>YOUNG BUCKS: Killing the Business From Backyards To The Big Leagues</a></li><li><a href="http://www.backsportspage.com/pr-man-jay-horwitz/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2020/08/jay_horwitz_4-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2020/08/jay_horwitz_4-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2020/08/jay_horwitz_4-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Nobody Has More Stories To Tell Than Former New York Mets PR Man Jay Horwitz</a></li><li><a href="http://www.backsportspage.com/barry-zitos-autobiography-throws-his-audience-a-curveball/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2020/03/tuesday-hot-clicks-barry-zito-oakland-athletics-national-anthem-earth-day-videojpg-1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2020/03/tuesday-hot-clicks-barry-zito-oakland-athletics-national-anthem-earth-day-videojpg-1-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2020/03/tuesday-hot-clicks-barry-zito-oakland-athletics-national-anthem-earth-day-videojpg-1-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Barry Zito’s Autobiography Throws His Audience a Curveball</a></li></ul></div></div></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-323"><a href="http://www.backsportspage.com/category/features/in-the-business/">In the Business</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="http://www.backsportspage.com/the-zero-technique-football-podcast-special-guest-mike-wright-of-the-fantasy-footballers/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/03/ZTP-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>The Zero Technique Football Podcast: Special Guest Mike Wright of The Fantasy Footballers</a></li><li><a href="http://www.backsportspage.com/no-hate-tour-and-zenni-join-forces-for-high-school-anti-bullying-initiative/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-25-at-12.18.46-PM-800x445-1-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>No Hate Tour and Zenni Join Forces for High School Anti-Bullying Initiative</a></li><li><a href="http://www.backsportspage.com/danny-cortenraede-is-here-to-play-but-he-isnt-messing-around/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/02/thumbnail_LAMOREAUX-53-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/02/thumbnail_LAMOREAUX-53-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/02/thumbnail_LAMOREAUX-53-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Danny Cortenraede is Here to Play&#8211; But He isn&#8217;t Messing Around</a></li><li><a href="http://www.backsportspage.com/mlb-eliminates-majority-of-social-media-content-creator-positions/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/02/meu200t0dn0rsukkqpri-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>MLB Eliminates Majority of Social Media Content Creator Positions</a></li><li><a href="http://www.backsportspage.com/bob-rathbun-talks-hawks-his-journey-with-bsp/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/01/maxresdefault-7-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/01/maxresdefault-7-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/01/maxresdefault-7-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Bob Rathbun Talks Trey Young Comments, Hawks, His Journey And More With BSP</a></li></ul></div></div></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-324"><a href="http://www.backsportspage.com/category/features/in-the-community/">In the Community</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="http://www.backsportspage.com/baseball-in-july-baseball-is-back/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/IMG_4286-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="Omaha Storm Chasers" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/IMG_4286-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/IMG_4286-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Baseball in July: Baseball is Back</a></li><li><a href="http://www.backsportspage.com/baseball-in-july-a-game-of-contrasts/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/0-e1625896187484-400x240.jpeg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="salt lake bees" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/0-e1625896187484-400x240.jpeg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/0-e1625896187484-1000x600.jpeg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Baseball in July: A Game of Contrasts</a></li><li><a href="http://www.backsportspage.com/baseball-in-july-an-endless-game-of-repeated-summers/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/06/5ef1342f432a0.image_-e1623044536367-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="Minor League Baseball" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/06/5ef1342f432a0.image_-e1623044536367-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/06/5ef1342f432a0.image_-e1623044536367-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Baseball in July: “An Endless Game of Repeated Summers”</a></li><li><a href="http://www.backsportspage.com/minor-league-baseball-in-the-mountains-no-more/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/05/GH8A8628-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="Minor League Baseball" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/05/GH8A8628-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/05/GH8A8628-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Minor League Baseball in the Mountains No More</a></li><li><a href="http://www.backsportspage.com/no-hate-tour-and-zenni-join-forces-for-high-school-anti-bullying-initiative/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-25-at-12.18.46-PM-800x445-1-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>No Hate Tour and Zenni Join Forces for High School Anti-Bullying Initiative</a></li></ul></div></div></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3939"><a href="http://www.backsportspage.com/category/features/community-events/">Community Events</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-698"><a href="http://www.backsportspage.com/category/features/question-of-the-day/">Question of the Day</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5726"><a href="http://www.backsportspage.com/category/features/the-rundown-with-tmoney/">The Rundown w/T-Money</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-325"><a href="http://www.backsportspage.com/category/features/the-transition/">The Transition</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="http://www.backsportspage.com/bsp-flashback-interview-brian-scalabrine/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2018/12/scalring_medium-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2018/12/scalring_medium-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2018/12/scalring_medium-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>BSP Flashback Interview Brian Scalabrine</a></li><li><a href="http://www.backsportspage.com/the-transition-chris-canty/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2017/07/Chris-Canty_Kay-Debate-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2017/07/Chris-Canty_Kay-Debate-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2017/07/Chris-Canty_Kay-Debate-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>The Transition: Chris Canty</a></li><li><a href="http://www.backsportspage.com/the-changing-uniforms-of-life/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2017/06/beasonweb14s-3-web-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>The Changing Uniforms Of Life</a></li><li><a href="http://www.backsportspage.com/the-transition-of-takeo-spikes/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2017/06/ESPNTheMagazinesNEXTEventENb5DXjCkP2x-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>The Transition of Takeo Spikes</a></li></ul></div></div></li>
</ul>
</li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-330"><a href="http://www.backsportspage.com/category/nfl/">NFL</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="http://www.backsportspage.com/dallas-cowboys-notable-offseason-losses/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/bengals-sign-chidobe-awuzie-three-year-deal-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/bengals-sign-chidobe-awuzie-three-year-deal-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/bengals-sign-chidobe-awuzie-three-year-deal-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Dallas Cowboys: Notable Offseason Losses</a></li><li><a href="http://www.backsportspage.com/can-dan-quinn-turn-the-cowboys-defense-around/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/USATSI_14955479-e1610413379359-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/USATSI_14955479-e1610413379359-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/USATSI_14955479-e1610413379359-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Can Dan Quinn Turn the Cowboys Defense Around?</a></li><li><a href="http://www.backsportspage.com/dallas-cowboys-key-offseason-additions-and-re-signings/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/UVCWODQRLFHCLAUIIO6U2HZ5T4-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/UVCWODQRLFHCLAUIIO6U2HZ5T4-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/UVCWODQRLFHCLAUIIO6U2HZ5T4-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Dallas Cowboys: Key Offseason Additions and Re-Signings</a></li><li><a href="http://www.backsportspage.com/how-dak-prescotts-return-will-impact-the-cowboys/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/usatsi_13397600-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/usatsi_13397600-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/usatsi_13397600-700x420.jpg 700w, http://www.backsportspage.com/wp-content/uploads/2021/07/usatsi_13397600-768x461.jpg 768w, http://www.backsportspage.com/wp-content/uploads/2021/07/usatsi_13397600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>How Dak Prescott&#8217;s Return will Impact the Cowboys</a></li><li><a href="http://www.backsportspage.com/big-blue-report-eli-manning-returns-to-the-giants-in-the-front-office/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/thumbnail_image002-1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>Big Blue Report: Eli Manning Returns To The Giants..In The Front Office</a></li></ul></div></div>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-770"><a href="http://www.backsportspage.com/category/features/big-blue-report/">Big Blue Report</a></li>
</ul>
</li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-326"><a href="http://www.backsportspage.com/category/mlb/">MLB</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="http://www.backsportspage.com/baseball-in-july-baseball-is-back/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/IMG_4286-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="Omaha Storm Chasers" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/IMG_4286-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/IMG_4286-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Baseball in July: Baseball is Back</a></li><li><a href="http://www.backsportspage.com/mlb-draft-day-is-here-expect-the-unexpected-tonight/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/GYI0060671459.0.0-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="MLB Draft" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/GYI0060671459.0.0-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/GYI0060671459.0.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>MLB Draft Day is Here: Expect the Unexpected Tonight</a></li><li><a href="http://www.backsportspage.com/baseball-in-july-a-game-of-contrasts/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/0-e1625896187484-400x240.jpeg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="salt lake bees" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/0-e1625896187484-400x240.jpeg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/0-e1625896187484-1000x600.jpeg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Baseball in July: A Game of Contrasts</a></li><li><a href="http://www.backsportspage.com/mlb-trade-deadline-sellers-buyers-and-whos-likely-getting-traded/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/Kris-Bryant-Chicago-Cubs-e1625895777278-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="Kris Bryant Chicago Cubs" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/Kris-Bryant-Chicago-Cubs-e1625895777278-400x240.png 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/Kris-Bryant-Chicago-Cubs-e1625895777278-1000x600.png 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>MLB Trade Deadline Sellers, Buyers, and Who&#8217;s Likely Getting Traded</a></li><li><a href="http://www.backsportspage.com/major-league-baseballs-all-star-pitching-staff-results-and-biggest-snubs/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/sptn_taijuan_walker_0310-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="Taijuan Walker New York Mets" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/sptn_taijuan_walker_0310-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/sptn_taijuan_walker_0310-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Major League Baseball&#8217;s All-Star Pitching Staff: Results and Biggest Snubs</a></li></ul></div></div></li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-328"><a href="http://www.backsportspage.com/category/nba/">NBA</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="http://www.backsportspage.com/what-constitutes-a-batman-versus-a-robin/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/April30_UND_PerkinsScreengrab000000_1280x720_1514946115563-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/April30_UND_PerkinsScreengrab000000_1280x720_1514946115563-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/April30_UND_PerkinsScreengrab000000_1280x720_1514946115563-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>What Constitutes a Batman versus a Robin?</a></li><li><a href="http://www.backsportspage.com/mikal-bridges-shines-in-game-two/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/Mikal-Bridges-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/Mikal-Bridges-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/Mikal-Bridges-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Mikal Bridges Shines in Game Two</a></li><li><a href="http://www.backsportspage.com/are-the-milwaukee-bucks-doomed-in-the-nba-finals/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/usa_today_16386338.0-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/usa_today_16386338.0-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/usa_today_16386338.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Are the Milwaukee Bucks Doomed in the NBA Finals?</a></li><li><a href="http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/Joel-Embiid-12-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>Where Do the 76ers Go From Here? Part 4: Joel Embiid</a></li><li><a href="http://www.backsportspage.com/adam-silver-cautiously-optimistic-as-nba-moves-forward/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/dae91d9c-087d-4195-9ff6-c37e2b14278e-USATSI_12175574-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/dae91d9c-087d-4195-9ff6-c37e2b14278e-USATSI_12175574-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/dae91d9c-087d-4195-9ff6-c37e2b14278e-USATSI_12175574-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Adam Silver Cautiously Optimistic as NBA Moves Forward</a></li></ul></div></div></li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-331"><a href="http://www.backsportspage.com/category/nhl/">NHL</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="http://www.backsportspage.com/despite-playoff-loss-the-toronto-maple-leafs-should-stay-the-course/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/06/cut-1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>Despite Playoff Loss, the Toronto Maple Leafs Should Stay the Course</a></li><li><a href="http://www.backsportspage.com/after-a-playoff-sweep-where-do-the-oilers-go-from-here/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/05/Connor-McDavid-Oilers-2-1200x880-1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/05/Connor-McDavid-Oilers-2-1200x880-1-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/05/Connor-McDavid-Oilers-2-1200x880-1-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>After a Playoff Sweep, Where Do the Oilers Go From Here?</a></li><li><a href="http://www.backsportspage.com/the-man-to-man-podcast-episode-xxvi-the-nba-is-so-back/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/04/thumbnail_Man2Man-video-screen-2-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/04/thumbnail_Man2Man-video-screen-2-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/04/thumbnail_Man2Man-video-screen-2-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>The Man to Man Podcast Episode XXVI: The NBA is BACK!</a></li><li><a href="http://www.backsportspage.com/nhl-playoff-preview-examining-the-first-round-matchups/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/05/cut-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>NHL Playoff Preview: Examining the First Round Matchups</a></li><li><a href="http://www.backsportspage.com/the-race-in-the-west-is-down-to-the-wire/"><div class="mvp-mega-img"></div>The Race in the West is Down to the Wire</a></li></ul></div></div>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4469"><a href="http://www.backsportspage.com/category/features/breaking-the-ice/">Breaking The Ice</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="http://www.backsportspage.com/category/other-sports/">•••</a>
<ul class="sub-menu">
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-327"><a href="http://www.backsportspage.com/category/mma/">MMA</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="http://www.backsportspage.com/ufc-261s-main-event-conundrum/"><div class="mvp-mega-img"></div>UFC 261’s Main Event Conundrum</a></li><li><a href="http://www.backsportspage.com/francis-ngannous-moment-is-here/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/03/francis-ngannou-predator-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/03/francis-ngannou-predator-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/03/francis-ngannou-predator-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Francis Ngannou’s Moment Is Here</a></li><li><a href="http://www.backsportspage.com/whats-next-for-israel-adesanya/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/03/israel-adesanya-ufc-234-3-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="What&#039;s Next for Israel Adesanya" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/03/israel-adesanya-ufc-234-3-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/03/israel-adesanya-ufc-234-3-700x420.jpg 700w, http://www.backsportspage.com/wp-content/uploads/2021/03/israel-adesanya-ufc-234-3-768x461.jpg 768w, http://www.backsportspage.com/wp-content/uploads/2021/03/israel-adesanya-ufc-234-3.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>What’s Next for Israel Adesanya?</a></li><li><a href="http://www.backsportspage.com/magomed-ankalaev-a-continued-rise/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/02/i-1-1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/02/i-1-1-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/02/i-1-1-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Magomed Ankalaev: A Continued Rise</a></li><li><a href="http://www.backsportspage.com/who-will-be-the-next-generational-athlete/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/02/untitled-design-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/02/untitled-design-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/02/untitled-design-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Speaking of Generational Coaches, Who Will Be the Next Generational Athlete?</a></li></ul></div></div></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-318"><a href="http://www.backsportspage.com/category/other-sports/soccer/">Soccer</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="http://www.backsportspage.com/denmark-continue-euros-cinderella-run/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/212031270_910401746174004_2680318705436965461_n-400x240.gif" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/212031270_910401746174004_2680318705436965461_n-400x240.gif 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/212031270_910401746174004_2680318705436965461_n-1000x600.gif 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Denmark Continue Euros Cinderella Run</a></li><li><a href="http://www.backsportspage.com/rising-stars-of-the-euro-2020-group-stage/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/06/alexander-isak-real-sociedad-2020-21_j0s8qt1r8w8szzy15u9axoom-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/06/alexander-isak-real-sociedad-2020-21_j0s8qt1r8w8szzy15u9axoom-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/06/alexander-isak-real-sociedad-2020-21_j0s8qt1r8w8szzy15u9axoom-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Rising Stars Of The Euro 2020 Group Stage</a></li><li><a href="http://www.backsportspage.com/how-eriksen-will-force-soccer-to-change-for-the-better/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/06/199548188_336116891379869_4079181178440909310_n-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/06/199548188_336116891379869_4079181178440909310_n-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/06/199548188_336116891379869_4079181178440909310_n-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>How Eriksen Will Force Soccer To Change For The Better</a></li><li><a href="http://www.backsportspage.com/examining-the-provisional-england-euro-2020-squad/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/05/192913145_329742425202932_9075708809724461537_n-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/05/192913145_329742425202932_9075708809724461537_n-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/05/192913145_329742425202932_9075708809724461537_n-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Examining The Provisional England Euro 2020 Squad</a></li><li><a href="http://www.backsportspage.com/the-man-to-man-podcast-episode-xxvii-trivia-bonanza/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/04/thumbnail_Man2Man-video-screen-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/04/thumbnail_Man2Man-video-screen-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/04/thumbnail_Man2Man-video-screen-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>The Man to Man Podcast Episode XXVII: Trivia Bonanza!</a></li></ul></div></div></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317"><a href="http://www.backsportspage.com/category/other-sports/golf/">Golf</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="http://www.backsportspage.com/2020-us-open-preview/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2020/09/usa_today_12872662.0-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2020/09/usa_today_12872662.0-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2020/09/usa_today_12872662.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>2020 US Open Preview</a></li><li><a href="http://www.backsportspage.com/tour-championship-preview/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2020/09/usatsi-12525902-webb-simpson-2019-masters-r3-1st-fairway-1400-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2020/09/usatsi-12525902-webb-simpson-2019-masters-r3-1st-fairway-1400-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2020/09/usatsi-12525902-webb-simpson-2019-masters-r3-1st-fairway-1400-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Tour Championship Preview</a></li></ul></div></div></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-319"><a href="http://www.backsportspage.com/category/other-sports/wwe/">WWE</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="http://www.backsportspage.com/5-wwe-releases-and-where-they-should-go/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/04/wrestlemania-samoa-joe-1165665-1280x0-1-400x240.jpeg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/04/wrestlemania-samoa-joe-1165665-1280x0-1-400x240.jpeg 400w, http://www.backsportspage.com/wp-content/uploads/2021/04/wrestlemania-samoa-joe-1165665-1280x0-1-1000x600.jpeg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>5 WWE Releases and Where They Should Go</a></li><li><a href="http://www.backsportspage.com/wwe-superstars-cameo-accounts-banned-by-mcmahon/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2020/10/45-12-1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2020/10/45-12-1-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2020/10/45-12-1-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Recent Banning Of WWE Superstar Cameo Accounts By COO Vince McMahon</a></li><li><a href="http://www.backsportspage.com/virtually-challenged-wrestling-promoter-tommy-fierro-piledriving-the-pandemic-through-virtual-signings/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2020/09/t120272594_1264565297215262_114900790179391510_n_1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>Virtually Challenged: Wrestling Promoter Tommy Fierro Piledriving the Pandemic Through Virtual Signings</a></li><li><a href="http://www.backsportspage.com/deep-6-wrestling-pocast-wwe-clash-of-champions-review/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2020/05/95897696_237106810873028_3997347399784726528_n-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>Deep 6 Wrestling Pocast: WWE Clash Of Champions Review</a></li><li><a href="http://www.backsportspage.com/off-topic-notes-from-the-anthony-carelli-interview/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2020/09/Santino_Marella_1920x1080-dba6128057796e51aae4dc2b849c966e.0.0-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2020/09/Santino_Marella_1920x1080-dba6128057796e51aae4dc2b849c966e.0.0-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2020/09/Santino_Marella_1920x1080-dba6128057796e51aae4dc2b849c966e.0.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Off Topic: Notes From The Anthony Carelli Interview</a></li></ul></div></div></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13816"><a href="http://www.backsportspage.com/category/features/wrestling/">Wrestling</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8497"><a href="http://www.backsportspage.com/category/features/wnba/">WNBA</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10684"><a href="http://www.backsportspage.com/category/features/aew-wrestling/">AEW Wrestling</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-329"><a href="http://www.backsportspage.com/category/ncaa/">NCAA</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="http://www.backsportspage.com/nba-mock-draft-picks-1-14-end-of-regular-season-edition/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/05/USATSI_15476645-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="USC&#039;s Evan Mobley" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/05/USATSI_15476645-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/05/USATSI_15476645-700x420.jpg 700w, http://www.backsportspage.com/wp-content/uploads/2021/05/USATSI_15476645-768x461.jpg 768w, http://www.backsportspage.com/wp-content/uploads/2021/05/USATSI_15476645.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>NBA Mock Draft (Picks 1-14): End of Regular Season Edition</a></li><li><a href="http://www.backsportspage.com/the-man-to-man-podcast-episode-xxvii-trivia-bonanza/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/04/thumbnail_Man2Man-video-screen-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/04/thumbnail_Man2Man-video-screen-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/04/thumbnail_Man2Man-video-screen-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>The Man to Man Podcast Episode XXVII: Trivia Bonanza!</a></li><li><a href="http://www.backsportspage.com/the-man-to-man-podcast-episode-xxvi-the-nba-is-so-back/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/04/thumbnail_Man2Man-video-screen-2-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/04/thumbnail_Man2Man-video-screen-2-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/04/thumbnail_Man2Man-video-screen-2-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>The Man to Man Podcast Episode XXVI: The NBA is BACK!</a></li><li><a href="http://www.backsportspage.com/the-man-to-man-podcast-episode-xxv-football-is-over-jai-alai-is-in/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/04/thumbnail_Man2Man-video-screen-2-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/04/thumbnail_Man2Man-video-screen-2-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/04/thumbnail_Man2Man-video-screen-2-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>The Man to Man Podcast Episode XXV: Football is Over, We&#8217;re On To Jai Alai</a></li><li><a href="http://www.backsportspage.com/the-man-to-man-podcast-episode-xxiv-the-boat-is-back/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/04/thumbnail_Man2Man-video-screen-2-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/04/thumbnail_Man2Man-video-screen-2-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/04/thumbnail_Man2Man-video-screen-2-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>The Man to Man Podcast Episode XXIV: The Boat Is Back!</a></li></ul></div></div></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7221"><a href="http://www.backsportspage.com/category/other-sports/xfl/">XFL</a></li>
</ul>
</li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1098"><a href="http://www.backsportspage.com/category/photos/">BSP Photos</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="http://www.backsportspage.com/xfl-opener-ny-guardians-vs-tampa-vipers-2-9-metlife-stadium/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2020/02/MAF8916-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2020/02/MAF8916-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2020/02/MAF8916-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>XFL Opener: NY Guardians VS Tampa Vipers 2/9-Metlife Stadium</a></li><li><a href="http://www.backsportspage.com/2017-giants-training-camp-photos/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2019/07/IMG_20161218_164603-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2019/07/IMG_20161218_164603-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2019/07/IMG_20161218_164603-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>2017 Giants Training Camp Photos</a></li><li><a href="http://www.backsportspage.com/2018-giants-training-camp-photos/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2019/07/20180726_163113-e1562934455443-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2019/07/20180726_163113-e1562934455443-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2019/07/20180726_163113-e1562934455443-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>2018 Giants Training Camp Photos</a></li><li><a href="http://www.backsportspage.com/ny-mets-6-vs-washington-nationals-5-4-6-19-2/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2019/04/MAF_9403-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2019/04/MAF_9403-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2019/04/MAF_9403-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>NY Mets (6) vs. Washington Nationals (5) &#8211; 4.6.19</a></li><li><a href="http://www.backsportspage.com/ny-mets-vs-atl-braves-8-4-18-2/"><div class="mvp-mega-img"><img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2018/08/MAF_7263-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2018/08/MAF_7263-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2018/08/MAF_7263-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>NY Mets vs. ATL Braves &#8211; 8.4.18</a></li></ul></div></div></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-346"><a href="http://www.backsportspage.com/bsp-writers/">BSP Writers</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-341"><a href="#mailmunch-pop-509941">Subscribe</a></li>
</ul></div>									</div><!--mvp-nav-menu-->
								</div><!--mvp-bot-nav-in-->
							</div><!--mvp-bot-nav-out-->
						</div><!--mvp-bot-nav-cont-->
					</div><!--mvp-main-box-cont-->
				</div><!--mvp-bot-nav-wrap-->
			</nav><!--mvp-main-nav-wrap-->
		</header>
		<main id="mvp-main-wrap" class="left relative">
						<div id="mvp-main-body-wrap" class="left relative">
				<div class="mvp-main-box-cont">
					<div id="mvp-main-body" class="left relative"><article id="mvp-article-wrap" class="post-22993 post type-post status-publish format-standard has-post-thumbnail hentry category-features category-nba tag-ben-simmons tag-doc-rivers tag-joel-embiid tag-philadelphia-76ers" itemscope itemtype="http://schema.org/NewsArticle">
		<div class="mvp-sec-pad left relative">
		<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/"/>
				<div id="mvp-article-head" class="left relative">
												<h3 class="mvp-post-cat left"><a class="mvp-post-cat-link" href="http://www.backsportspage.com/category/features/"><span class="mvp-post-cat left">Features</span></a></h3>
								<h1 class="mvp-post-title left entry-title" itemprop="headline">Where Do the 76ers Go From Here? Part 4: Joel Embiid</h1>
												<div class="mvp-author-info-wrap left relative">
					<ul class="mvp-author-info-list left relative">
						<li class="mvp-author-info-thumb">
							<img alt='' src='http://0.gravatar.com/avatar/3d22fbedaeedac2d1b0e37d3e2ba3ff2?s=46&#038;d=mm&#038;r=pg' srcset='http://0.gravatar.com/avatar/3d22fbedaeedac2d1b0e37d3e2ba3ff2?s=92&#038;d=mm&#038;r=pg 2x' class='avatar avatar-46 photo' height='46' width='46' loading='lazy'/>						</li>
						<li class="mvp-author-info-name" itemprop="author" itemscope itemtype="https://schema.org/Person">
							<p>by</p> <span class="author-name vcard fn author" itemprop="name"><a href="http://www.backsportspage.com/author/py_bsp/" title="Posts by Patrick Yen" rel="author">Patrick Yen</a></span>
						</li>
												<li class="mvp-author-info-date">
							<span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2021-07-09">July 9, 2021</time></span>
							<meta itemprop="dateModified" content="2021-07-11"/>
						</li>
					</ul>
				</div><!--mvp-author-info-wrap-->
									</div><!--mvp-article-head-->
				<div class="mvp-post-content-out relative">
			<div class="mvp-post-content-in">
									<div id="mvp-post-content" class="left relative">
																		<div class="mvp-content-box">
																										<div class="mvp-post-soc-out relative">
														<div id="mvp-post-soc-wrap" class="left relative">
								<ul class="mvp-post-soc-list left relative">
									<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/&amp;t=Where Do the 76ers Go From Here? Part 4: Joel Embiid', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
									<li class="mvp-post-soc-fb">
										<i class="fa fa-2 fa-facebook" aria-hidden="true"></i>
									</li>
									</a>
									<a href="#" onclick="window.open('http://twitter.com/share?text=Where Do the 76ers Go From Here? Part 4: Joel Embiid -&amp;url=http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
									<li class="mvp-post-soc-twit">
										<i class="fa fa-2 fa-twitter" aria-hidden="true"></i>
									</li>
									</a>
									<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/&amp;media=http://www.backsportspage.com/wp-content/uploads/2021/07/Joel-Embiid-12-1000x576.jpg&amp;description=Where Do the 76ers Go From Here? Part 4: Joel Embiid', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
									<li class="mvp-post-soc-pin">
										<i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i>
									</li>
									</a>
									<a href="mailto:?subject=Where Do the 76ers Go From Here? Part 4: Joel Embiid&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/">
									<li class="mvp-post-soc-email">
										<i class="fa fa-2 fa-envelope" aria-hidden="true"></i>
									</li>
									</a>
																														<a href="http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/#respond">
											<li class="mvp-post-soc-com mvp-com-click">
												<i class="fa fa-2 fa-commenting" aria-hidden="true"></i>
											</li>
											</a>
																											</ul>
							</div><!--mvp-post-soc-wrap-->
														<div class="mvp-post-soc-in">
																																<div id="mvp-content-main" class="left relative" itemprop="articleBody">
																																																							<div id="mvp-post-feat-img" class="left relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
														<img width="1024" height="576" src="http://www.backsportspage.com/wp-content/uploads/2021/07/Joel-Embiid-12.jpg" class="attachment- size- wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/Joel-Embiid-12.jpg 1024w, http://www.backsportspage.com/wp-content/uploads/2021/07/Joel-Embiid-12-700x394.jpg 700w, http://www.backsportspage.com/wp-content/uploads/2021/07/Joel-Embiid-12-768x432.jpg 768w" sizes="(max-width: 1024px) 100vw, 1024px" />																												<meta itemprop="url" content="http://www.backsportspage.com/wp-content/uploads/2021/07/Joel-Embiid-12-1000x576.jpg">
														<meta itemprop="width" content="1000">
														<meta itemprop="height" content="576">
													</div><!--mvp-post-feat-img-->
																																																																										<div class='mailmunch-forms-before-post' style='display: none !important;'></div><div id="tps_slideContainer_22993" class="theiaPostSlider_slides"><div class="theiaPostSlider_preloadedSlide">

<p><span style="font-weight: 400;">The final part of a series looking at the Philadelphia 76ers future. The <a href="http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-1-ben-simmons/">first part talked about Ben Simmons</a> and the fact that they need to move on from him. The <a href="http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-2-doc-rivers/">second part was on Doc Rivers</a>, who’s propensity to choke in playoff games is concerning, but ultimately the improvements the players made and the more obvious problems that caused the playoff loss are enough for Rivers to keep his job&#8230;for now. <a href="http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-3-tobias-harris/">The focus of the third part turned to Tobias Harris</a>. A few playoff games aside, Harris had a very good season, and he proved himself a viable third option for a playoff team. Even if they wanted to trade him, what could Harris realistically get? This final part will be on the last of the 76ers’ Big Three, Joel Embiid.</span></p>
<p>&nbsp;</p>
<h4><span style="font-weight: 400;">What Should the 76ers Do With Joel Embiid?</span></h4>
<p><span style="font-weight: 400;">The answer is obvious.  They’ll keep him and make a run for a championship for the duration of his prime. It’s what they should do and what they will do. This isn’t the end of the article though. Engage in a thought experiment with me, if you will. What if the 76ers deal Joel Embiid? The first question that immediately arises is, why would they trade an MVP level player in the prime of his career? There are a few reasons why they might trade him, but the biggest one, by far, is injuries.</span></p>
<p>&nbsp;</p>
<h4><span style="font-weight: 400;">Can He Stay Healthy?</span></h4>
<p><img src="https://sixerswire.usatoday.com/wp-content/uploads/sites/30/2021/05/JoJo-5.jpg?w=1000&amp;h=600&amp;crop=1" alt="Sixers star Joel Embiid will not return vs. Wizards with knee injury" /></p>
<p>Tommy Gilligan/USA TODAY Sports</p>
<p><span style="font-weight: 400;">Joel Embiid is injury prone. There’s not really any way around that. He’s missed around twenty games every season since he’s been in the league. He’s had multiple knee, leg and back problems, and as a 7’0 280 pound guy that’s troubling. People of that size don’t magically become less injury prone as they get older, and in fact it’s very possible these problems compound and get worse. </span></p>
<p><span style="font-weight: 400;">As we’ve seen this year, health is really the key to winning championships, and the chances that Joel Embiid is fully healthy for a full playoff run is slim to none. Even if he’s able to play, injuries will limit him, whether it’s his minutes, the way he has to play or his effectiveness, everything is impacted. Embiid playing on a partially torn meniscus might be the healthiest you can hope for him. To be fair, that is good enough against many teams, and it should have been enough against the Atlanta Hawks, but will it be good enough to win a championship? </span></p>
<p><span style="font-weight: 400;">Is Embiid’s health a gamble you want to make year after year? Maybe there’s a magical run where he never gets hurt and the 76ers win a championship, but there’s a lot of reason out there to doubt that ever happens. </span></p>
<p>&nbsp;</p>
<h4><span style="font-weight: 400;">Can Centers Win? </span></h4>
<p><span style="font-weight: 400;">Health is the biggest concern for Embiid and the 76ers’ championship hopes, no doubt about it. Other concerns do still exist however. Positions are nebulous, and Jalen Rose often says the traditional 1-5 was made up for fans to understand that game better. If we stay within those traditional confines though, when was the last time a team who’s best player was a center won a championship? One could easily argue for the Los Angeles Lakers with Anthony Davis, but he himself doesn’t seem to like that role, and I’d argue LeBron James is still their best player. Then before that, you had Kawhi Leonard and the Toronto Raptors, Stephen Curry or Kevin Durant for the Golden State Warriors, LeBron again and Curry again before we get to the San Antonio Spurs and Tim Duncan. </span></p>
<p><span style="font-weight: 400;">Duncan is often considered a power forward, but calling him a center is fine. Was he their best player though? Perhaps, but the Spurs were often a collaborative effort, with Tony Parker, Manu Ginobli and a young Kawhi Leonard contributing a similar amount as Duncan. Still, the bigs can have that one. If we go back a few more years, we have LeBron, Dirk Nowitzki and Kobe Bryant to round out the last decade of basketball. </span></p>
<p><span style="font-weight: 400;">In that time, only one championship team was led by a center, if you can even call it that. If you want to extend the category out to all big men, you could also include Dirk and the Dallas Mavericks in 2011, but he plays very differently from most big men. The point is, the game has changed to be very perimeter oriented, and it’s possible a team whose best player by far is a center simply cannot win anymore. </span></p>
<p>&nbsp;</p><div class='mailmunch-forms-in-post-middle' style='display: none !important;'></div>
<h4><span style="font-weight: 400;">Being a Center is Really Hard</span></h4>
<p><img src="https://bloximages.chicago2.vip.townnews.com/delcotimes.com/content/tncms/assets/v3/editorial/a/be/abe6fc24-6c63-11e9-86af-7f0713c78b6a/5cca23d0dd6be.image.jpg?crop=1652%2C1239%2C10%2C0&amp;resize=1652%2C1239&amp;order=crop%2Cresize" alt="Through double and triple teams, Joel Embiid content to help Sixers settle a score | Sports | delcotimes.com" /></p>
<p>Frank Gunn/Associated Press</p>
<p><span style="font-weight: 400;">Why can’t centers win anymore? It’s a valid question, but the NBA has seemingly moved past the post ups and that style of isolation ball. The modern NBA team basketball is all about pace and space, two things that centers don’t really participate in. Even when you go into isolation mode, which is still a big part of the game, it’s much harder to double a perimeter player in isolation than a post guy. Teams can send two, even three guys at Embiid, and finding players across the court from the post is much more difficult than doing it from the perimeter. </span></p>
<p><span style="font-weight: 400;">Perimeter players also get the benefit of being able to hunt for switches. With enough picks, a perimeter player can often get a much more favorable matchup. Look at how many times the Hawks were able to find Seth Curry and abuse him, or get Gallinari against someone like George Hill. Or how about the number of times Trae Young can get a screen and then get Ben Simmons or Matisse Thybulle on his back leading to easy foul shots, or force Joel Embiid to step up to him which leads to an easy lob. </span></p>
<p><span style="font-weight: 400;">Teams can also deny centers the ball much more easily than perimeter players. If Embiid gets the ball in his position down low, it’s almost an instant bucket. The problem is getting it there. Teams can go all out to deny the entry pass down low, which forces Embiid to go further and further out to receive the ball. This makes him settle for jumpers more often, or be forced to put the ball on the ground which leads to turnovers. Embiid averaged 4.7 turnovers per game against the Hawks, and had eight in game six and seven, <a href="https://streamable.com/lbz4yu">including the back breaker to Gallinari</a> in the dying embers of the final contest. </span></p>
<p><span style="font-weight: 400;">Finally, unless you have a once-in-a-lifetime passing talent like Nikola Jokic as your center, ball movement really suffers when you have a center as the focal point of your offense. Embiid got better at passing out the post, but it’s still not great, and the ball often gets stuck down there. It often feels like Embiid isn’t really a part of the offense. On any given offensive possession, it’s either the four guys besides Embiid do their thing, or the ball goes to Embiid and the other four stand around. That could be a failure of the coach to get Embiid involved, or a failure of the players around him to help Embiid, but there’s a disconnect somewhere. How often did John Collins and Clint Capela get easy buckets? Then think about how many easy buckets Embiid gets in a game. It’s close to zero, and every single basket he makes is a tough shot, or one he had to work incredibly hard for. </span></p>
<p><span style="font-weight: 400;">It doesn’t seem like a sustainable style of play, and when Embiid gets cold from the midrange and he can’t get his postups for one of the many reasons discussed already, the Sixers get very cold as well. </span></p>
<p>&nbsp;</p>
<h4><span style="font-weight: 400;">A Doctor Strange Future</span></h4>
<p><span style="font-weight: 400;">Realistically, Embiid isn’t going anywhere. For all the flaws mentioned, Embiid is one of the best players in the NBA, arguably THE best. He’s an offensive mismatch, able to take on anyone down low while also having a wet midrange jumper and a serviceable three point shot. He hits free throws at a fantastic clip, and he’s also a defensive force. Moving on from him when he’s just 27 would be ludicrous, especially coming off his best season and seeing all the improvements he has made over the years. If he played enough games he would’ve been the MVP for goodness sake. Who has ever heard of a team trading an MVP away? </span></p>
<p><span style="font-weight: 400;">That being said, Embiid’s value will never be higher than right now. With the haul they could get for Embiid, they can transform this team over night. There’s a future out there, one out of 14 million where the 76ers trade Embiid, realizing that he’s too injury prone, or that traditional centers like Embiid cannot be the best player on a championship team in today’s perimeter centric NBA. Instead of toiling for years with Embiid, always falling short in the playoffs because Embiid can’t play at 100%, they create a dynasty with the five unprotected first round picks and whatever star player they want. Instead of CJ McCollum from the Trailblazers, how about Damian Lillard, Norman Powell and Jusuf Nurkic with a boatload of picks? </span></p>
<p>&nbsp;</p>
<p><span style="font-weight: 400;">It won’t happen, and to be clear I’m not saying it should happen. Trading Embiid would be certifiably insane after the year he had. But What If?</span></p>

</div></div><div class="theiaPostSlider_footer _footer"></div><p><!-- END THEIA POST SLIDER --></p>
<div class='mailmunch-forms-after-post' style='display: none !important;'></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div><div data-theiaPostSlider-sliderOptions='{&quot;slideContainer&quot;:&quot;#tps_slideContainer_22993&quot;,&quot;nav&quot;:[&quot;.theiaPostSlider_nav&quot;],&quot;navText&quot;:&quot;%{currentSlide} of %{totalSlides}&quot;,&quot;helperText&quot;:&quot;Use your &amp;leftarrow; &amp;rightarrow; (arrow) keys to browse&quot;,&quot;defaultSlide&quot;:0,&quot;transitionEffect&quot;:&quot;slide&quot;,&quot;transitionSpeed&quot;:400,&quot;keyboardShortcuts&quot;:true,&quot;scrollAfterRefresh&quot;:true,&quot;numberOfSlides&quot;:1,&quot;slides&quot;:[],&quot;useSlideSources&quot;:null,&quot;themeType&quot;:&quot;font&quot;,&quot;prevText&quot;:&quot;Prev&quot;,&quot;nextText&quot;:&quot;Next&quot;,&quot;buttonWidth&quot;:0,&quot;buttonWidth_post&quot;:0,&quot;postUrl&quot;:&quot;http:\/\/www.backsportspage.com\/where-do-the-76ers-go-from-here-part-4-joel-embiid\/&quot;,&quot;postId&quot;:22993,&quot;refreshAds&quot;:false,&quot;refreshAdsEveryNSlides&quot;:1,&quot;adRefreshingMechanism&quot;:&quot;javascript&quot;,&quot;ajaxUrl&quot;:&quot;http:\/\/www.backsportspage.com\/wp-admin\/admin-ajax.php&quot;,&quot;loopSlides&quot;:false,&quot;scrollTopOffset&quot;:0,&quot;hideNavigationOnFirstSlide&quot;:false,&quot;isRtl&quot;:false,&quot;excludedWords&quot;:[&quot;&quot;],&quot;prevFontIcon&quot;:&quot;&lt;span aria-hidden=\&quot;true\&quot; class=\&quot;tps-icon-chevron-circle-left\&quot;&gt;&lt;\/span&gt;&quot;,&quot;nextFontIcon&quot;:&quot;&lt;span aria-hidden=\&quot;true\&quot; class=\&quot;tps-icon-chevron-circle-right\&quot;&gt;&lt;\/span&gt;&quot;}' 
					 data-theiaPostSlider-onChangeSlide='&quot;&quot;'></div>																																					<div class="mvp-post-tags">
											<span class="mvp-post-tags-header">Related Topics</span><span itemprop="keywords"><a href="http://www.backsportspage.com/tag/ben-simmons/" rel="tag">Ben Simmons</a><a href="http://www.backsportspage.com/tag/doc-rivers/" rel="tag">Doc Rivers</a><a href="http://www.backsportspage.com/tag/joel-embiid/" rel="tag">Joel Embiid</a><a href="http://www.backsportspage.com/tag/philadelphia-76ers/" rel="tag">Philadelphia 76ers</a></span>
										</div><!--mvp-post-tags-->
																		<div class="posts-nav-link">
																			</div><!--posts-nav-link-->
																		<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
										<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
																							<img src="http://www.backsportspage.com/wp-content/uploads/2017/06/logo-nav.png"/>
												<meta itemprop="url" content="http://www.backsportspage.com/wp-content/uploads/2017/06/logo-nav.png">
																					</div><!--mvp-org-logo-->
										<meta itemprop="name" content="Back Sports Page">
									</div><!--mvp-org-wrap-->
								</div><!--mvp-content-main-->
																																					<div id="mvp-comments-button" class="left relative mvp-com-click">
											<span class="mvp-comment-but-text">Click to comment</span>
										</div><!--mvp-comments-button-->
										<div id="comments">
				
	
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><h4 class="mvp-sec-head"><span class="mvp-sec-head">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/where-do-the-76ers-go-from-here-part-4-joel-embiid/#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://www.backsportspage.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='22993' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="565eac941c" /></p>
<noscript><input type="hidden" name="JS04X7" value="NS1" /></noscript>
<noscript><p><strong>Currently you have JavaScript disabled. In order to post comments, please make sure JavaScript and Cookies are enabled, and reload the page.</strong> <a href="http://enable-javascript.com/" rel="nofollow external" >Click here for instructions on how to enable JavaScript in your browser.</a></p></noscript>
<input type="hidden" id="ak_js" name="ak_js" value="83"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	
</div><!--comments-->																								</div><!--mvp-post-soc-in-->
						</div><!--mvp-post-soc-out-->
						</div><!--mvp-content-box-->
					</div><!--mvp-post-content-->
											</div><!--mvp-post-content-in-->
							<div id="mvp-side-wrap" class="relative">
						<section id="mvp_home_tagfeat_widget-2" class="mvp-side-widget mvp_home_tagfeat_widget">
					<h4 class="mvp-sec-head mvp-widget-feat-head"><span class="mvp-sec-head">Featured Articles</span></h4>
					<div class="mvp-widget-feat-wrap left relative">
				<ul class="mvp-widget-feat-list left relative">
											<li>
															<a href="http://www.backsportspage.com/what-constitutes-a-batman-versus-a-robin/" rel="bookmark">
								<div class="mvp-widget-feat-img left relative">
									<img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/April30_UND_PerkinsScreengrab000000_1280x720_1514946115563-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/April30_UND_PerkinsScreengrab000000_1280x720_1514946115563-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/April30_UND_PerkinsScreengrab000000_1280x720_1514946115563-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="http://www.backsportspage.com/wp-content/uploads/2021/07/April30_UND_PerkinsScreengrab000000_1280x720_1514946115563-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/April30_UND_PerkinsScreengrab000000_1280x720_1514946115563-80x80.jpg 80w, http://www.backsportspage.com/wp-content/uploads/2021/07/April30_UND_PerkinsScreengrab000000_1280x720_1514946115563-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-widget-feat-img-->
								</a>
														<div class="mvp-widget-feat-text left relative">
								<div class="mvp-post-info-top left relative">
									<h3><a href="http://www.backsportspage.com/category/nba/">NBA</a></h3><span class="mvp-post-info-date left relative">/ 2 mins ago</span>
								</div><!--mvp-post-info-top-->
								<h2><a href="http://www.backsportspage.com/what-constitutes-a-batman-versus-a-robin/" rel="bookmark">What Constitutes a Batman versus a Robin?</a></h2>
								<p>A lot has been made about what constitutes a “Batman” versus a “Robin” amongst...</p>
								<div class="mvp-blog-story-info left relative">
									<span class="mvp-blog-story-author left">By <a href="http://www.backsportspage.com/author/mm1_bsp/" title="Posts by Meyer McCaulsky" rel="author">Meyer McCaulsky</a></span>
								</div><!--mvp-blog-story-info-->
							</div><!--mvp-widget-feat-text-->
						</li>
											<li>
															<a href="http://www.backsportspage.com/mikal-bridges-shines-in-game-two/" rel="bookmark">
								<div class="mvp-widget-feat-img left relative">
									<img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/Mikal-Bridges-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/Mikal-Bridges-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/Mikal-Bridges-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="http://www.backsportspage.com/wp-content/uploads/2021/07/Mikal-Bridges-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/Mikal-Bridges-80x80.jpg 80w, http://www.backsportspage.com/wp-content/uploads/2021/07/Mikal-Bridges-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-widget-feat-img-->
								</a>
														<div class="mvp-widget-feat-text left relative">
								<div class="mvp-post-info-top left relative">
									<h3><a href="http://www.backsportspage.com/category/nba/">NBA</a></h3><span class="mvp-post-info-date left relative">/ 47 mins ago</span>
								</div><!--mvp-post-info-top-->
								<h2><a href="http://www.backsportspage.com/mikal-bridges-shines-in-game-two/" rel="bookmark">Mikal Bridges Shines in Game Two</a></h2>
								<p>In an always important Game Two in the NBA Finals, the Phoenix Suns defeated...</p>
								<div class="mvp-blog-story-info left relative">
									<span class="mvp-blog-story-author left">By <a href="http://www.backsportspage.com/author/jd_bsp/" title="Posts by James Dalpino" rel="author">James Dalpino</a></span>
								</div><!--mvp-blog-story-info-->
							</div><!--mvp-widget-feat-text-->
						</li>
											<li>
															<a href="http://www.backsportspage.com/are-the-milwaukee-bucks-doomed-in-the-nba-finals/" rel="bookmark">
								<div class="mvp-widget-feat-img left relative">
									<img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/usa_today_16386338.0-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/usa_today_16386338.0-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/usa_today_16386338.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="http://www.backsportspage.com/wp-content/uploads/2021/07/usa_today_16386338.0-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/usa_today_16386338.0-80x80.jpg 80w, http://www.backsportspage.com/wp-content/uploads/2021/07/usa_today_16386338.0-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-widget-feat-img-->
								</a>
														<div class="mvp-widget-feat-text left relative">
								<div class="mvp-post-info-top left relative">
									<h3><a href="http://www.backsportspage.com/category/nba/">NBA</a></h3><span class="mvp-post-info-date left relative">/ 2 hours ago</span>
								</div><!--mvp-post-info-top-->
								<h2><a href="http://www.backsportspage.com/are-the-milwaukee-bucks-doomed-in-the-nba-finals/" rel="bookmark">Are the Milwaukee Bucks Doomed in the NBA Finals?</a></h2>
								<p>The Milwaukee Bucks endured another gut punch on Thursday with a 118-108 loss to...</p>
								<div class="mvp-blog-story-info left relative">
									<span class="mvp-blog-story-author left">By <a href="http://www.backsportspage.com/author/cs1_bsp/" title="Posts by Caden Starnes" rel="author">Caden Starnes</a></span>
								</div><!--mvp-blog-story-info-->
							</div><!--mvp-widget-feat-text-->
						</li>
											<li>
															<a href="http://www.backsportspage.com/baseball-in-july-baseball-is-back/" rel="bookmark">
								<div class="mvp-widget-feat-img left relative">
									<img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/IMG_4286-400x240.jpg" class="mvp-reg-img wp-post-image" alt="Omaha Storm Chasers" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/IMG_4286-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/IMG_4286-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="http://www.backsportspage.com/wp-content/uploads/2021/07/IMG_4286-80x80.jpg" class="mvp-mob-img wp-post-image" alt="Omaha Storm Chasers" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/IMG_4286-80x80.jpg 80w, http://www.backsportspage.com/wp-content/uploads/2021/07/IMG_4286-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-widget-feat-img-->
								</a>
														<div class="mvp-widget-feat-text left relative">
								<div class="mvp-post-info-top left relative">
									<h3><a href="http://www.backsportspage.com/category/features/">Features</a></h3><span class="mvp-post-info-date left relative">/ 7 hours ago</span>
								</div><!--mvp-post-info-top-->
								<h2><a href="http://www.backsportspage.com/baseball-in-july-baseball-is-back/" rel="bookmark">Baseball in July: Baseball is Back</a></h2>
								<p>Omaha Storm Chasers vs. Toledo Mud Hens On July 9, the sun set on...</p>
								<div class="mvp-blog-story-info left relative">
									<span class="mvp-blog-story-author left">By <a href="http://www.backsportspage.com/author/gh_bsp/" title="Posts by Grace Hansen" rel="author">Grace Hansen</a></span>
								</div><!--mvp-blog-story-info-->
							</div><!--mvp-widget-feat-text-->
						</li>
									</ul>
			</div><!--mvp-widget-feat-wrap-->

		</section><section id="mvp_authors_widget-3" class="mvp-side-widget mvp_authors_widget"><h4 class="mvp-sec-head"><span class="mvp-sec-head">Featured Writers</span></h4>
		<div class="mvp-widget-authors-wrap left relative">
							<div class="mvp-widget-author left relative">
					<div class="mvp-100img-out right relative">
						<div class="mvp-widget-author-img left relative">
							<img alt='' src='http://0.gravatar.com/avatar/f8fe62a4dc78c486e142fcf85c650d2b?s=100&#038;d=mm&#038;r=pg' srcset='http://0.gravatar.com/avatar/f8fe62a4dc78c486e142fcf85c650d2b?s=200&#038;d=mm&#038;r=pg 2x' class='avatar avatar-100 photo' height='100' width='100' loading='lazy'/>						</div><!--mvp-widget-author-img-->
						<div class="mvp-100img-in">
							<div class="mvp-widget-author-text left relative">
																	<h3><a href="http://www.backsportspage.com/author/rzellea/">Randy Zellea</a></h3>
									<h2><a href="http://www.backsportspage.com/big-blue-report-eli-manning-returns-to-the-giants-in-the-front-office/" rel="bookmark">Big Blue Report: Eli Manning Returns To The Giants..In The Front Office</a></h2>
															</div><!--mvp-widget-author-text-->
						</div><!--mvp-100img-in-->
					</div><!--mvp-100img-out-->
				</div><!--mvp-widget-author-->
							<div class="mvp-widget-author left relative">
					<div class="mvp-100img-out right relative">
						<div class="mvp-widget-author-img left relative">
							<img alt='' src='http://1.gravatar.com/avatar/467fba54a9a347aa869150cb49b4531c?s=100&#038;d=mm&#038;r=pg' srcset='http://1.gravatar.com/avatar/467fba54a9a347aa869150cb49b4531c?s=200&#038;d=mm&#038;r=pg 2x' class='avatar avatar-100 photo' height='100' width='100' loading='lazy'/>						</div><!--mvp-widget-author-img-->
						<div class="mvp-100img-in">
							<div class="mvp-widget-author-text left relative">
																	<h3><a href="http://www.backsportspage.com/author/jb3_bsp/">Justin Brownlow</a></h3>
									<h2><a href="http://www.backsportspage.com/he-man-to-man-podcast-episode-xxxii-the-process-is-finished/" rel="bookmark">The Man To Man Podcast Episode XXXII: The Process Is Finished</a></h2>
															</div><!--mvp-widget-author-text-->
						</div><!--mvp-100img-in-->
					</div><!--mvp-100img-out-->
				</div><!--mvp-widget-author-->
							<div class="mvp-widget-author left relative">
					<div class="mvp-100img-out right relative">
						<div class="mvp-widget-author-img left relative">
							<img alt='' src='http://2.gravatar.com/avatar/8095b7c7fc24cdc9d92a34691c0034d3?s=100&#038;d=mm&#038;r=pg' srcset='http://2.gravatar.com/avatar/8095b7c7fc24cdc9d92a34691c0034d3?s=200&#038;d=mm&#038;r=pg 2x' class='avatar avatar-100 photo' height='100' width='100' loading='lazy'/>						</div><!--mvp-widget-author-img-->
						<div class="mvp-100img-in">
							<div class="mvp-widget-author-text left relative">
																	<h3><a href="http://www.backsportspage.com/author/tmoney/">Tracy Graven</a></h3>
									<h2><a href="http://www.backsportspage.com/2x-most-valuable-not-valuable-enough/" rel="bookmark">2x Most Valuable Not Valuable Enough</a></h2>
															</div><!--mvp-widget-author-text-->
						</div><!--mvp-100img-in-->
					</div><!--mvp-100img-out-->
				</div><!--mvp-widget-author-->
							<div class="mvp-widget-author left relative">
					<div class="mvp-100img-out right relative">
						<div class="mvp-widget-author-img left relative">
							<img alt='' src='http://0.gravatar.com/avatar/0459ce4c628ae728ebfe2f028e65015b?s=100&#038;d=mm&#038;r=pg' srcset='http://0.gravatar.com/avatar/0459ce4c628ae728ebfe2f028e65015b?s=200&#038;d=mm&#038;r=pg 2x' class='avatar avatar-100 photo' height='100' width='100' loading='lazy'/>						</div><!--mvp-widget-author-img-->
						<div class="mvp-100img-in">
							<div class="mvp-widget-author-text left relative">
																	<h3><a href="http://www.backsportspage.com/author/rt_bsp/">Ryan Truland</a></h3>
									<h2><a href="http://www.backsportspage.com/ufc-258-miranda-maverick-interview/" rel="bookmark">UFC 258 – Miranda Maverick Interview</a></h2>
															</div><!--mvp-widget-author-text-->
						</div><!--mvp-100img-in-->
					</div><!--mvp-100img-out-->
				</div><!--mvp-widget-author-->
							<div class="mvp-widget-author left relative">
					<div class="mvp-100img-out right relative">
						<div class="mvp-widget-author-img left relative">
							<img alt='' src='http://2.gravatar.com/avatar/eaf1153516f59832e8656b36432de512?s=100&#038;d=mm&#038;r=pg' srcset='http://2.gravatar.com/avatar/eaf1153516f59832e8656b36432de512?s=200&#038;d=mm&#038;r=pg 2x' class='avatar avatar-100 photo' height='100' width='100' loading='lazy'/>						</div><!--mvp-widget-author-img-->
						<div class="mvp-100img-in">
							<div class="mvp-widget-author-text left relative">
																	<h3><a href="http://www.backsportspage.com/author/jz1_bsp/">Jesse Zaragoza</a></h3>
									<h2><a href="http://www.backsportspage.com/one-stop-7-7/" rel="bookmark">One Stop: 7/7</a></h2>
															</div><!--mvp-widget-author-text-->
						</div><!--mvp-100img-in-->
					</div><!--mvp-100img-out-->
				</div><!--mvp-widget-author-->
					</div><!--mvp-widget-authors-wrap-->

		</section>			</div><!--mvp-side-wrap-->					</div><!--mvp-post-content-out-->
							<section id="mvp-more-post-wrap" class="left relative">
				<h4 class="mvp-sec-head"><span class="mvp-sec-head">More in Features</span></h4>
				<ul class="mvp-more-post-list left relative">
											<li>
															<a href="http://www.backsportspage.com/baseball-in-july-baseball-is-back/" rel="bookmark">
								<div class="mvp-more-post-img left relative">
									<img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/IMG_4286-400x240.jpg" class="mvp-reg-img wp-post-image" alt="Omaha Storm Chasers" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/IMG_4286-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/IMG_4286-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="http://www.backsportspage.com/wp-content/uploads/2021/07/IMG_4286-80x80.jpg" class="mvp-mob-img wp-post-image" alt="Omaha Storm Chasers" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/IMG_4286-80x80.jpg 80w, http://www.backsportspage.com/wp-content/uploads/2021/07/IMG_4286-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-more-post-img-->
								</a>
														<div class="mvp-more-post-text left relative">
								<h2><a href="http://www.backsportspage.com/baseball-in-july-baseball-is-back/" rel="bookmark">Baseball in July: Baseball is Back</a></h2>
								<p>Omaha Storm Chasers vs. Toledo Mud Hens On July 9, the sun set on...</p>
							</div><!--mvp-more-post-text-->
						</li>
											<li>
															<a href="http://www.backsportspage.com/baseball-in-july-a-game-of-contrasts/" rel="bookmark">
								<div class="mvp-more-post-img left relative">
									<img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/0-e1625896187484-400x240.jpeg" class="mvp-reg-img wp-post-image" alt="salt lake bees" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/0-e1625896187484-400x240.jpeg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/0-e1625896187484-1000x600.jpeg 1000w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="http://www.backsportspage.com/wp-content/uploads/2021/07/0-e1625896187484-80x80.jpeg" class="mvp-mob-img wp-post-image" alt="salt lake bees" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/0-e1625896187484-80x80.jpeg 80w, http://www.backsportspage.com/wp-content/uploads/2021/07/0-e1625896187484-150x150.jpeg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-more-post-img-->
								</a>
														<div class="mvp-more-post-text left relative">
								<h2><a href="http://www.backsportspage.com/baseball-in-july-a-game-of-contrasts/" rel="bookmark">Baseball in July: A Game of Contrasts</a></h2>
								<p>Salt Lake City Bees vs. Sacramento Rivercats Salt Lake City, much like the game...</p>
							</div><!--mvp-more-post-text-->
						</li>
											<li>
															<a href="http://www.backsportspage.com/2x-most-valuable-not-valuable-enough/" rel="bookmark">
								<div class="mvp-more-post-img left relative">
									<img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/ant-gassed-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" />									<img width="80" height="80" src="http://www.backsportspage.com/wp-content/uploads/2021/07/ant-gassed-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/ant-gassed-80x80.jpg 80w, http://www.backsportspage.com/wp-content/uploads/2021/07/ant-gassed-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-more-post-img-->
								</a>
														<div class="mvp-more-post-text left relative">
								<h2><a href="http://www.backsportspage.com/2x-most-valuable-not-valuable-enough/" rel="bookmark">2x Most Valuable Not Valuable Enough</a></h2>
								<p>The Milwaukee Bucks now have to win four of the next five games …...</p>
							</div><!--mvp-more-post-text-->
						</li>
											<li>
															<a href="http://www.backsportspage.com/kemba-for-kuz-good-or-bad/" rel="bookmark">
								<div class="mvp-more-post-img left relative">
									<img width="400" height="240" src="http://www.backsportspage.com/wp-content/uploads/2021/07/12-1-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/12-1-400x240.jpg 400w, http://www.backsportspage.com/wp-content/uploads/2021/07/12-1-700x420.jpg 700w, http://www.backsportspage.com/wp-content/uploads/2021/07/12-1-768x461.jpg 768w, http://www.backsportspage.com/wp-content/uploads/2021/07/12-1.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="http://www.backsportspage.com/wp-content/uploads/2021/07/12-1-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2021/07/12-1-80x80.jpg 80w, http://www.backsportspage.com/wp-content/uploads/2021/07/12-1-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-more-post-img-->
								</a>
														<div class="mvp-more-post-text left relative">
								<h2><a href="http://www.backsportspage.com/kemba-for-kuz-good-or-bad/" rel="bookmark">Kemba for Kuz: Good or Bad?</a></h2>
								<p>Kemba Walker to LA, is that something that will get LeBron, AD and the...</p>
							</div><!--mvp-more-post-text-->
						</li>
									</ul>
			</section><!--mvp-more-post-wrap-->
											<div id="mvp-prev-next-wrap">
									<div id="mvp-prev-post-wrap">
						<div id="mvp-prev-post-arrow" class="relative">
							<span class="fa fa-angle-left fa-4" aria-hidden="true"></span>
						</div><!--mvp-prev-post-arrow-->
						<div class="mvp-prev-next-text">
							<a href="http://www.backsportspage.com/adam-silver-cautiously-optimistic-as-nba-moves-forward/" rel="prev">Adam Silver Cautiously Optimistic as NBA Moves Forward</a>						</div><!--mvp-prev-post-text-->
					</div><!--mvp-prev-post-wrap-->
													<div id="mvp-next-post-wrap">
						<div id="mvp-next-post-arrow" class="relative">
							<span class="fa fa-angle-right fa-4 " aria-hidden="true"></span>
						</div><!--mvp-prev-post-arrow-->
						<div class="mvp-prev-next-text">
							<a href="http://www.backsportspage.com/baseball-in-july-a-game-of-contrasts/" rel="next">Baseball in July: A Game of Contrasts</a>						</div><!--mvp-prev-next-text-->
					</div><!--mvp-next-post-wrap-->
							</div><!--mvp-prev-next-wrap-->
					</div><!--mvp-sec-pad-->
</article><!--mvp-article-wrap-->
				</div><!--mvp-main-body-->
			</div><!--mvp-main-box-cont-->
		</div><!--mvp-main-body-wrap-->
	</main><!--mvp-main-wrap-->
		<footer id="mvp-foot-wrap" class="left relative">
		<div id="mvp-foot-top" class="left relative">
			<div class="mvp-main-box-cont">
				<div id="mvp-foot-logo" class="left relative">
											<a href="http://www.backsportspage.com/"><img src="http://www.backsportspage.com/wp-content/uploads/2017/06/logo-footer.png" alt="Back Sports Page" data-rjs="2" /></a>
									</div><!--mvp-foot-logo-->
				<div id="mvp-foot-soc" class="left relative">
					<ul class="mvp-foot-soc-list left relative">
														<li><a href="https://www.facebook.com/backsportspage" target="_blank" class="fa fa-facebook-official fa-2"></a></li>
																			<li><a href="https://twitter.com/BackSportsPage" target="_blank" class="fa fa-twitter fa-2"></a></li>
																									<li><a href="https://www.instagram.com/backsportspage/" target="_blank" class="fa fa-instagram fa-2"></a></li>
																									<li><a href="https://www.youtube.com/user/BackSportsPage" target="_blank" class="fa fa-youtube-play fa-2"></a></li>
																							</ul>
				</div><!--mvp-foot-soc-->
			</div><!--mvp-main-box-cont-->
		</div><!--mvp-foot-top-->
		<div id="mvp-foot-bot" class="left relative">
			<div id="mvp-foot-menu-wrap" class="left relative">
				<div class="mvp-main-box-cont">
					<div id="mvp-foot-menu" class="left relative">
						<div class="menu-primary-menu-container"><ul id="menu-primary-menu-2" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-389"><a href="http://www.backsportspage.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-333"><a href="http://www.backsportspage.com/category/web-shows/">Web Shows</a>
<ul class="sub-menu">
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-337"><a href="http://www.backsportspage.com/category/web-shows/seth-and-sean-sports/">Seth and Sean Sports</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-336"><a href="http://www.backsportspage.com/category/web-shows/off-topic/">Off Topic</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5143"><a href="http://www.backsportspage.com/category/web-shows/hardwood-huddle/">Hardwood Huddle</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13815"><a href="http://www.backsportspage.com/category/web-shows/4th-and-long/">4th And Long</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13485"><a href="http://www.backsportspage.com/category/web-shows/the-cut/">The Cut</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8917"><a href="http://www.backsportspage.com/category/web-shows/exit-velo/">Exit Velo</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8919"><a href="http://www.backsportspage.com/category/web-shows/ear-to-canvas/">Ear To Canvas</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5144"><a href="http://www.backsportspage.com/category/web-shows/zero-technique-podcast/">Zero Technique Podcast</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8926"><a href="http://www.backsportspage.com/category/web-shows/the-trifecta/">The Trifecta</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20325"><a href="http://www.backsportspage.com/category/web-shows/man-to-man-podcast/">Man To Man Podcast</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8558"><a href="http://www.backsportspage.com/category/web-shows/deep-6-podcast/">Deep 6 Podcast</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20326"><a href="http://www.backsportspage.com/category/web-shows/under-the-hoodies/">Under The Hoodies</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-320"><a href="http://www.backsportspage.com/category/features/">Features</a>
<ul class="sub-menu">
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-321"><a href="http://www.backsportspage.com/category/features/beyond-the-athlete/">Beyond the Athlete</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-322"><a href="http://www.backsportspage.com/category/features/book-reviews/">Book Reviews</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-323"><a href="http://www.backsportspage.com/category/features/in-the-business/">In the Business</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-324"><a href="http://www.backsportspage.com/category/features/in-the-community/">In the Community</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3939"><a href="http://www.backsportspage.com/category/features/community-events/">Community Events</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-698"><a href="http://www.backsportspage.com/category/features/question-of-the-day/">Question of the Day</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5726"><a href="http://www.backsportspage.com/category/features/the-rundown-with-tmoney/">The Rundown w/T-Money</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-325"><a href="http://www.backsportspage.com/category/features/the-transition/">The Transition</a></li>
</ul>
</li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-330"><a href="http://www.backsportspage.com/category/nfl/">NFL</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-770"><a href="http://www.backsportspage.com/category/features/big-blue-report/">Big Blue Report</a></li>
</ul>
</li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-326"><a href="http://www.backsportspage.com/category/mlb/">MLB</a></li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-328"><a href="http://www.backsportspage.com/category/nba/">NBA</a></li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-331"><a href="http://www.backsportspage.com/category/nhl/">NHL</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4469"><a href="http://www.backsportspage.com/category/features/breaking-the-ice/">Breaking The Ice</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="http://www.backsportspage.com/category/other-sports/">•••</a>
<ul class="sub-menu">
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-327"><a href="http://www.backsportspage.com/category/mma/">MMA</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-318"><a href="http://www.backsportspage.com/category/other-sports/soccer/">Soccer</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317"><a href="http://www.backsportspage.com/category/other-sports/golf/">Golf</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-319"><a href="http://www.backsportspage.com/category/other-sports/wwe/">WWE</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13816"><a href="http://www.backsportspage.com/category/features/wrestling/">Wrestling</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8497"><a href="http://www.backsportspage.com/category/features/wnba/">WNBA</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10684"><a href="http://www.backsportspage.com/category/features/aew-wrestling/">AEW Wrestling</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-329"><a href="http://www.backsportspage.com/category/ncaa/">NCAA</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7221"><a href="http://www.backsportspage.com/category/other-sports/xfl/">XFL</a></li>
</ul>
</li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1098"><a href="http://www.backsportspage.com/category/photos/">BSP Photos</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-346"><a href="http://www.backsportspage.com/bsp-writers/">BSP Writers</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-341"><a href="#mailmunch-pop-509941">Subscribe</a></li>
</ul></div>					</div><!--mvp-foot-menu-->
				</div><!--mvp-main-box-cont-->
			</div><!--mvp-foot-menu-wrap-->
			<div id="mvp-foot-copy-wrap" class="left relative">
				<div class="mvp-main-box-cont">
					<div id="mvp-foot-copy" class="left relative">
						<p>Copyright © 2017 Back Sports Page, All rights reserved.</br>
Web design by Pixel Fisch Creative Solutions.</p>
					</div><!--mvp-foot-copy-->
				</div><!--mvp-main-box-cont-->
			</div><!--mvp-foot-copy-wrap-->
		</div><!--mvp-foot-bot-->
	</footer>
				<div id="mvp-mob-soc-wrap" class="left relative">
			<span class="mvp-mob-soc-share-but fa fa-share fa-2 mvp-mob-soc-click" aria-hidden="true"></span>
			<ul class="mvp-mob-soc-list left relative">
				<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/&amp;t=Where Do the 76ers Go From Here? Part 4: Joel Embiid', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
				<li class="mvp-mob-soc-fb">
					<i class="fa fa-2 fa-facebook" aria-hidden="true"></i>
				</li>
				</a>
				<a href="#" onclick="window.open('http://twitter.com/share?text=Where Do the 76ers Go From Here? Part 4: Joel Embiid -&amp;url=http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
				<li class="mvp-mob-soc-twit">
					<i class="fa fa-2 fa-twitter" aria-hidden="true"></i>
				</li>
				</a>
				<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/&amp;media=http://www.backsportspage.com/wp-content/uploads/2021/07/Joel-Embiid-12-1000x576.jpg&amp;description=Where Do the 76ers Go From Here? Part 4: Joel Embiid', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
				<li class="mvp-mob-soc-pin">
					<i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i>
				</li>
				</a>
				<a href="mailto:?subject=Where Do the 76ers Go From Here? Part 4: Joel Embiid&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: http://www.backsportspage.com/where-do-the-76ers-go-from-here-part-4-joel-embiid/">
				<li class="mvp-mob-soc-email">
					<i class="fa fa-2 fa-envelope" aria-hidden="true"></i>
				</li>
				</a>
			</ul>
		</div><!--mvp-post-soc-wrap-->
		</div><!--mvp-site-->
												<div id="mvp-post-trend-wrap">
						<div class="mvp-main-box-cont relative">
							<ul class="mvp-post-trend-list left relative">
																	<li>
										<div class="mvp-post-trend-out relative">
																							<div class="mvp-post-trend-img left relative">
													<a href="http://www.backsportspage.com/klay-thompson-achilles-injury-insight/" rel="bookmark">
														<div class="mvp-trend-widget-img left relative">
															<img width="80" height="80" src="http://www.backsportspage.com/wp-content/uploads/2020/11/usa_today_11494157.0-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2020/11/usa_today_11494157.0-80x80.jpg 80w, http://www.backsportspage.com/wp-content/uploads/2020/11/usa_today_11494157.0-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />														</div><!--mvp-trend-widget-img-->
													</a>
												</div><!--mvp-post-trend-img-->
																						<div class="mvp-post-trend-in">
												<div class="mvp-post-trend-text left relative">
													<h3>NBA</h3>
													<a href="http://www.backsportspage.com/klay-thompson-achilles-injury-insight/" rel="bookmark">Klay Thompson Achilles&#8217; Injury Insight</a>
												</div><!--mvp-post-trend-text-->
											</div><!--mvp-post-trend-in-->
										</div><!--mvp-post-trend-out-->
									</li>
																	<li>
										<div class="mvp-post-trend-out relative">
																							<div class="mvp-post-trend-img left relative">
													<a href="http://www.backsportspage.com/the-boys-discuss-buffetts-vegas-vs-atlantic-city-and-tracey-murrey-joins-the-show/" rel="bookmark">
														<div class="mvp-trend-widget-img left relative">
															<img width="80" height="80" src="http://www.backsportspage.com/wp-content/uploads/2017/06/tracey_murrey-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2017/06/tracey_murrey-80x80.jpg 80w, http://www.backsportspage.com/wp-content/uploads/2017/06/tracey_murrey-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />														</div><!--mvp-trend-widget-img-->
													</a>
												</div><!--mvp-post-trend-img-->
																						<div class="mvp-post-trend-in">
												<div class="mvp-post-trend-text left relative">
													<h3>NBA</h3>
													<a href="http://www.backsportspage.com/the-boys-discuss-buffetts-vegas-vs-atlantic-city-and-tracey-murrey-joins-the-show/" rel="bookmark">Tracy Murray Joins Off Topic</a>
												</div><!--mvp-post-trend-text-->
											</div><!--mvp-post-trend-in-->
										</div><!--mvp-post-trend-out-->
									</li>
																	<li>
										<div class="mvp-post-trend-out relative">
																							<div class="mvp-post-trend-img left relative">
													<a href="http://www.backsportspage.com/r-truth-and-carmella-discuss-working-with-unicef-during-wrestlemania-week/" rel="bookmark">
														<div class="mvp-trend-widget-img left relative">
															<img width="80" height="80" src="http://www.backsportspage.com/wp-content/uploads/2019/04/thumbnail_IMG_1440-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2019/04/thumbnail_IMG_1440-80x80.jpg 80w, http://www.backsportspage.com/wp-content/uploads/2019/04/thumbnail_IMG_1440-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />														</div><!--mvp-trend-widget-img-->
													</a>
												</div><!--mvp-post-trend-img-->
																						<div class="mvp-post-trend-in">
												<div class="mvp-post-trend-text left relative">
													<h3>Community Events</h3>
													<a href="http://www.backsportspage.com/r-truth-and-carmella-discuss-working-with-unicef-during-wrestlemania-week/" rel="bookmark">R-Truth and Carmella Discuss Working With UNICEF During Wrestlemania Week</a>
												</div><!--mvp-post-trend-text-->
											</div><!--mvp-post-trend-in-->
										</div><!--mvp-post-trend-out-->
									</li>
																	<li>
										<div class="mvp-post-trend-out relative">
																							<div class="mvp-post-trend-img left relative">
													<a href="http://www.backsportspage.com/jared-greenberg-and-his-path-to-sports-broadcasting-success/" rel="bookmark">
														<div class="mvp-trend-widget-img left relative">
															<img width="80" height="80" src="http://www.backsportspage.com/wp-content/uploads/2017/06/Jared_greenberg-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" loading="lazy" srcset="http://www.backsportspage.com/wp-content/uploads/2017/06/Jared_greenberg-80x80.jpg 80w, http://www.backsportspage.com/wp-content/uploads/2017/06/Jared_greenberg-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />														</div><!--mvp-trend-widget-img-->
													</a>
												</div><!--mvp-post-trend-img-->
																						<div class="mvp-post-trend-in">
												<div class="mvp-post-trend-text left relative">
													<h3>In the Business</h3>
													<a href="http://www.backsportspage.com/jared-greenberg-and-his-path-to-sports-broadcasting-success/" rel="bookmark">Jared Greenberg And His Path To Sports Broadcasting Success</a>
												</div><!--mvp-post-trend-text-->
											</div><!--mvp-post-trend-in-->
										</div><!--mvp-post-trend-out-->
									</li>
															</ul>
							<span class="mvp-post-trend-but fa fa-angle-down mvp-post-trend-but-click" aria-hidden="true"></span>
						</div><!--mvp-main-box-cont-->
					</div><!--mvp-post-trend-wrap-->
							<div class="mvp-fly-top back-to-top">
	<i class="fa fa-angle-up fa-3"></i>
</div><!--mvp-fly-top-->
<div class="mvp-fly-fade mvp-fly-but-click">
</div><!--mvp-fly-fade-->
		<div data-theiaStickySidebar-sidebarSelector='"#secondary, #sidebar, .sidebar, #primary"'
		     data-theiaStickySidebar-options='{"containerSelector":"","additionalMarginTop":0,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
		
<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf4N='bbd4480ed8f040a348f0caa82a0f2bb3';
hf4V='3ed123cc5b8594cdacac851ff42c7077';
cm4S="form[action='http://www.backsportspage.com/wp-comments-post.php']";
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, "+cm4S+", #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(e);return true;});$("#comment").attr({minlength:"15",maxlength:"15360"})});
/* ]]> */
</script> 
<!-- YouTube Feed JS -->
<script type="text/javascript">

</script>
	<div style="display:none">
	<div class="grofile-hash-map-7845848b543e7ffffd797ec7fbd0ea17">
	</div>
	<div class="grofile-hash-map-f8fe62a4dc78c486e142fcf85c650d2b">
	</div>
	<div class="grofile-hash-map-467fba54a9a347aa869150cb49b4531c">
	</div>
	<div class="grofile-hash-map-8095b7c7fc24cdc9d92a34691c0034d3">
	</div>
	<div class="grofile-hash-map-0459ce4c628ae728ebfe2f028e65015b">
	</div>
	<div class="grofile-hash-map-eaf1153516f59832e8656b36432de512">
	</div>
	</div>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/plugins/mvp-scoreboard/js/score-script.js?ver=5.7.2' id='mvp-score-script-js'></script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/plugins/theia-sticky-sidebar/js/ResizeSensor.js?ver=1.7.0' id='theia-sticky-sidebar/ResizeSensor.js-js'></script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.7.0' id='theia-sticky-sidebar/theia-sticky-sidebar.js-js'></script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.7.0' id='theia-sticky-sidebar/main.js-js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=202127' id='grofiles-cards-js'></script>
<script type='text/javascript' id='wpgroho-js-extra'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=9.9' id='wpgroho-js'></script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/themes/the-league/js/mvpcustom.js?ver=5.7.2' id='mvp-custom-js'></script>
<script type='text/javascript' id='mvp-custom-js-after'>

	jQuery(document).ready(function($) {
	$(window).load(function(){
	var aboveHeight = $("#mvp-top-head-wrap").outerHeight();
	$(window).scroll(function(event){
	    	if ($(window).scrollTop() > aboveHeight){
	    		$("#mvp-top-head-wrap").addClass("mvp-score-up");
			$("#mvp-wallpaper").addClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").addClass("mvp-post-trend-down");
			$(".mvp-fly-top").addClass("mvp-to-top");
	    	} else {
	    		$("#mvp-top-head-wrap").removeClass("mvp-score-up");
			$("#mvp-wallpaper").removeClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").removeClass("mvp-post-trend-down");
	    		$(".mvp-fly-top").removeClass("mvp-to-top");
	    	}
	});
	});
	});
	

	jQuery(document).ready(function($) {
	// Main Menu Dropdown Toggle
	$(".menu-item-has-children a").click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$(".menu-item-has-children").click(function(){
    	  $(this).addClass("toggled");
    	  if($(".menu-item-has-children").hasClass("toggled"))
    	  {
    	  $(this).children("ul").toggle();
	  $(".mvp-fly-nav-menu").getNiceScroll().resize();
	  }
	  $(this).toggleClass("tog-minus");
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $(".mvp-fly-nav-menu").niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});
	});
	

	jQuery(document).ready(function($) {
	$(".infinite-content").infinitescroll({
	  navSelector: ".mvp-nav-links",
	  nextSelector: ".mvp-nav-links a:first",
	  itemSelector: ".infinite-post",
	  errorCallback: function(){ $(".mvp-inf-more-but").css("display", "none") }
	});
	$(window).unbind(".infscr");
	$(".mvp-inf-more-but").click(function(){
   		$(".infinite-content").infinitescroll("retrieve");
        	return false;
	});
	$(window).load(function(){
		if ($(".mvp-nav-links a").length) {
			$(".mvp-inf-more-but").css("display","inline-block");
		} else {
			$(".mvp-inf-more-but").css("display","none");
		}
	});
	});
	
</script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/themes/the-league/js/scripts.js?ver=5.7.2' id='clickmag-js'></script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/themes/the-league/js/retina.js?ver=5.7.2' id='retina-js'></script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/plugins/js_composer/assets/lib/bower/flexslider/jquery.flexslider-min.js?ver=5.1.1' id='flexslider-js'></script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/themes/the-league/js/jquery.infinitescroll.min.js?ver=5.7.2' id='infinitescroll-js'></script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-includes/js/comment-reply.min.js?ver=5.7.2' id='comment-reply-js'></script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/plugins/wp-spamshield/js/jscripts-ftr-min.js' id='wpss-jscripts-ftr-js'></script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.backsportspage.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20210604' id='jetpack_related-posts-js'></script>
<script defer type='text/javascript' src='http://www.backsportspage.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.10' id='akismet-form-js'></script>
<script src='https://stats.wp.com/e-202127.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.9',blog:'161203849',post:'22993',tz:'-4',srv:'www.backsportspage.com'} ]);
	_stq.push([ 'clickTrackerInit', '161203849', '22993' ]);
</script>
</body>
<script>'undefined'=== typeof _trfq || (window._trfq = []);'undefined'=== typeof _trfd && (window._trfd=[]),_trfd.push({'tccl.baseHost':'secureserver.net'}),_trfd.push({'ap':'cpbh'},{'server':'a2plvcpnl218830'}) // Monitoring performance to make your website faster. If you want to opt-out, please contact web hosting support.</script><script src='https://img1.wsimg.com/tcc/tcc_l.combined.1.0.6.min.js'></script></html>