<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<link rel="shortcut icon" href="http://www.backsportspage.com/wp-content/uploads/2017/06/logo-nav_FavIcon1.png" /><link rel="pingback" href="https://www.backsportspage.com/xmlrpc.php" />
<meta property="og:image" content="https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-1000x600.jpg" />
<meta name="twitter:image" content="https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-1000x600.jpg" />
<meta property="og:type" content="article" />
<meta property="og:description" content="One Tough Out: Fighting Off Life’s Curveballs by Rod Carew with Jaime Aron offers a rich and insightful look at the Hall of Famer’s career, family tragedy, philanthropy, and how he overcame adversity. The seven-time batting champion made baseball look “easy” as he was a consistent top-of-the-order hitter with the Minnesota Twins and California Angels. [&hellip;]" />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="https://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/">
<meta name="twitter:title" content="Rod Carew Shares Triumphs And Adversities In His Autobiography">
<meta name="twitter:description" content="One Tough Out: Fighting Off Life’s Curveballs by Rod Carew with Jaime Aron offers a rich and insightful look at the Hall of Famer’s career, family tragedy, philanthropy, and how he overcame adversity. The seven-time batting champion made baseball look “easy” as he was a consistent top-of-the-order hitter with the Minnesota Twins and California Angels. [&hellip;]">
<!-- Jetpack Site Verification Tags -->

	<!-- This site is optimized with the Yoast SEO plugin v15.5 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Rod Carew shares triumphs and adversities in his autobiography</title>
	<meta name="description" content="One Tough Out: Fighting Off Life’s Curveballs by Rod Carew with Jaime Aron offers a rich and insightful look at the Hall of Famer’s career, family tragedy, philanthropy, and how he overcame adversity. The seven-time batting champion made baseball look “easy” as he was a consistent top-of-the-order hitter with the Minnesota Twins and California Angels. Off the field, however, Carew dealt with his fair share of demons." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="http://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Rod Carew shares triumphs and adversities in his autobiography" />
	<meta property="og:description" content="One Tough Out: Fighting Off Life’s Curveballs by Rod Carew with Jaime Aron offers a rich and insightful look at the Hall of Famer’s career, family tragedy, philanthropy, and how he overcame adversity. The seven-time batting champion made baseball look “easy” as he was a consistent top-of-the-order hitter with the Minnesota Twins and California Angels. Off the field, however, Carew dealt with his fair share of demons." />
	<meta property="og:url" content="http://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/" />
	<meta property="og:site_name" content="Back Sports Page" />
	<meta property="article:published_time" content="2020-12-28T16:46:06+00:00" />
	<meta property="article:modified_time" content="2020-12-28T19:17:21+00:00" />
	<meta property="og:image" content="https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth.jpg" />
	<meta property="og:image:width" content="1222" />
	<meta property="og:image:height" content="813" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:title" content="Rod Carew shares triumphs and adversities in his autobiography" />
	<meta name="twitter:description" content="One Tough Out: Fighting Off Life’s Curveballs by Rod Carew with Jaime Aron offers a rich and insightful look at the Hall of Famer’s career, family tragedy, philanthropy, and how he overcame adversity. The seven-time batting champion made baseball look “easy” as he was a consistent top-of-the-order hitter with the Minnesota Twins and California Angels. Off the field, however, Carew dealt with his fair share of demons." />
	<meta name="twitter:image" content="https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth.jpg" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Adam Cohen">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="3 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.backsportspage.com/#website","url":"https://www.backsportspage.com/","name":"Back Sports Page","description":"Sports Beyond the Game","potentialAction":[{"@type":"SearchAction","target":"https://www.backsportspage.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en"},{"@type":"ImageObject","@id":"http://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/#primaryimage","inLanguage":"en","url":"https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth.jpg","width":1222,"height":813},{"@type":"WebPage","@id":"http://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/#webpage","url":"http://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/","name":"Rod Carew shares triumphs and adversities in his autobiography","isPartOf":{"@id":"https://www.backsportspage.com/#website"},"primaryImageOfPage":{"@id":"http://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/#primaryimage"},"datePublished":"2020-12-28T16:46:06+00:00","dateModified":"2020-12-28T19:17:21+00:00","author":{"@id":"https://www.backsportspage.com/#/schema/person/68be49271f84bf2a06c53554ecf9d605"},"description":"One Tough Out: Fighting Off Life\u2019s Curveballs by Rod Carew with Jaime Aron offers a rich and insightful look at the Hall of Famer\u2019s career, family tragedy, philanthropy, and how he overcame adversity. The seven-time batting champion made baseball look \u201ceasy\u201d as he was a consistent top-of-the-order hitter with the Minnesota Twins and California Angels. Off the field, however, Carew dealt with his fair share of demons.","inLanguage":"en","potentialAction":[{"@type":"ReadAction","target":["http://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/"]}]},{"@type":"Person","@id":"https://www.backsportspage.com/#/schema/person/68be49271f84bf2a06c53554ecf9d605","name":"Adam Cohen","image":{"@type":"ImageObject","@id":"https://www.backsportspage.com/#personlogo","inLanguage":"en","url":"https://secure.gravatar.com/avatar/07b888ffd11d9348c672e4eb9fbe7129?s=96&d=mm&r=pg","caption":"Adam Cohen"},"sameAs":["http://www.backsportspage.com"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Back Sports Page &raquo; Feed" href="https://www.backsportspage.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Back Sports Page &raquo; Comments Feed" href="https://www.backsportspage.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Back Sports Page &raquo; Rod Carew Shares Triumphs And Adversities In His Autobiography Comments Feed" href="https://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.backsportspage.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.backsportspage.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='liveblog24_live_blogging_tool-cgb-style-css-css'  href='https://www.backsportspage.com/wp-content/plugins/24liveblog/dist/blocks.style.build.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-components-css'  href='https://www.backsportspage.com/wp-includes/css/dist/components/style.min.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='wp-editor-font-css'  href='https://fonts.googleapis.com/css?family=Noto+Serif%3A400%2C400i%2C700%2C700i&#038;ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-editor-css'  href='https://www.backsportspage.com/wp-includes/css/dist/block-editor/style.min.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='wp-nux-css'  href='https://www.backsportspage.com/wp-includes/css/dist/nux/style.min.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='wp-editor-css'  href='https://www.backsportspage.com/wp-includes/css/dist/editor/style.min.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='blocks-ape-gallery-style-css-css'  href='https://www.backsportspage.com/wp-content/plugins/gallery-images-ape/modules/block/dist/blocks.style.build.css?ver=2.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.backsportspage.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/font-awesome.min.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='ctf_styles-css'  href='https://www.backsportspage.com/wp-content/plugins/custom-twitter-feeds/css/ctf-styles.min.css?ver=1.7' type='text/css' media='all' />
<link rel='stylesheet' id='photoblocks-css'  href='https://www.backsportspage.com/wp-content/plugins/photoblocks-grid-gallery/public/css/photoblocks-public.css?ver=1.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='tp_twitter_plugin_css-css'  href='https://www.backsportspage.com/wp-content/plugins/recent-tweets-widget/tp_twitter_plugin.css?ver=1.0' type='text/css' media='screen' />
<link rel='stylesheet' id='theiaPostSlider-css'  href='https://www.backsportspage.com/wp-content/plugins/theia-post-slider/css/font-theme.css?ver=1.14.0' type='text/css' media='all' />
<style id='theiaPostSlider-inline-css' type='text/css'>


				.theiaPostSlider_nav.fontTheme ._title,
				.theiaPostSlider_nav.fontTheme ._text {
					line-height: 48px;
				}
	
				.theiaPostSlider_nav.fontTheme ._button {
					color: #f08100;
				}
	
				.theiaPostSlider_nav.fontTheme ._button ._2 span {
					font-size: 48px;
					line-height: 48px;
				}
	
				.theiaPostSlider_nav.fontTheme ._button:hover,
				.theiaPostSlider_nav.fontTheme ._button:focus {
					color: #ffa338;
				}
	
				.theiaPostSlider_nav.fontTheme ._disabled {
					color: #777777 !important;
				}
			
</style>
<link rel='stylesheet' id='theiaPostSlider-font-css'  href='https://www.backsportspage.com/wp-content/plugins/theia-post-slider/fonts/style.css?ver=1.14.0' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-custom-style-css'  href='https://www.backsportspage.com/wp-content/themes/the-league/style.css?ver=5.6' type='text/css' media='all' />
<style id='mvp-custom-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='mvp-reset-css'  href='https://www.backsportspage.com/wp-content/themes/the-league/css/reset.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://www.backsportspage.com/wp-content/themes/the-league/font-awesome/css/font-awesome.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-fonts-css'  href='//fonts.googleapis.com/css?family=Advent+Pro%3A700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7COswald%3A300%2C400%2C700%7CLato%3A300%2C400%2C700%7CWork+Sans%3A200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COpen+Sans%3A400%2C700%2C800%7CRoboto+Condensed%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-media-queries-css'  href='https://www.backsportspage.com/wp-content/themes/the-league/css/media-queries.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='__EPYT__style-css'  href='https://www.backsportspage.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=13.4.1.2' type='text/css' media='all' />
<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.backsportspage.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.2.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.backsportspage.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20191011' id='jetpack_related-posts-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/plugins/photoblocks-grid-gallery/public/js/anime.min.js?ver=1.2.2' id='anime-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/plugins/photoblocks-grid-gallery/public/js/packery.pkgd.js?ver=5.6' id='packery-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/plugins/photoblocks-grid-gallery/public/js/photoblocks.public.js?ver=1.2.2' id='photoblocks-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/plugins/theia-post-slider/js/balupton-history.js/jquery.history.js?ver=1.7.1' id='history.js-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/plugins/theia-post-slider/js/async.min.js?ver=14.09.2014' id='async.js-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/plugins/theia-post-slider/js/tps.js?ver=1.14.0' id='theiaPostSlider/theiaPostSlider.js-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/plugins/theia-post-slider/js/main.js?ver=1.14.0' id='theiaPostSlider/main.js-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/plugins/theia-post-slider/js/tps-transition-slide.js?ver=1.14.0' id='theiaPostSlider/transition.js-js'></script>
<script type='text/javascript' id='__ytprefs__-js-extra'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"https:\/\/www.backsportspage.com\/wp-admin\/admin-ajax.php","security":"989d13406a","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/www.backsportspage.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","eppath":"https:\/\/www.backsportspage.com\/wp-content\/plugins\/youtube-embed-plus\/","epresponsiveselector":"[\"iframe.__youtube_prefs_widget__\"]","epdovol":"1","version":"13.4.1.2","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","pause_others":"","stopMobileBuffer":"1","vi_active":"","vi_js_posttypes":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=13.4.1.2' id='__ytprefs__-js'></script>
<link rel="https://api.w.org/" href="https://www.backsportspage.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.backsportspage.com/wp-json/wp/v2/posts/15917" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.backsportspage.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.backsportspage.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6" />
<link rel='shortlink' href='https://wp.me/paUou5-48J' />
<link rel="alternate" type="application/json+oembed" href="https://www.backsportspage.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.backsportspage.com%2Frod-carew-shares-triumphs-and-adversities-in-his-autobiography%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.backsportspage.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.backsportspage.com%2Frod-carew-shares-triumphs-and-adversities-in-his-autobiography%2F&#038;format=xml" />
<script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":15917,"post_name":"rod-carew-shares-triumphs-and-adversities-in-his-autobiography","post_title":"Rod Carew Shares Triumphs And Adversities In His Autobiography","post_type":"post","post_author":"57","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":9,"name":"Book Reviews","slug":"book-reviews","term_group":0,"term_taxonomy_id":9,"taxonomy":"category","description":"","parent":4,"count":14,"filter":"raw","cat_ID":9,"category_count":14,"category_description":"","cat_name":"Book Reviews","category_nicename":"book-reviews","category_parent":4},{"term_id":4,"name":"Features","slug":"features","term_group":0,"term_taxonomy_id":4,"taxonomy":"category","description":"","parent":0,"count":676,"filter":"raw","cat_ID":4,"category_count":676,"category_description":"","cat_name":"Features","category_nicename":"features","category_parent":0},{"term_id":18,"name":"MLB","slug":"mlb","term_group":0,"term_taxonomy_id":18,"taxonomy":"category","description":"","parent":0,"count":239,"filter":"raw","cat_ID":18,"category_count":239,"category_description":"","cat_name":"MLB","category_nicename":"mlb","category_parent":0}]; _mmunch['postTags'] = [{"term_id":37,"name":"Baseball","slug":"baseball","term_group":0,"term_taxonomy_id":37,"taxonomy":"post_tag","description":"","parent":0,"count":76,"filter":"raw"},{"term_id":3881,"name":"Billy Martin","slug":"billy-martin","term_group":0,"term_taxonomy_id":3881,"taxonomy":"post_tag","description":"","parent":0,"count":1,"filter":"raw"},{"term_id":150,"name":"Book Reviews","slug":"book-reviews","term_group":0,"term_taxonomy_id":150,"taxonomy":"post_tag","description":"","parent":0,"count":4,"filter":"raw"},{"term_id":3880,"name":"California Angels","slug":"california-angels","term_group":0,"term_taxonomy_id":3880,"taxonomy":"post_tag","description":"","parent":0,"count":1,"filter":"raw"},{"term_id":62,"name":"Featured","slug":"featured","term_group":0,"term_taxonomy_id":62,"taxonomy":"post_tag","description":"","parent":0,"count":1521,"filter":"raw"},{"term_id":3841,"name":"Featured MLB","slug":"featured-mlb","term_group":0,"term_taxonomy_id":3841,"taxonomy":"post_tag","description":"","parent":0,"count":4,"filter":"raw"},{"term_id":3884,"name":"Harmon Killebrew","slug":"harmon-killebrew","term_group":0,"term_taxonomy_id":3884,"taxonomy":"post_tag","description":"","parent":0,"count":1,"filter":"raw"},{"term_id":1378,"name":"Minnesota Twins","slug":"minnesota-twins","term_group":0,"term_taxonomy_id":1378,"taxonomy":"post_tag","description":"","parent":0,"count":4,"filter":"raw"},{"term_id":40,"name":"MLB","slug":"mlb","term_group":0,"term_taxonomy_id":40,"taxonomy":"post_tag","description":"","parent":0,"count":159,"filter":"raw"},{"term_id":3879,"name":"Rod Carew","slug":"rod-carew","term_group":0,"term_taxonomy_id":3879,"taxonomy":"post_tag","description":"","parent":0,"count":1,"filter":"raw"},{"term_id":3883,"name":"Tony Oliva","slug":"tony-oliva","term_group":0,"term_taxonomy_id":3883,"taxonomy":"post_tag","description":"","parent":0,"count":1,"filter":"raw"}]; _mmunch['postAuthor'] = {"name":"Adam Cohen","ID":57};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="mailmunch" data-mailmunch-site-id="390713" async></script><style>.post-thumbnail img[src$='.svg'] { width: 100%; height: auto; }</style><script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//www.backsportspage.com/?wordfence_lh=1&hid=45131551DB9339AA461EE76C18D61B9E');
</script><style type='text/css'>img#wpstats{display:none}</style><meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.backsportspage.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #dcdcdc; }
</style>
				<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://www.backsportspage.com/?custom-css=de2c845fc6" />
		<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/plugins/wp-spamshield/js/jscripts.php'></script> 
</head>
<body class="post-template-default single single-post postid-15917 single-format-standard custom-background theiaPostSlider_body wpb-js-composer js-comp-ver-5.1.1 vc_responsive">
	<div id="mvp-fly-wrap">
	<div id="mvp-fly-menu-top" class="left relative">
		<div class="mvp-fly-top-out left relative">
			<div class="mvp-fly-top-in">
				<div id="mvp-fly-logo" class="left relative">
											<a href="https://www.backsportspage.com/"><img src="http://www.backsportspage.com/wp-content/uploads/2017/06/logo-nav.png" alt="Back Sports Page" data-rjs="2" /></a>
									</div><!--mvp-fly-logo-->
			</div><!--mvp-fly-top-in-->
			<div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click">
				<span></span>
				<span></span>
				<span></span>
				<span></span>
			</div><!--mvp-fly-but-wrap-->
		</div><!--mvp-fly-top-out-->
	</div><!--mvp-fly-menu-top-->
	<div id="mvp-fly-menu-wrap">
		<nav class="mvp-fly-nav-menu left relative">
			<div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li id="menu-item-389" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-389"><a href="https://www.backsportspage.com/">Home</a></li>
<li id="menu-item-333" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-333"><a href="https://www.backsportspage.com/category/web-shows/">Web Shows</a>
<ul class="sub-menu">
	<li id="menu-item-336" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-336"><a href="https://www.backsportspage.com/category/web-shows/off-topic/">Off Topic</a></li>
	<li id="menu-item-337" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-337"><a href="https://www.backsportspage.com/category/web-shows/seth-and-sean-sports/">Seth and Sean Sports</a></li>
	<li id="menu-item-3938" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3938"><a href="https://www.backsportspage.com/category/web-shows/weekend-recap/">The Weekend Recap</a></li>
	<li id="menu-item-5143" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5143"><a href="https://www.backsportspage.com/category/web-shows/hardwood-huddle/">Hardwood Huddle</a></li>
	<li id="menu-item-334" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334"><a href="https://www.backsportspage.com/category/web-shows/60-minute-overtime/">60 Minute Overtime</a></li>
	<li id="menu-item-13815" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13815"><a href="https://www.backsportspage.com/category/web-shows/4th-and-long/">4th And Long</a></li>
	<li id="menu-item-335" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-335"><a href="https://www.backsportspage.com/category/web-shows/new-york-groove/">New York Groove</a></li>
	<li id="menu-item-4865" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4865"><a href="https://www.backsportspage.com/category/web-shows/the-back-check/">The Back Check</a></li>
	<li id="menu-item-13485" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13485"><a href="https://www.backsportspage.com/category/web-shows/the-cut/">The Cut</a></li>
	<li id="menu-item-8917" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8917"><a href="https://www.backsportspage.com/category/web-shows/exit-velo/">Exit Velo</a></li>
	<li id="menu-item-4204" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4204"><a href="https://www.backsportspage.com/category/web-shows/the-wind-up/">The Wind Up</a></li>
	<li id="menu-item-8919" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8919"><a href="https://www.backsportspage.com/category/web-shows/ear-to-canvas/">Ear To Canvas</a></li>
	<li id="menu-item-5144" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5144"><a href="https://www.backsportspage.com/category/web-shows/zero-technique-podcast/">Zero Technique Podcast</a></li>
	<li id="menu-item-338" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-338"><a href="https://www.backsportspage.com/category/web-shows/thats-what-she-said-sports/">Thats What She Said Sports</a></li>
	<li id="menu-item-8926" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8926"><a href="https://www.backsportspage.com/category/web-shows/the-trifecta/">The Trifecta</a></li>
	<li id="menu-item-8558" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8558"><a href="https://www.backsportspage.com/category/web-shows/deep-6-podcast/">Deep 6 Podcast</a></li>
</ul>
</li>
<li id="menu-item-320" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-320"><a href="https://www.backsportspage.com/category/features/">Features</a>
<ul class="sub-menu">
	<li id="menu-item-321" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-321"><a href="https://www.backsportspage.com/category/features/beyond-the-athlete/">Beyond the Athlete</a></li>
	<li id="menu-item-322" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-322"><a href="https://www.backsportspage.com/category/features/book-reviews/">Book Reviews</a></li>
	<li id="menu-item-323" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-323"><a href="https://www.backsportspage.com/category/features/in-the-business/">In the Business</a></li>
	<li id="menu-item-324" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-324"><a href="https://www.backsportspage.com/category/features/in-the-community/">In the Community</a></li>
	<li id="menu-item-3939" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3939"><a href="https://www.backsportspage.com/category/features/community-events/">Community Events</a></li>
	<li id="menu-item-698" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-698"><a href="https://www.backsportspage.com/category/features/question-of-the-day/">Question of the Day</a></li>
	<li id="menu-item-5726" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5726"><a href="https://www.backsportspage.com/category/features/the-rundown-with-tmoney/">The Rundown w/T-Money</a></li>
	<li id="menu-item-325" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-325"><a href="https://www.backsportspage.com/category/features/the-transition/">The Transition</a></li>
</ul>
</li>
<li id="menu-item-330" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-330"><a href="https://www.backsportspage.com/category/nfl/">NFL</a>
<ul class="sub-menu">
	<li id="menu-item-770" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-770"><a href="https://www.backsportspage.com/category/features/big-blue-report/">Big Blue Report</a></li>
</ul>
</li>
<li id="menu-item-326" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-326"><a href="https://www.backsportspage.com/category/mlb/">MLB</a></li>
<li id="menu-item-328" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-328"><a href="https://www.backsportspage.com/category/nba/">NBA</a></li>
<li id="menu-item-331" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-331"><a href="https://www.backsportspage.com/category/nhl/">NHL</a>
<ul class="sub-menu">
	<li id="menu-item-4469" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4469"><a href="https://www.backsportspage.com/category/features/breaking-the-ice/">Breaking The Ice</a></li>
</ul>
</li>
<li id="menu-item-316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="https://www.backsportspage.com/category/other-sports/">•••</a>
<ul class="sub-menu">
	<li id="menu-item-327" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-327"><a href="https://www.backsportspage.com/category/mma/">MMA</a></li>
	<li id="menu-item-318" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-318"><a href="https://www.backsportspage.com/category/other-sports/soccer/">Soccer</a></li>
	<li id="menu-item-317" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317"><a href="https://www.backsportspage.com/category/other-sports/golf/">Golf</a></li>
	<li id="menu-item-319" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-319"><a href="https://www.backsportspage.com/category/other-sports/wwe/">WWE</a></li>
	<li id="menu-item-13816" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13816"><a href="https://www.backsportspage.com/category/features/wrestling/">Wrestling</a></li>
	<li id="menu-item-8497" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8497"><a href="https://www.backsportspage.com/category/features/wnba/">WNBA</a></li>
	<li id="menu-item-10684" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10684"><a href="https://www.backsportspage.com/category/features/aew-wrestling/">AEW Wrestling</a></li>
	<li id="menu-item-329" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-329"><a href="https://www.backsportspage.com/category/ncaa/">NCAA</a></li>
	<li id="menu-item-7221" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7221"><a href="https://www.backsportspage.com/category/other-sports/xfl/">XFL</a></li>
</ul>
</li>
<li id="menu-item-1098" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1098"><a href="https://www.backsportspage.com/category/photos/">BSP Photos</a></li>
<li id="menu-item-346" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-346"><a href="https://www.backsportspage.com/bsp-writers/">BSP Writers</a></li>
<li id="menu-item-341" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-341"><a href="#mailmunch-pop-509941">Subscribe</a></li>
</ul></div>		</nav>
	</div><!--mvp-fly-menu-wrap-->
	<div id="mvp-fly-soc-wrap">
		<span class="mvp-fly-soc-head">Connect with us</span>
		<ul class="mvp-fly-soc-list left relative">
							<li><a href="https://www.facebook.com/backsportspage" target="_blank" class="fa fa-facebook-official fa-2"></a></li>
										<li><a href="https://twitter.com/BackSportsPage" target="_blank" class="fa fa-twitter fa-2"></a></li>
													<li><a href="https://www.instagram.com/backsportspage/" target="_blank" class="fa fa-instagram fa-2"></a></li>
													<li><a href="https://www.youtube.com/user/BackSportsPage" target="_blank" class="fa fa-youtube-play fa-2"></a></li>
											</ul>
	</div><!--mvp-fly-soc-wrap-->
</div><!--mvp-fly-wrap-->				<div id="mvp-site" class="left relative">
		<div id="mvp-search-wrap">
			<div id="mvp-search-box">
				<form method="get" id="searchform" action="https://www.backsportspage.com/">
	<input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>			</div><!--mvp-search-box-->
			<div class="mvp-search-but-wrap mvp-search-click">
				<span></span>
				<span></span>
			</div><!--mvp-search-but-wrap-->
		</div><!--mvp-search-wrap-->
		<header id="mvp-top-head-wrap">
													<nav id="mvp-main-nav-wrap">
				<div id="mvp-top-nav-wrap" class="left relative">
					<div class="mvp-main-box-cont">
						<div id="mvp-top-nav-cont" class="left relative">
							<div class="mvp-top-nav-right-out relative">
								<div class="mvp-top-nav-right-in">
									<div id="mvp-top-nav-left" class="left relative">
										<div class="mvp-top-nav-left-out relative">
											<div class="mvp-top-nav-menu-but left relative">
												<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
													<span></span>
													<span></span>
													<span></span>
													<span></span>
												</div><!--mvp-fly-but-wrap-->
											</div><!--mvp-top-nav-menu-but-->
											<div class="mvp-top-nav-left-in">
												<div id="mvp-top-nav-logo" class="left relative" itemscope itemtype="http://schema.org/Organization">
																											<a itemprop="url" href="https://www.backsportspage.com/"><img itemprop="logo" src="http://www.backsportspage.com/wp-content/uploads/2017/06/logo-nav.png" alt="Back Sports Page" data-rjs="2" /></a>
																																								<h2 class="mvp-logo-title">Back Sports Page</h2>
																									</div><!--mvp-top-nav-logo-->
																							</div><!--mvp-top-nav-left-in-->
										</div><!--mvp-top-nav-left-out-->
									</div><!--mvp-top-nav-left-->
								</div><!--mvp-top-nav-right-in-->
								<div id="mvp-top-nav-right" class="right relative">
																		<div id="mvp-top-nav-soc" class="left relative">
																					<a href="https://www.youtube.com/user/BackSportsPage" target="_blank"><span class="mvp-nav-soc-but fa fa-youtube fa-2"></span></a>
																															<a href="https://www.instagram.com/backsportspage/" target="_blank"><span class="mvp-nav-soc-but fa fa-instagram fa-2"></span></a>
																															<a href="https://twitter.com/BackSportsPage" target="_blank"><span class="mvp-nav-soc-but fa fa-twitter fa-2"></span></a>
																															<a href="https://www.facebook.com/backsportspage" target="_blank"><span class="mvp-nav-soc-but fa fa-facebook-official fa-2"></span></a>
																				<span class="mvp-nav-soc-head">Connect with us</span>
									</div><!--mvp-top-nav-soc-->
																		<span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span>
								</div><!--mvp-top-nav-right-->
							</div><!--mvp-top-nav-right-out-->
						</div><!--mvp-top-nav-cont-->
					</div><!--mvp-main-box-cont-->
				</div><!--mvp-top-nav-wrap-->
				<div id="mvp-bot-nav-wrap" class="left relative">
					<div class="mvp-main-box-cont">
						<div id="mvp-bot-nav-cont" class="left">
							<div class="mvp-bot-nav-out">
								<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
									<span></span>
									<span></span>
									<span></span>
									<span></span>
								</div><!--mvp-fly-but-wrap-->
								<div class="mvp-bot-nav-in">
									<div id="mvp-nav-menu" class="left">
										<div class="menu-primary-menu-container"><ul id="menu-primary-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-389"><a href="https://www.backsportspage.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-333"><a href="https://www.backsportspage.com/category/web-shows/">Web Shows</a>
<ul class="sub-menu">
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-336"><a href="https://www.backsportspage.com/category/web-shows/off-topic/">Off Topic</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="https://www.backsportspage.com/off-topic-thunder-rosa/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/10/bandicam-2020-06-29-19-57-32-070-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/10/bandicam-2020-06-29-19-57-32-070-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/10/bandicam-2020-06-29-19-57-32-070-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Off Topic: Thunder Rosa</a></li><li><a href="https://www.backsportspage.com/off-topic-jeff-coffin/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/10/tech-company-logo-generator-with-an-abstract-shape-illustration-2174i-2585-1-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/10/tech-company-logo-generator-with-an-abstract-shape-illustration-2174i-2585-1-400x240.png 400w, https://www.backsportspage.com/wp-content/uploads/2020/10/tech-company-logo-generator-with-an-abstract-shape-illustration-2174i-2585-1-1000x600.png 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Off Topic: Jeff Coffin</a></li><li><a href="https://www.backsportspage.com/off-topic-keith-elliot-greenberg-returns/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/10/tech-company-logo-generator-with-an-abstract-shape-illustration-2174i-2585-1-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/10/tech-company-logo-generator-with-an-abstract-shape-illustration-2174i-2585-1-400x240.png 400w, https://www.backsportspage.com/wp-content/uploads/2020/10/tech-company-logo-generator-with-an-abstract-shape-illustration-2174i-2585-1-1000x600.png 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Off Topic: Keith Elliot Greenberg Returns</a></li><li><a href="https://www.backsportspage.com/off-topic-notes-from-the-anthony-carelli-interview/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/09/Santino_Marella_1920x1080-dba6128057796e51aae4dc2b849c966e.0.0-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/09/Santino_Marella_1920x1080-dba6128057796e51aae4dc2b849c966e.0.0-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/09/Santino_Marella_1920x1080-dba6128057796e51aae4dc2b849c966e.0.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Off Topic: Notes From The Anthony Carelli Interview</a></li><li><a href="https://www.backsportspage.com/off-topic-santino-marella-anthony-carelli/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/09/Santino_Marella_1920x1080-dba6128057796e51aae4dc2b849c966e.0.0-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/09/Santino_Marella_1920x1080-dba6128057796e51aae4dc2b849c966e.0.0-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/09/Santino_Marella_1920x1080-dba6128057796e51aae4dc2b849c966e.0.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Off Topic: Santino Marella (Anthony Carelli)</a></li></ul></div></div></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-337"><a href="https://www.backsportspage.com/category/web-shows/seth-and-sean-sports/">Seth and Sean Sports</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="https://www.backsportspage.com/seth-and-sean-sports-12-8/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/logo-generator-for-a-gaming-clan-featuring-a-symmetric-emblem-3757g-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/logo-generator-for-a-gaming-clan-featuring-a-symmetric-emblem-3757g-400x240.png 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/logo-generator-for-a-gaming-clan-featuring-a-symmetric-emblem-3757g-1000x600.png 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Seth And Sean Sports 12/8</a></li><li><a href="https://www.backsportspage.com/bsp-live-seth-and-sean-9-15/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/07/82328864_1097098624017017_5191063938288058368_n-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>BSP Live: Seth And Sean 9/15</a></li><li><a href="https://www.backsportspage.com/bsp-live-seth-and-sean-9-8/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/07/82328864_1097098624017017_5191063938288058368_n-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>BSP Live: Seth And Sean 9/8</a></li><li><a href="https://www.backsportspage.com/bsp-live-seth-and-sean-6-16/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2017/02/demo-1-400x240.gif" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2017/02/demo-1-400x240.gif 400w, https://www.backsportspage.com/wp-content/uploads/2017/02/demo-1-300x180.gif 300w, https://www.backsportspage.com/wp-content/uploads/2017/02/demo-1-768x461.gif 768w" sizes="(max-width: 400px) 100vw, 400px" /></div>BSP Live: Seth and Sean 6/16</a></li><li><a href="https://www.backsportspage.com/bsp-live-seth-and-sean-5-28/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2019/10/demo-1-1-400x240.gif" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2019/10/demo-1-1-400x240.gif 400w, https://www.backsportspage.com/wp-content/uploads/2019/10/demo-1-1-700x420.gif 700w, https://www.backsportspage.com/wp-content/uploads/2019/10/demo-1-1-768x461.gif 768w" sizes="(max-width: 400px) 100vw, 400px" /></div>BSP Live: Seth And Sean 5/28</a></li></ul></div></div></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3938"><a href="https://www.backsportspage.com/category/web-shows/weekend-recap/">The Weekend Recap</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5143"><a href="https://www.backsportspage.com/category/web-shows/hardwood-huddle/">Hardwood Huddle</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334"><a href="https://www.backsportspage.com/category/web-shows/60-minute-overtime/">60 Minute Overtime</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="https://www.backsportspage.com/60-minute-overtime-fall-2017-episode-7/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2017/12/20294417_10209774025170612_44920229229711999_n-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>60 Minute Overtime Fall 2017 Episode 7</a></li><li><a href="https://www.backsportspage.com/60-minute-overtime-fall-episode-5/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2017/12/20294417_10209774025170612_44920229229711999_n-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>60 Minute Overtime Fall Episode 5</a></li></ul></div></div></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13815"><a href="https://www.backsportspage.com/category/web-shows/4th-and-long/">4th And Long</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-335"><a href="https://www.backsportspage.com/category/web-shows/new-york-groove/">New York Groove</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"></ul></div></div></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4865"><a href="https://www.backsportspage.com/category/web-shows/the-back-check/">The Back Check</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13485"><a href="https://www.backsportspage.com/category/web-shows/the-cut/">The Cut</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8917"><a href="https://www.backsportspage.com/category/web-shows/exit-velo/">Exit Velo</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4204"><a href="https://www.backsportspage.com/category/web-shows/the-wind-up/">The Wind Up</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8919"><a href="https://www.backsportspage.com/category/web-shows/ear-to-canvas/">Ear To Canvas</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5144"><a href="https://www.backsportspage.com/category/web-shows/zero-technique-podcast/">Zero Technique Podcast</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-338"><a href="https://www.backsportspage.com/category/web-shows/thats-what-she-said-sports/">Thats What She Said Sports</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="https://www.backsportspage.com/thats-what-she-says-sports-thankful/"><div class="mvp-mega-img"><img width="200" height="200" src="https://www.backsportspage.com/wp-content/uploads/2017/09/6555130a27f287e0c543baf74b431d22.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2017/09/6555130a27f287e0c543baf74b431d22.jpg 200w, https://www.backsportspage.com/wp-content/uploads/2017/09/6555130a27f287e0c543baf74b431d22-150x150.jpg 150w, https://www.backsportspage.com/wp-content/uploads/2017/09/6555130a27f287e0c543baf74b431d22-80x80.jpg 80w" sizes="(max-width: 200px) 100vw, 200px" /></div>That&#8217;s What She Says Sports: Thankful</a></li><li><a href="https://www.backsportspage.com/twsss-sit-down-and-be-humble/"><div class="mvp-mega-img"><img width="200" height="200" src="https://www.backsportspage.com/wp-content/uploads/2017/09/6555130a27f287e0c543baf74b431d22.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2017/09/6555130a27f287e0c543baf74b431d22.jpg 200w, https://www.backsportspage.com/wp-content/uploads/2017/09/6555130a27f287e0c543baf74b431d22-150x150.jpg 150w, https://www.backsportspage.com/wp-content/uploads/2017/09/6555130a27f287e0c543baf74b431d22-80x80.jpg 80w" sizes="(max-width: 200px) 100vw, 200px" /></div>TWSSS: Sit Down and Be Humble</a></li><li><a href="https://www.backsportspage.com/not-any-given-sunday/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2017/09/buffalo-bills-kneel-national-anthem-nfl-football-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2017/09/buffalo-bills-kneel-national-anthem-nfl-football-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2017/09/buffalo-bills-kneel-national-anthem-nfl-football-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>NOT ANY GIVEN SUNDAY</a></li><li><a href="https://www.backsportspage.com/twsss-sisters-and-sisters/"><div class="mvp-mega-img"><img width="200" height="200" src="https://www.backsportspage.com/wp-content/uploads/2017/09/6555130a27f287e0c543baf74b431d22.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2017/09/6555130a27f287e0c543baf74b431d22.jpg 200w, https://www.backsportspage.com/wp-content/uploads/2017/09/6555130a27f287e0c543baf74b431d22-150x150.jpg 150w, https://www.backsportspage.com/wp-content/uploads/2017/09/6555130a27f287e0c543baf74b431d22-80x80.jpg 80w" sizes="(max-width: 200px) 100vw, 200px" /></div>TWSSS: Sisters and Sisters</a></li><li><a href="https://www.backsportspage.com/fan-or-fraud/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2017/09/jj-watt_kqt5teswo1gm1oou9io3pve7e-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2017/09/jj-watt_kqt5teswo1gm1oou9io3pve7e-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2017/09/jj-watt_kqt5teswo1gm1oou9io3pve7e-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>FAN or FRAUD?</a></li></ul></div></div></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8926"><a href="https://www.backsportspage.com/category/web-shows/the-trifecta/">The Trifecta</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8558"><a href="https://www.backsportspage.com/category/web-shows/deep-6-podcast/">Deep 6 Podcast</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-320"><a href="https://www.backsportspage.com/category/features/">Features</a>
<ul class="sub-menu">
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-321"><a href="https://www.backsportspage.com/category/features/beyond-the-athlete/">Beyond the Athlete</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="https://www.backsportspage.com/minnesota-athletes-react-to-george-floyds-murder/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/06/towns-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/06/towns-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/06/towns-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Minnesota Athletes React to George Floyd’s Murder</a></li><li><a href="https://www.backsportspage.com/wnba-star-takes-off-season-to-support-prison-reform/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/03/maya_moore-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/03/maya_moore-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/03/maya_moore-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>WNBA Star Takes Off Season to Support Prison Reform</a></li><li><a href="https://www.backsportspage.com/an-athlete-a-father-a-legend-kobe-bryant/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/01/thumbnail_Gianna-and-Kobe-1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>An Athlete, A Father, A Legend: Kobe Bryant</a></li><li><a href="https://www.backsportspage.com/army-navy-captains-reflect/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2019/12/80003599_468990837151411_9124294545859674112_n-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2019/12/80003599_468990837151411_9124294545859674112_n-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2019/12/80003599_468990837151411_9124294545859674112_n-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Army-Navy Captains Reflect</a></li><li><a href="https://www.backsportspage.com/muscular-dystrophy-association-hosts-23rd-annual-muscle-team-gala/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2019/11/thumbnail_gala-cipriani-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2019/11/thumbnail_gala-cipriani-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2019/11/thumbnail_gala-cipriani-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Muscular Dystrophy Association Hosts 23rd Annual Muscle Team Gala</a></li></ul></div></div></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-322"><a href="https://www.backsportspage.com/category/features/book-reviews/">Book Reviews</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="https://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Rod Carew Shares Triumphs And Adversities In His Autobiography</a></li><li><a href="https://www.backsportspage.com/book-review-doc-the-life-of-roy-halladay-perfectly-encapsulates-the-hall-of-famers-legacy/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/Roy-halladay-hall-of-fame-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>Book Review: &#8220;Doc: The Life of Roy Halladay&#8221; perfectly encapsulates the Hall of Famer&#8217;s legacy</a></li><li><a href="https://www.backsportspage.com/young-bucks-killing-the-business-from-backyards-to-the-big-leagues/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/11/1574779885_396_young-bucks-696x392-1-scaled-1280x720-1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/11/1574779885_396_young-bucks-696x392-1-scaled-1280x720-1-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/11/1574779885_396_young-bucks-696x392-1-scaled-1280x720-1-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>YOUNG BUCKS: Killing the Business From Backyards To The Big Leagues</a></li><li><a href="https://www.backsportspage.com/pr-man-jay-horwitz/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/08/jay_horwitz_4-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/08/jay_horwitz_4-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/08/jay_horwitz_4-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Nobody Has More Stories To Tell Than Former New York Mets PR Man Jay Horwitz</a></li><li><a href="https://www.backsportspage.com/barry-zitos-autobiography-throws-his-audience-a-curveball/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/03/tuesday-hot-clicks-barry-zito-oakland-athletics-national-anthem-earth-day-videojpg-1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/03/tuesday-hot-clicks-barry-zito-oakland-athletics-national-anthem-earth-day-videojpg-1-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/03/tuesday-hot-clicks-barry-zito-oakland-athletics-national-anthem-earth-day-videojpg-1-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Barry Zito’s Autobiography Throws His Audience a Curveball</a></li></ul></div></div></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-323"><a href="https://www.backsportspage.com/category/features/in-the-business/">In the Business</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="https://www.backsportspage.com/nets-warriors-and-lakers-clippers-on-opening-night-dec-22-five-christmas-day-games-highlight-start-of-2020-21-nba-season/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/03/nba-logo-1-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/03/nba-logo-1-400x240.png 400w, https://www.backsportspage.com/wp-content/uploads/2020/03/nba-logo-1-1000x600.png 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>NETS-WARRIORS AND LAKERS-CLIPPERS ON OPENING NIGHT DEC. 22, FIVE CHRISTMAS DAY GAMES HIGHLIGHT START OF 2020-21 NBA SEASON</a></li><li><a href="https://www.backsportspage.com/jessica-mendoza-is-breaking-barriers-again/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/10/Mendoza-e1565566598967-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/10/Mendoza-e1565566598967-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/10/Mendoza-e1565566598967-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Jessica Mendoza is Breaking Barriers Again</a></li><li><a href="https://www.backsportspage.com/orlando-magics-malika-harrison-will-be-honored-by-orlando-business-journal/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/10/1200px-Orlando_Magic_logo.svg-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/10/1200px-Orlando_Magic_logo.svg-400x240.png 400w, https://www.backsportspage.com/wp-content/uploads/2020/10/1200px-Orlando_Magic_logo.svg-1000x600.png 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Orlando Magic’s Malika Harrison Will be Honored by Orlando Business Journal</a></li><li><a href="https://www.backsportspage.com/candice-parker-is-now-an-la-franchise-owner/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/10/9dd44303-9f4e-4049-8031-0aa9f1ebd593-thumbnail_CP_HEADSHOT_123-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/10/9dd44303-9f4e-4049-8031-0aa9f1ebd593-thumbnail_CP_HEADSHOT_123-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/10/9dd44303-9f4e-4049-8031-0aa9f1ebd593-thumbnail_CP_HEADSHOT_123-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Candice Parker is Now an LA Franchise Owner</a></li><li><a href="https://www.backsportspage.com/ross-forman-leaves-his-footprint-in-the-wrestling-industry/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/10/KAWUXX6G6FBTBDYCE6MWDJKCJY-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/10/KAWUXX6G6FBTBDYCE6MWDJKCJY-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/10/KAWUXX6G6FBTBDYCE6MWDJKCJY-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Ross Forman Leaves His Footprint In The Wrestling Industry</a></li></ul></div></div></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-324"><a href="https://www.backsportspage.com/category/features/in-the-community/">In the Community</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="https://www.backsportspage.com/stop-shop-and-the-new-york-giants-to-support-food-bank-for-new-york-city/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/roz31cmhwxocpgdlqt7q-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/roz31cmhwxocpgdlqt7q-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/roz31cmhwxocpgdlqt7q-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Stop &#038; Shop and the New York Giants to Support Food Bank for New York City</a></li><li><a href="https://www.backsportspage.com/record-number-of-nfl-players-raise-awareness-through-my-cause-my-cleats/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/Mycausecleats-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/Mycausecleats-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/Mycausecleats-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>RECORD NUMBER OF NFL PLAYERS RAISE AWARENESS THROUGH MY CAUSE MY CLEATS</a></li><li><a href="https://www.backsportspage.com/chicago-bulls-introduce-new-city-edition-uniforms-for-2020-21-season/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/11/guN8rEP4-400x240.jpeg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/11/guN8rEP4-400x240.jpeg 400w, https://www.backsportspage.com/wp-content/uploads/2020/11/guN8rEP4-1000x600.jpeg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>CHICAGO BULLS INTRODUCE NEW CITY EDITION UNIFORMS FOR 2020-21 SEASON</a></li><li><a href="https://www.backsportspage.com/new-orleans-pelicans-unveil-city-edition-uniform-inspired-by-flag-of-new-orleans/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/11/Vr-o0_pI-400x240.jpeg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/11/Vr-o0_pI-400x240.jpeg 400w, https://www.backsportspage.com/wp-content/uploads/2020/11/Vr-o0_pI-1000x600.jpeg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>NEW ORLEANS PELICANS UNVEIL CITY EDITION UNIFORM INSPIRED BY FLAG OF NEW ORLEANS</a></li><li><a href="https://www.backsportspage.com/nfl-recognizes-and-honors-the-military-community-through-increased-grants-and-partnerships/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/03/thumbnail_nfl-logo-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/03/thumbnail_nfl-logo-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/03/thumbnail_nfl-logo-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>NFL RECOGNIZES AND HONORS THE MILITARY COMMUNITY THROUGH INCREASED GRANTS AND PARTNERSHIPS</a></li></ul></div></div></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3939"><a href="https://www.backsportspage.com/category/features/community-events/">Community Events</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-698"><a href="https://www.backsportspage.com/category/features/question-of-the-day/">Question of the Day</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5726"><a href="https://www.backsportspage.com/category/features/the-rundown-with-tmoney/">The Rundown w/T-Money</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-325"><a href="https://www.backsportspage.com/category/features/the-transition/">The Transition</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="https://www.backsportspage.com/bsp-flashback-interview-brian-scalabrine/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2018/12/scalring_medium-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2018/12/scalring_medium-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2018/12/scalring_medium-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>BSP Flashback Interview Brian Scalabrine</a></li><li><a href="https://www.backsportspage.com/the-transition-chris-canty/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2017/07/Chris-Canty_Kay-Debate-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2017/07/Chris-Canty_Kay-Debate-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2017/07/Chris-Canty_Kay-Debate-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>The Transition: Chris Canty</a></li><li><a href="https://www.backsportspage.com/the-changing-uniforms-of-life/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2017/06/beasonweb14s-3-web-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>The Changing Uniforms Of Life</a></li><li><a href="https://www.backsportspage.com/the-transition-of-takeo-spikes/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2017/06/ESPNTheMagazinesNEXTEventENb5DXjCkP2x-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>The Transition of Takeo Spikes</a></li></ul></div></div></li>
</ul>
</li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-330"><a href="https://www.backsportspage.com/category/nfl/">NFL</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="https://www.backsportspage.com/a-tale-of-two-quarterbacks/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/USATSI_15341096-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/USATSI_15341096-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/USATSI_15341096-700x420.jpg 700w, https://www.backsportspage.com/wp-content/uploads/2020/12/USATSI_15341096-768x461.jpg 768w, https://www.backsportspage.com/wp-content/uploads/2020/12/USATSI_15341096.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>A Tale Of Two Quarterbacks</a></li><li><a href="https://www.backsportspage.com/nfl-lottery-should-the-nfl-adopt-an-nba-style-lottery-for-draft-positions/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2018/04/draft-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2018/04/draft-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2018/04/draft-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>NFL Lottery: Should the NFL Adopt an NBA-Style Lottery for Draft Positions?</a></li><li><a href="https://www.backsportspage.com/bears-one-win-away-from-nfc-wildcard-playoff-birth/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/USATSI_15341129-1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/USATSI_15341129-1-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/USATSI_15341129-1-700x420.jpg 700w, https://www.backsportspage.com/wp-content/uploads/2020/12/USATSI_15341129-1-768x461.jpg 768w, https://www.backsportspage.com/wp-content/uploads/2020/12/USATSI_15341129-1.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Bears one win away from NFC wildcard playoff birth.</a></li><li><a href="https://www.backsportspage.com/cleveland-browns-vs-new-york-jets-is-it-panic-time-in-cleveland-live-blog/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/usatsi_13370040-1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/usatsi_13370040-1-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/usatsi_13370040-1-700x420.jpg 700w, https://www.backsportspage.com/wp-content/uploads/2020/12/usatsi_13370040-1-768x461.jpg 768w, https://www.backsportspage.com/wp-content/uploads/2020/12/usatsi_13370040-1.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Cleveland Browns vs New York Jets: Is it Panic Time In Cleveland Live Blog</a></li><li><a href="https://www.backsportspage.com/is-it-panic-time-for-the-browns/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/11/download-18-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/11/download-18-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/11/download-18-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Is it Panic Time For the Browns? Multiple Reports Say that The Browns Could Be Without their Four Top Receivers on Sunday</a></li></ul></div></div>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-770"><a href="https://www.backsportspage.com/category/features/big-blue-report/">Big Blue Report</a></li>
</ul>
</li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-326"><a href="https://www.backsportspage.com/category/mlb/">MLB</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="https://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Rod Carew Shares Triumphs And Adversities In His Autobiography</a></li><li><a href="https://www.backsportspage.com/green-and-gold-report-oakland-as-offseason-news-december-week-three-winter-meetings-report/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/1277616523.jpg.0-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/1277616523.jpg.0-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/1277616523.jpg.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Green And Gold Report: Oakland A’s Offseason News December Week Three, Winter Meetings Report</a></li><li><a href="https://www.backsportspage.com/exit-velo-60-josh-bell-to-the-nats-white-sox-sign-yoelkis-cespedes/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/11/sports-logo-generator-for-a-baseball-team-featuring-a-pitcher-illustration-172u-2541-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/11/sports-logo-generator-for-a-baseball-team-featuring-a-pitcher-illustration-172u-2541-400x240.png 400w, https://www.backsportspage.com/wp-content/uploads/2020/11/sports-logo-generator-for-a-baseball-team-featuring-a-pitcher-illustration-172u-2541-1000x600.png 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Exit Velo #60: Josh Bell to the Nats; White Sox sign Yoelkis Céspedes</a></li><li><a href="https://www.backsportspage.com/interview-with-jonathan-de-marte-a-day-in-the-life/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/Jonathan-de-Marte-400x240.png" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/Jonathan-de-Marte-400x240.png 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/Jonathan-de-Marte-1000x600.png 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Interview With Jonathan de Marte, A Day In The Life.</a></li><li><a href="https://www.backsportspage.com/new-york-mets-and-noah-syndergaard-avoid-arbitration/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/syndergaard2-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/syndergaard2-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/syndergaard2-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>New York Mets and Noah Syndergaard avoid arbitration</a></li></ul></div></div></li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-328"><a href="https://www.backsportspage.com/category/nba/">NBA</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="https://www.backsportspage.com/spencer-dinwiddie-medical-update/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/spencer-dinwiddie-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/spencer-dinwiddie-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/spencer-dinwiddie-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>SPENCER DINWIDDIE MEDICAL UPDATE</a></li><li><a href="https://www.backsportspage.com/cavs-win-their-third-straight-game-to-open-the-season/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/usa_today_15363559.0-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/usa_today_15363559.0-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/usa_today_15363559.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Drummond&#8217;s Double-Double Plus the Backcourt Tandem of Sexton and Garland, Pace Cavs as They Win Their Third Straight Game to Start the Season</a></li><li><a href="https://www.backsportspage.com/grizzlies-fall-prey-to-hawks-expensive-lessons-learned-cheaply/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/usa_today_15362824.0-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/usa_today_15362824.0-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/usa_today_15362824.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Grizzlies Fall Prey to Hawks: Expensive Lessons Learned Cheaply</a></li><li><a href="https://www.backsportspage.com/hornets-edge-nets-106-104-in-charlotte-to-hand-brooklyn-first-loss/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/kyrie-irving-1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/kyrie-irving-1-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/kyrie-irving-1-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Hornets Edge Nets 106-104 In Charlotte To Hand Brooklyn First Loss</a></li><li><a href="https://www.backsportspage.com/is-rj-barrett-the-future-of-knicks-basketball/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/7HLZCCBDYVCQDENC5MLQXGHX4Q-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/7HLZCCBDYVCQDENC5MLQXGHX4Q-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/7HLZCCBDYVCQDENC5MLQXGHX4Q-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Is RJ Barrett the Future of Knicks Basketball?</a></li></ul></div></div></li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-331"><a href="https://www.backsportspage.com/category/nhl/">NHL</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="https://www.backsportspage.com/ottawa-adds-veterans-in-multiple-trades/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/New_Era.0-1024x683-1-400x240.jpeg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/New_Era.0-1024x683-1-400x240.jpeg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/New_Era.0-1024x683-1-1000x600.jpeg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Ottawa Adds Veterans In Multiple Trades</a></li><li><a href="https://www.backsportspage.com/how-division-realignment-will-affect-some-nhl-teams/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/cut-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>How Division Realignment Will Affect Some NHL Teams</a></li><li><a href="https://www.backsportspage.com/2021-world-juniors-preview-team-usa/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/maxresdefault-1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/maxresdefault-1-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/maxresdefault-1-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>2021 World Juniors Preview: Team USA</a></li><li><a href="https://www.backsportspage.com/2021-world-juniors-preview-team-canada/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/1191305013.0-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/1191305013.0-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/1191305013.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>2021 World Juniors Preview: Team Canada</a></li><li><a href="https://www.backsportspage.com/2021-world-juniors-preview-team-sweden/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/1191939898.0-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/1191939898.0-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/1191939898.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>2021 World Juniors Preview: Team Sweden</a></li></ul></div></div>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4469"><a href="https://www.backsportspage.com/category/features/breaking-the-ice/">Breaking The Ice</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="https://www.backsportspage.com/category/other-sports/">•••</a>
<ul class="sub-menu">
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-327"><a href="https://www.backsportspage.com/category/mma/">MMA</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="https://www.backsportspage.com/fighters-primed-to-headline-for-the-first-time-in-2021/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/ciryl-gane-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/ciryl-gane-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/ciryl-gane-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Fighters Primed to Headline for the First Time in 2021</a></li><li><a href="https://www.backsportspage.com/ufc-vegas-17-official-predictions/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/neal-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/neal-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/neal-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>UFC Vegas 17 Official Predictions</a></li><li><a href="https://www.backsportspage.com/can-stephen-thompson-make-another-run-for-a-title/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/wonderboy-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/wonderboy-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/wonderboy-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Can Stephen Thompson Make Another Run for a Title?</a></li><li><a href="https://www.backsportspage.com/ufc-vegas-17-everything-you-need-to-know/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/ufc-vegas-17-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/ufc-vegas-17-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/ufc-vegas-17-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>UFC Vegas 17 — Everything You Need to Know</a></li><li><a href="https://www.backsportspage.com/alex-morono-best-case-scenario-facing-pettis/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/alex-morono-2-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/alex-morono-2-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/alex-morono-2-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Alex Morono — &#8220;Best Case Scenario&#8221; Facing Pettis</a></li></ul></div></div></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-318"><a href="https://www.backsportspage.com/category/other-sports/soccer/">Soccer</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="https://www.backsportspage.com/the-us-men-national-teams-future-looks-bright/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/11/mckennie-wales-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>The US Men National Team&#8217;s Future Looks Bright</a></li><li><a href="https://www.backsportspage.com/why-is-soccer-not-as-popular-in-the-u-s/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/10/1000x-1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/10/1000x-1-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/10/1000x-1-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Why Is Soccer Not As Popular In The U.S?</a></li><li><a href="https://www.backsportspage.com/red-bulls-comment-on-extended-postponement/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/03/usa_today_13475214.0-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/03/usa_today_13475214.0-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/03/usa_today_13475214.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>RED BULLS COMMENT ON EXTENDED POSTPONEMENT</a></li><li><a href="https://www.backsportspage.com/mls-suspends-operations-due-to-caronavirus/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/03/dims-400x240.jpeg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/03/dims-400x240.jpeg 400w, https://www.backsportspage.com/wp-content/uploads/2020/03/dims-1000x600.jpeg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>MLS SUSPENDS OPERATIONS DUE TO CARONAVIRUS</a></li><li><a href="https://www.backsportspage.com/ny-red-bulls-vs-philadelphia-union-2/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2017/08/MAF_5173-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2017/08/MAF_5173-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2017/08/MAF_5173-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>NY Red Bulls vs. Philadelphia Union</a></li></ul></div></div></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317"><a href="https://www.backsportspage.com/category/other-sports/golf/">Golf</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="https://www.backsportspage.com/2020-us-open-preview/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/09/usa_today_12872662.0-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/09/usa_today_12872662.0-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/09/usa_today_12872662.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>2020 US Open Preview</a></li><li><a href="https://www.backsportspage.com/tour-championship-preview/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/09/usatsi-12525902-webb-simpson-2019-masters-r3-1st-fairway-1400-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/09/usatsi-12525902-webb-simpson-2019-masters-r3-1st-fairway-1400-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/09/usatsi-12525902-webb-simpson-2019-masters-r3-1st-fairway-1400-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Tour Championship Preview</a></li></ul></div></div></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-319"><a href="https://www.backsportspage.com/category/other-sports/wwe/">WWE</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="https://www.backsportspage.com/wwe-superstars-cameo-accounts-banned-by-mcmahon/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/10/45-12-1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/10/45-12-1-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/10/45-12-1-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Recent Banning Of WWE Superstar Cameo Accounts By COO Vince McMahon</a></li><li><a href="https://www.backsportspage.com/virtually-challenged-wrestling-promoter-tommy-fierro-piledriving-the-pandemic-through-virtual-signings/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/09/t120272594_1264565297215262_114900790179391510_n_1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>Virtually Challenged: Wrestling Promoter Tommy Fierro Piledriving the Pandemic Through Virtual Signings</a></li><li><a href="https://www.backsportspage.com/deep-6-wrestling-pocast-wwe-clash-of-champions-review/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/05/95897696_237106810873028_3997347399784726528_n-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>Deep 6 Wrestling Pocast: WWE Clash Of Champions Review</a></li><li><a href="https://www.backsportspage.com/off-topic-notes-from-the-anthony-carelli-interview/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/09/Santino_Marella_1920x1080-dba6128057796e51aae4dc2b849c966e.0.0-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/09/Santino_Marella_1920x1080-dba6128057796e51aae4dc2b849c966e.0.0-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/09/Santino_Marella_1920x1080-dba6128057796e51aae4dc2b849c966e.0.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Off Topic: Notes From The Anthony Carelli Interview</a></li><li><a href="https://www.backsportspage.com/aew-dynamite-review-7-29-20/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/08/AEW00349-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/08/AEW00349-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/08/AEW00349-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>AEW Dynamite Review (7.29.20)</a></li></ul></div></div></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13816"><a href="https://www.backsportspage.com/category/features/wrestling/">Wrestling</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8497"><a href="https://www.backsportspage.com/category/features/wnba/">WNBA</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10684"><a href="https://www.backsportspage.com/category/features/aew-wrestling/">AEW Wrestling</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-329"><a href="https://www.backsportspage.com/category/ncaa/">NCAA</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="https://www.backsportspage.com/the-fourth-long-podcast-episode-20-the-final-four-is-set/"><div class="mvp-mega-img"><img width="361" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/thumbnail_FourthAndLongLogo-DarkBackround_AR-1-361x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>The Fourth &amp; Long Podcast Epiosode 20: The Final Four is Set</a></li><li><a href="https://www.backsportspage.com/the-rubber-match-trevor-lawrence-vs-justin-fields/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/pjimage-8-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/pjimage-8-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/pjimage-8-700x420.jpg 700w, https://www.backsportspage.com/wp-content/uploads/2020/12/pjimage-8-768x461.jpg 768w, https://www.backsportspage.com/wp-content/uploads/2020/12/pjimage-8.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>The Rubber Match “ Trevor Lawrence vs Justin Fields”</a></li><li><a href="https://www.backsportspage.com/fourth-long-new-alternative-playoff/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/I3PEUK7YINFPXPGYNZY2XMISEQ-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/I3PEUK7YINFPXPGYNZY2XMISEQ-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/I3PEUK7YINFPXPGYNZY2XMISEQ-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Fourth &amp; Long: New Alternative Playoff</a></li><li><a href="https://www.backsportspage.com/lets-see-who-will-be-competing-for-a-national-title-in-2021/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/ohio-state-football-generic-1-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/ohio-state-football-generic-1-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/ohio-state-football-generic-1-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>Fourth &#038; Long: The Time Has Come, Let&#8217;s See Who Will be Competing for A National Title in 2021</a></li><li><a href="https://www.backsportspage.com/the-fourth-long-podcast-episode-19-win-or-go-home/"><div class="mvp-mega-img"><img width="361" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/thumbnail_FourthAndLongLogo-DarkBackround_AR-1-361x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" /></div>The Fourth &amp; Long Podcast Episode 19: Win or Go Home</a></li></ul></div></div></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7221"><a href="https://www.backsportspage.com/category/other-sports/xfl/">XFL</a></li>
</ul>
</li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1098"><a href="https://www.backsportspage.com/category/photos/">BSP Photos</a><div class="mvp-mega-dropdown"><div class="mvp-main-box-cont"><ul class="mvp-mega-list"><li><a href="https://www.backsportspage.com/xfl-opener-ny-guardians-vs-tampa-vipers-2-9-metlife-stadium/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/02/MAF8916-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/02/MAF8916-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/02/MAF8916-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>XFL Opener: NY Guardians VS Tampa Vipers 2/9-Metlife Stadium</a></li><li><a href="https://www.backsportspage.com/2017-giants-training-camp-photos/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2019/07/IMG_20161218_164603-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2019/07/IMG_20161218_164603-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2019/07/IMG_20161218_164603-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>2017 Giants Training Camp Photos</a></li><li><a href="https://www.backsportspage.com/2018-giants-training-camp-photos/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2019/07/20180726_163113-e1562934455443-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2019/07/20180726_163113-e1562934455443-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2019/07/20180726_163113-e1562934455443-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>2018 Giants Training Camp Photos</a></li><li><a href="https://www.backsportspage.com/ny-mets-6-vs-washington-nationals-5-4-6-19-2/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2019/04/MAF_9403-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2019/04/MAF_9403-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2019/04/MAF_9403-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>NY Mets (6) vs. Washington Nationals (5) &#8211; 4.6.19</a></li><li><a href="https://www.backsportspage.com/ny-mets-vs-atl-braves-8-4-18-2/"><div class="mvp-mega-img"><img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2018/08/MAF_7263-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2018/08/MAF_7263-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2018/08/MAF_7263-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></div>NY Mets vs. ATL Braves &#8211; 8.4.18</a></li></ul></div></div></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-346"><a href="https://www.backsportspage.com/bsp-writers/">BSP Writers</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-341"><a href="#mailmunch-pop-509941">Subscribe</a></li>
</ul></div>									</div><!--mvp-nav-menu-->
								</div><!--mvp-bot-nav-in-->
							</div><!--mvp-bot-nav-out-->
						</div><!--mvp-bot-nav-cont-->
					</div><!--mvp-main-box-cont-->
				</div><!--mvp-bot-nav-wrap-->
			</nav><!--mvp-main-nav-wrap-->
		</header>
		<main id="mvp-main-wrap" class="left relative">
						<div id="mvp-main-body-wrap" class="left relative">
				<div class="mvp-main-box-cont">
					<div id="mvp-main-body" class="left relative"><article id="mvp-article-wrap" class="post-15917 post type-post status-publish format-standard has-post-thumbnail hentry category-book-reviews category-features category-mlb tag-baseball tag-billy-martin tag-book-reviews tag-california-angels tag-featured tag-featured-mlb tag-harmon-killebrew tag-minnesota-twins tag-mlb tag-rod-carew tag-tony-oliva" itemscope itemtype="http://schema.org/NewsArticle">
		<div class="mvp-sec-pad left relative">
		<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/"/>
				<div id="mvp-article-head" class="left relative">
												<h3 class="mvp-post-cat left"><a class="mvp-post-cat-link" href="https://www.backsportspage.com/category/features/book-reviews/"><span class="mvp-post-cat left">Book Reviews</span></a></h3>
								<h1 class="mvp-post-title left entry-title" itemprop="headline">Rod Carew Shares Triumphs And Adversities In His Autobiography</h1>
												<div class="mvp-author-info-wrap left relative">
					<ul class="mvp-author-info-list left relative">
						<li class="mvp-author-info-thumb">
							<img alt='' src='https://secure.gravatar.com/avatar/07b888ffd11d9348c672e4eb9fbe7129?s=46&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/07b888ffd11d9348c672e4eb9fbe7129?s=92&#038;d=mm&#038;r=pg 2x' class='avatar avatar-46 photo' height='46' width='46' loading='lazy'/>						</li>
						<li class="mvp-author-info-name" itemprop="author" itemscope itemtype="https://schema.org/Person">
							<p>by</p> <span class="author-name vcard fn author" itemprop="name"><a href="https://www.backsportspage.com/author/ac_bsp/" title="Posts by Adam Cohen" rel="author">Adam Cohen</a></span>
						</li>
												<li class="mvp-author-info-date">
							<span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2020-12-28">December 28, 2020</time></span>
							<meta itemprop="dateModified" content="2020-12-28"/>
						</li>
					</ul>
				</div><!--mvp-author-info-wrap-->
									</div><!--mvp-article-head-->
				<div class="mvp-post-content-out relative">
			<div class="mvp-post-content-in">
									<div id="mvp-post-content" class="left relative">
																		<div class="mvp-content-box">
																										<div class="mvp-post-soc-out relative">
														<div id="mvp-post-soc-wrap" class="left relative">
								<ul class="mvp-post-soc-list left relative">
									<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/&amp;t=Rod Carew Shares Triumphs And Adversities In His Autobiography', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
									<li class="mvp-post-soc-fb">
										<i class="fa fa-2 fa-facebook" aria-hidden="true"></i>
									</li>
									</a>
									<a href="#" onclick="window.open('http://twitter.com/share?text=Rod Carew Shares Triumphs And Adversities In His Autobiography -&amp;url=https://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
									<li class="mvp-post-soc-twit">
										<i class="fa fa-2 fa-twitter" aria-hidden="true"></i>
									</li>
									</a>
									<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/&amp;media=https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-1000x600.jpg&amp;description=Rod Carew Shares Triumphs And Adversities In His Autobiography', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
									<li class="mvp-post-soc-pin">
										<i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i>
									</li>
									</a>
									<a href="mailto:?subject=Rod Carew Shares Triumphs And Adversities In His Autobiography&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/">
									<li class="mvp-post-soc-email">
										<i class="fa fa-2 fa-envelope" aria-hidden="true"></i>
									</li>
									</a>
																														<a href="https://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/#respond">
											<li class="mvp-post-soc-com mvp-com-click">
												<i class="fa fa-2 fa-commenting" aria-hidden="true"></i>
											</li>
											</a>
																											</ul>
							</div><!--mvp-post-soc-wrap-->
														<div class="mvp-post-soc-in">
																																<div id="mvp-content-main" class="left relative" itemprop="articleBody">
																																																							<div id="mvp-post-feat-img" class="left relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
														<img width="1222" height="813" src="https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth.jpg" class="attachment- size- wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth.jpg 1222w, https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-700x466.jpg 700w, https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-1024x681.jpg 1024w, https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-768x511.jpg 768w" sizes="(max-width: 1222px) 100vw, 1222px" />																												<meta itemprop="url" content="https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-1000x600.jpg">
														<meta itemprop="width" content="1000">
														<meta itemprop="height" content="600">
													</div><!--mvp-post-feat-img-->
																																																																										<div class='mailmunch-forms-before-post' style='display: none !important;'></div><div id="tps_slideContainer_15917" class="theiaPostSlider_slides"><div class="theiaPostSlider_preloadedSlide">

<p><em>One Tough Out: Fighting Off Life’s Curveballs</em> by Rod Carew with Jaime Aron offers a rich and insightful look at the Hall of Famer’s career, family tragedy, philanthropy, and how he overcame adversity. The seven-time batting champion made baseball look “easy” as he was a consistent top-of-the-order hitter with the Minnesota Twins and California Angels. Off the field, however, Carew dealt with his fair share of demons.&nbsp;</p>



<p>It would be an understatement to say that Carew experienced a rough childhood. Carew grew up in Panama and his alcoholic father constantly abused him and his mother. Even though she was physically attacked and tried her best to protect her son from being harmed, Carew’s mother Olga preached to him that God always has a plan and works in mysterious ways. Olga’s unrelenting faith and regular Sunday church outings with the young Rod Carew convinced him that there would be better days ahead.</p>



<p>Although his home life was a nightmare, Carew had a natural knack for baseball. Carew played above his age group and over time became one of the most highly touted players in Panama. Nevertheless, once Olga found a way to move to New York with her youngest son, his focus shifted to schoolwork and adjusting to life in a completely different world. Fortunately, Carew found his way back to baseball, excelled in adult amateur leagues, and was signed by the Twins after putting on a power display at Yankee Stadium.&nbsp;</p>



<p>One of the book’s biggest themes was how Carew’s family and friends inspired him throughout his life. Carew entered the Major Leagues as a star contact hitter but struggled with hardships along the way. Carew was bullied in Class A ball and was immensely worried during a short slump in his second season. At times, Carew did not encounter his problems head-on, as his struggles warranted a “flight” response most likely hailing from his horrible childhood. As a result, Carew left the team without notifying them, but Twins Owner Calvin Griffith and Twins Manager Billy Martin persuaded him to stay.&nbsp;</p>



<p>Besides those two executives, Tony Oliva and Harmon Killebrew both took Carew under their wing. His two teammates became some of Carew’s first friends at the professional level. Carew spent so much time with them that he was finally able to open up about his childhood trauma to other people, thus signaling how much Carew’s life improved since leaving Panama. No longer was Carew a scared kid with little hope of escaping his father’s wrath. His success as a baseball player, and healthier relationships in his life, allowed him to cope with his time spent in his home country.</p><div class='mailmunch-forms-in-post-middle' style='display: none !important;'></div>



<p>Carew continued to grow as an individual after his playing career too. Unfortunately, Carew’s daughter Michelle died at 18 from Leukemia, but his daughter wanted nothing more than to help the other patients. Therefore, in Michelle’s final days and after she died, Carew took initiative and began to raise awareness about the various transplants that helped his daughter. Carew was not very fond of the media and for the most part, was a reserved person. Nonetheless, Carew broke down the proverbial walls that he placed on the outside world, did everything from interviews to speaking with strangers to ask for donations, and provide funding. Indeed, many lives were saved because of Carew’s campaign to popularize bone marrow and umbilical cord blood transplants.</p>



<p>Sadly, Carew’s relationship with his first wife and children was strained by Michelle’s death. Even with his difficult family situation, Carew eventually met his second wife and her children became part of his family. Carew’s new family stayed by his side when he had a massive heart attack in 2015, which took years of recovery. After surviving the heart attack, Carew had to undergo intensive physical therapy,&nbsp; several transplants of his own, and a return of his “flight” response, yet Carew continued helping others. Carew partnered with the Twins, Angels, Major League Baseball, and the Hall of Fame to ask others to get screened before any heart problems occur.</p>



<p>Carew faced incredible hardships but went on to be a first-ballot Hall of Famer, a rarity among the best players enshrined in Cooperstown. His family life, both as a child and as an adult were challenging and traumatic for him. Yet, Carew continued to fight off life’s curveballs and did not let any of these adversities stop him from helping others, or using his platform to raise awareness. Furthermore, Carew’s autobiography has added to his legacy. Besides his philanthropic work and amazing performance on the diamond, Carew’s eloquently told story can inspire nearly anyone to overcome their own individual struggles.</p>

</div></div><div class="theiaPostSlider_footer _footer"></div><p><!-- END THEIA POST SLIDER --></p><div class='mailmunch-forms-after-post' style='display: none !important;'></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div><div data-theiaPostSlider-sliderOptions='{&quot;slideContainer&quot;:&quot;#tps_slideContainer_15917&quot;,&quot;nav&quot;:[&quot;.theiaPostSlider_nav&quot;],&quot;navText&quot;:&quot;%{currentSlide} of %{totalSlides}&quot;,&quot;helperText&quot;:&quot;Use your &amp;leftarrow; &amp;rightarrow; (arrow) keys to browse&quot;,&quot;defaultSlide&quot;:0,&quot;transitionEffect&quot;:&quot;slide&quot;,&quot;transitionSpeed&quot;:400,&quot;keyboardShortcuts&quot;:true,&quot;scrollAfterRefresh&quot;:true,&quot;numberOfSlides&quot;:1,&quot;slides&quot;:[],&quot;useSlideSources&quot;:null,&quot;themeType&quot;:&quot;font&quot;,&quot;prevText&quot;:&quot;Prev&quot;,&quot;nextText&quot;:&quot;Next&quot;,&quot;buttonWidth&quot;:0,&quot;buttonWidth_post&quot;:0,&quot;postUrl&quot;:&quot;https:\/\/www.backsportspage.com\/rod-carew-shares-triumphs-and-adversities-in-his-autobiography\/&quot;,&quot;postId&quot;:15917,&quot;refreshAds&quot;:false,&quot;refreshAdsEveryNSlides&quot;:1,&quot;adRefreshingMechanism&quot;:&quot;javascript&quot;,&quot;ajaxUrl&quot;:&quot;https:\/\/www.backsportspage.com\/wp-admin\/admin-ajax.php&quot;,&quot;loopSlides&quot;:false,&quot;scrollTopOffset&quot;:0,&quot;hideNavigationOnFirstSlide&quot;:false,&quot;isRtl&quot;:false,&quot;excludedWords&quot;:[&quot;&quot;],&quot;prevFontIcon&quot;:&quot;&lt;span aria-hidden=\&quot;true\&quot; class=\&quot;tps-icon-chevron-circle-left\&quot;&gt;&lt;\/span&gt;&quot;,&quot;nextFontIcon&quot;:&quot;&lt;span aria-hidden=\&quot;true\&quot; class=\&quot;tps-icon-chevron-circle-right\&quot;&gt;&lt;\/span&gt;&quot;}' 
					 data-theiaPostSlider-onChangeSlide='&quot;&quot;'></div>																																					<div class="mvp-post-tags">
											<span class="mvp-post-tags-header">Related Topics</span><span itemprop="keywords"><a href="https://www.backsportspage.com/tag/baseball/" rel="tag">Baseball</a><a href="https://www.backsportspage.com/tag/billy-martin/" rel="tag">Billy Martin</a><a href="https://www.backsportspage.com/tag/book-reviews/" rel="tag">Book Reviews</a><a href="https://www.backsportspage.com/tag/california-angels/" rel="tag">California Angels</a><a href="https://www.backsportspage.com/tag/featured/" rel="tag">Featured</a><a href="https://www.backsportspage.com/tag/featured-mlb/" rel="tag">Featured MLB</a><a href="https://www.backsportspage.com/tag/harmon-killebrew/" rel="tag">Harmon Killebrew</a><a href="https://www.backsportspage.com/tag/minnesota-twins/" rel="tag">Minnesota Twins</a><a href="https://www.backsportspage.com/tag/mlb/" rel="tag">MLB</a><a href="https://www.backsportspage.com/tag/rod-carew/" rel="tag">Rod Carew</a><a href="https://www.backsportspage.com/tag/tony-oliva/" rel="tag">Tony Oliva</a></span>
										</div><!--mvp-post-tags-->
																		<div class="posts-nav-link">
																			</div><!--posts-nav-link-->
																		<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
										<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
																							<img src="http://www.backsportspage.com/wp-content/uploads/2017/06/logo-nav.png"/>
												<meta itemprop="url" content="http://www.backsportspage.com/wp-content/uploads/2017/06/logo-nav.png">
																					</div><!--mvp-org-logo-->
										<meta itemprop="name" content="Back Sports Page">
									</div><!--mvp-org-wrap-->
								</div><!--mvp-content-main-->
																																					<div id="mvp-comments-button" class="left relative mvp-com-click">
											<span class="mvp-comment-but-text">Click to comment</span>
										</div><!--mvp-comments-button-->
										<div id="comments">
				
	
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><h4 class="mvp-sec-head"><span class="mvp-sec-head">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.backsportspage.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='15917' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>
<noscript><input type="hidden" name="JS04X7" value="NS1" /></noscript>
<noscript><p><strong>Currently you have JavaScript disabled. In order to post comments, please make sure JavaScript and Cookies are enabled, and reload the page.</strong> <a href="http://enable-javascript.com/" rel="nofollow external" >Click here for instructions on how to enable JavaScript in your browser.</a></p></noscript>
</form>	</div><!-- #respond -->
	
</div><!--comments-->																								</div><!--mvp-post-soc-in-->
						</div><!--mvp-post-soc-out-->
						</div><!--mvp-content-box-->
					</div><!--mvp-post-content-->
											</div><!--mvp-post-content-in-->
							<div id="mvp-side-wrap" class="relative">
						<section id="mvp_home_tagfeat_widget-2" class="mvp-side-widget mvp_home_tagfeat_widget">
					<h4 class="mvp-sec-head mvp-widget-feat-head"><span class="mvp-sec-head">Featured Articles</span></h4>
					<div class="mvp-widget-feat-wrap left relative">
				<ul class="mvp-widget-feat-list left relative">
											<li>
															<a href="https://www.backsportspage.com/spencer-dinwiddie-medical-update/" rel="bookmark">
								<div class="mvp-widget-feat-img left relative">
									<img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/spencer-dinwiddie-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/spencer-dinwiddie-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/spencer-dinwiddie-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="https://www.backsportspage.com/wp-content/uploads/2020/12/spencer-dinwiddie-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/spencer-dinwiddie-80x80.jpg 80w, https://www.backsportspage.com/wp-content/uploads/2020/12/spencer-dinwiddie-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-widget-feat-img-->
								</a>
														<div class="mvp-widget-feat-text left relative">
								<div class="mvp-post-info-top left relative">
									<h3><a href="https://www.backsportspage.com/category/features/">Features</a></h3><span class="mvp-post-info-date left relative">/ 37 mins ago</span>
								</div><!--mvp-post-info-top-->
								<h2><a href="https://www.backsportspage.com/spencer-dinwiddie-medical-update/" rel="bookmark">SPENCER DINWIDDIE MEDICAL UPDATE</a></h2>
								<p>Brooklyn Nets guard Spencer Dinwiddie has been diagnosed with a partially torn anterior cruciate...</p>
								<div class="mvp-blog-story-info left relative">
									<span class="mvp-blog-story-author left">By <a href="https://www.backsportspage.com/author/rzellea/" title="Posts by Randy Zellea" rel="author">Randy Zellea</a></span>
								</div><!--mvp-blog-story-info-->
							</div><!--mvp-widget-feat-text-->
						</li>
											<li>
															<a href="https://www.backsportspage.com/the-cut-pro-wrestling-podcast-conrad-thompson/" rel="bookmark">
								<div class="mvp-widget-feat-img left relative">
									<img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/download-400x240.png" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/download-400x240.png 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/download-1000x600.png 1000w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="https://www.backsportspage.com/wp-content/uploads/2020/12/download-80x80.png" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/download-80x80.png 80w, https://www.backsportspage.com/wp-content/uploads/2020/12/download-150x150.png 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-widget-feat-img-->
								</a>
														<div class="mvp-widget-feat-text left relative">
								<div class="mvp-post-info-top left relative">
									<h3><a href="https://www.backsportspage.com/category/web-shows/the-cut/">The Cut</a></h3><span class="mvp-post-info-date left relative">/ 1 hour ago</span>
								</div><!--mvp-post-info-top-->
								<h2><a href="https://www.backsportspage.com/the-cut-pro-wrestling-podcast-conrad-thompson/" rel="bookmark">The Cut Pro Wrestling Podcast: Conrad Thompson</a></h2>
								<p>This week the boys close out 2020 with the &#8220;PodFather of Pro Wrestling Podcasts&#8221;,...</p>
								<div class="mvp-blog-story-info left relative">
									<span class="mvp-blog-story-author left">By <a href="https://www.backsportspage.com/author/rzellea/" title="Posts by Randy Zellea" rel="author">Randy Zellea</a></span>
								</div><!--mvp-blog-story-info-->
							</div><!--mvp-widget-feat-text-->
						</li>
											<li>
															<a href="https://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/" rel="bookmark">
								<div class="mvp-widget-feat-img left relative">
									<img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-80x80.jpg 80w, https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-widget-feat-img-->
								</a>
														<div class="mvp-widget-feat-text left relative">
								<div class="mvp-post-info-top left relative">
									<h3><a href="https://www.backsportspage.com/category/features/book-reviews/">Book Reviews</a></h3><span class="mvp-post-info-date left relative">/ 3 hours ago</span>
								</div><!--mvp-post-info-top-->
								<h2><a href="https://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/" rel="bookmark">Rod Carew Shares Triumphs And Adversities In His Autobiography</a></h2>
								<p>One Tough Out: Fighting Off Life’s Curveballs by Rod Carew with Jaime Aron offers...</p>
								<div class="mvp-blog-story-info left relative">
									<span class="mvp-blog-story-author left">By <a href="https://www.backsportspage.com/author/ac_bsp/" title="Posts by Adam Cohen" rel="author">Adam Cohen</a></span>
								</div><!--mvp-blog-story-info-->
							</div><!--mvp-widget-feat-text-->
						</li>
											<li>
															<a href="https://www.backsportspage.com/a-tale-of-two-quarterbacks/" rel="bookmark">
								<div class="mvp-widget-feat-img left relative">
									<img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/USATSI_15341096-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/USATSI_15341096-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/12/USATSI_15341096-700x420.jpg 700w, https://www.backsportspage.com/wp-content/uploads/2020/12/USATSI_15341096-768x461.jpg 768w, https://www.backsportspage.com/wp-content/uploads/2020/12/USATSI_15341096.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="https://www.backsportspage.com/wp-content/uploads/2020/12/USATSI_15341096-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/USATSI_15341096-80x80.jpg 80w, https://www.backsportspage.com/wp-content/uploads/2020/12/USATSI_15341096-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-widget-feat-img-->
								</a>
														<div class="mvp-widget-feat-text left relative">
								<div class="mvp-post-info-top left relative">
									<h3><a href="https://www.backsportspage.com/category/nfl/">NFL</a></h3><span class="mvp-post-info-date left relative">/ 3 hours ago</span>
								</div><!--mvp-post-info-top-->
								<h2><a href="https://www.backsportspage.com/a-tale-of-two-quarterbacks/" rel="bookmark">A Tale Of Two Quarterbacks</a></h2>
								<p>If there is one position in Chicago Bears history that has not earned the...</p>
								<div class="mvp-blog-story-info left relative">
									<span class="mvp-blog-story-author left">By <a href="https://www.backsportspage.com/author/rh_bsp/" title="Posts by Ronald Hill" rel="author">Ronald Hill</a></span>
								</div><!--mvp-blog-story-info-->
							</div><!--mvp-widget-feat-text-->
						</li>
									</ul>
			</div><!--mvp-widget-feat-wrap-->

		</section><section id="mvp_authors_widget-3" class="mvp-side-widget mvp_authors_widget"><h4 class="mvp-sec-head"><span class="mvp-sec-head">Featured Writers</span></h4>
		<div class="mvp-widget-authors-wrap left relative">
							<div class="mvp-widget-author left relative">
					<div class="mvp-100img-out right relative">
						<div class="mvp-widget-author-img left relative">
							<img alt='' src='https://secure.gravatar.com/avatar/f8fe62a4dc78c486e142fcf85c650d2b?s=100&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/f8fe62a4dc78c486e142fcf85c650d2b?s=200&#038;d=mm&#038;r=pg 2x' class='avatar avatar-100 photo' height='100' width='100' loading='lazy'/>						</div><!--mvp-widget-author-img-->
						<div class="mvp-100img-in">
							<div class="mvp-widget-author-text left relative">
																	<h3><a href="https://www.backsportspage.com/author/rzellea/">Randy Zellea</a></h3>
									<h2><a href="https://www.backsportspage.com/spencer-dinwiddie-medical-update/" rel="bookmark">SPENCER DINWIDDIE MEDICAL UPDATE</a></h2>
															</div><!--mvp-widget-author-text-->
						</div><!--mvp-100img-in-->
					</div><!--mvp-100img-out-->
				</div><!--mvp-widget-author-->
							<div class="mvp-widget-author left relative">
					<div class="mvp-100img-out right relative">
						<div class="mvp-widget-author-img left relative">
							<img alt='' src='https://secure.gravatar.com/avatar/8095b7c7fc24cdc9d92a34691c0034d3?s=100&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/8095b7c7fc24cdc9d92a34691c0034d3?s=200&#038;d=mm&#038;r=pg 2x' class='avatar avatar-100 photo' height='100' width='100' loading='lazy'/>						</div><!--mvp-widget-author-img-->
						<div class="mvp-100img-in">
							<div class="mvp-widget-author-text left relative">
																	<h3><a href="https://www.backsportspage.com/author/tmoney/">Tracy Graven</a></h3>
									<h2><a href="https://www.backsportspage.com/the-rundown-v122820-charlotte-stings-the-nets-cavaliers-magic-hawks-pacers-thunder-undefeated/" rel="bookmark">The Rundown v122820 &#8211; Charlotte Stings the Nets; Cavaliers, Magic, Hawks, Pacers, Thunder Undefeated</a></h2>
															</div><!--mvp-widget-author-text-->
						</div><!--mvp-100img-in-->
					</div><!--mvp-100img-out-->
				</div><!--mvp-widget-author-->
							<div class="mvp-widget-author left relative">
					<div class="mvp-100img-out right relative">
						<div class="mvp-widget-author-img left relative">
							<img alt='' src='https://secure.gravatar.com/avatar/0459ce4c628ae728ebfe2f028e65015b?s=100&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/0459ce4c628ae728ebfe2f028e65015b?s=200&#038;d=mm&#038;r=pg 2x' class='avatar avatar-100 photo' height='100' width='100' loading='lazy'/>						</div><!--mvp-widget-author-img-->
						<div class="mvp-100img-in">
							<div class="mvp-widget-author-text left relative">
																	<h3><a href="https://www.backsportspage.com/author/rt_bsp/">Ryan Truland</a></h3>
									<h2><a href="https://www.backsportspage.com/fighters-primed-to-headline-for-the-first-time-in-2021/" rel="bookmark">Fighters Primed to Headline for the First Time in 2021</a></h2>
															</div><!--mvp-widget-author-text-->
						</div><!--mvp-100img-in-->
					</div><!--mvp-100img-out-->
				</div><!--mvp-widget-author-->
							<div class="mvp-widget-author left relative">
					<div class="mvp-100img-out right relative">
						<div class="mvp-widget-author-img left relative">
							<img alt='' src='https://secure.gravatar.com/avatar/467fba54a9a347aa869150cb49b4531c?s=100&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/467fba54a9a347aa869150cb49b4531c?s=200&#038;d=mm&#038;r=pg 2x' class='avatar avatar-100 photo' height='100' width='100' loading='lazy'/>						</div><!--mvp-widget-author-img-->
						<div class="mvp-100img-in">
							<div class="mvp-widget-author-text left relative">
																	<h3><a href="https://www.backsportspage.com/author/jb3_bsp/">Justin Brownlow</a></h3>
									<h2><a href="https://www.backsportspage.com/cavs-win-their-third-straight-game-to-open-the-season/" rel="bookmark">Drummond&#8217;s Double-Double Plus the Backcourt Tandem of Sexton and Garland, Pace Cavs as They Win Their Third Straight Game to Start the Season</a></h2>
															</div><!--mvp-widget-author-text-->
						</div><!--mvp-100img-in-->
					</div><!--mvp-100img-out-->
				</div><!--mvp-widget-author-->
							<div class="mvp-widget-author left relative">
					<div class="mvp-100img-out right relative">
						<div class="mvp-widget-author-img left relative">
							<img alt='' src='https://secure.gravatar.com/avatar/07b888ffd11d9348c672e4eb9fbe7129?s=100&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/07b888ffd11d9348c672e4eb9fbe7129?s=200&#038;d=mm&#038;r=pg 2x' class='avatar avatar-100 photo' height='100' width='100' loading='lazy'/>						</div><!--mvp-widget-author-img-->
						<div class="mvp-100img-in">
							<div class="mvp-widget-author-text left relative">
																	<h3><a href="https://www.backsportspage.com/author/ac_bsp/">Adam Cohen</a></h3>
									<h2><a href="https://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/" rel="bookmark">Rod Carew Shares Triumphs And Adversities In His Autobiography</a></h2>
															</div><!--mvp-widget-author-text-->
						</div><!--mvp-100img-in-->
					</div><!--mvp-100img-out-->
				</div><!--mvp-widget-author-->
					</div><!--mvp-widget-authors-wrap-->

		</section>			</div><!--mvp-side-wrap-->					</div><!--mvp-post-content-out-->
							<section id="mvp-more-post-wrap" class="left relative">
				<h4 class="mvp-sec-head"><span class="mvp-sec-head">More in Book Reviews</span></h4>
				<ul class="mvp-more-post-list left relative">
											<li>
															<a href="https://www.backsportspage.com/book-review-doc-the-life-of-roy-halladay-perfectly-encapsulates-the-hall-of-famers-legacy/" rel="bookmark">
								<div class="mvp-more-post-img left relative">
									<img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/12/Roy-halladay-hall-of-fame-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" />									<img width="80" height="80" src="https://www.backsportspage.com/wp-content/uploads/2020/12/Roy-halladay-hall-of-fame-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/12/Roy-halladay-hall-of-fame-80x80.jpg 80w, https://www.backsportspage.com/wp-content/uploads/2020/12/Roy-halladay-hall-of-fame-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-more-post-img-->
								</a>
														<div class="mvp-more-post-text left relative">
								<h2><a href="https://www.backsportspage.com/book-review-doc-the-life-of-roy-halladay-perfectly-encapsulates-the-hall-of-famers-legacy/" rel="bookmark">Book Review: &#8220;Doc: The Life of Roy Halladay&#8221; perfectly encapsulates the Hall of Famer&#8217;s legacy</a></h2>
								<p>Todd Zolecki, the author of “Doc: The Life of Roy Halladay”, describes the humility,...</p>
							</div><!--mvp-more-post-text-->
						</li>
											<li>
															<a href="https://www.backsportspage.com/young-bucks-killing-the-business-from-backyards-to-the-big-leagues/" rel="bookmark">
								<div class="mvp-more-post-img left relative">
									<img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/11/1574779885_396_young-bucks-696x392-1-scaled-1280x720-1-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/11/1574779885_396_young-bucks-696x392-1-scaled-1280x720-1-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/11/1574779885_396_young-bucks-696x392-1-scaled-1280x720-1-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="https://www.backsportspage.com/wp-content/uploads/2020/11/1574779885_396_young-bucks-696x392-1-scaled-1280x720-1-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/11/1574779885_396_young-bucks-696x392-1-scaled-1280x720-1-80x80.jpg 80w, https://www.backsportspage.com/wp-content/uploads/2020/11/1574779885_396_young-bucks-696x392-1-scaled-1280x720-1-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-more-post-img-->
								</a>
														<div class="mvp-more-post-text left relative">
								<h2><a href="https://www.backsportspage.com/young-bucks-killing-the-business-from-backyards-to-the-big-leagues/" rel="bookmark">YOUNG BUCKS: Killing the Business From Backyards To The Big Leagues</a></h2>
								<p>A warm, heartfelt story told with the brothers’ wit and charm, YOUNG BUCKS: Killing...</p>
							</div><!--mvp-more-post-text-->
						</li>
											<li>
															<a href="https://www.backsportspage.com/pr-man-jay-horwitz/" rel="bookmark">
								<div class="mvp-more-post-img left relative">
									<img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/08/jay_horwitz_4-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/08/jay_horwitz_4-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/08/jay_horwitz_4-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="https://www.backsportspage.com/wp-content/uploads/2020/08/jay_horwitz_4-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/08/jay_horwitz_4-80x80.jpg 80w, https://www.backsportspage.com/wp-content/uploads/2020/08/jay_horwitz_4-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-more-post-img-->
								</a>
														<div class="mvp-more-post-text left relative">
								<h2><a href="https://www.backsportspage.com/pr-man-jay-horwitz/" rel="bookmark">Nobody Has More Stories To Tell Than Former New York Mets PR Man Jay Horwitz</a></h2>
								<p>Longtime New York Mets PR man Jay Horwitz reminds me of any Jewish grandpa...</p>
							</div><!--mvp-more-post-text-->
						</li>
											<li>
															<a href="https://www.backsportspage.com/barry-zitos-autobiography-throws-his-audience-a-curveball/" rel="bookmark">
								<div class="mvp-more-post-img left relative">
									<img width="400" height="240" src="https://www.backsportspage.com/wp-content/uploads/2020/03/tuesday-hot-clicks-barry-zito-oakland-athletics-national-anthem-earth-day-videojpg-1-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/03/tuesday-hot-clicks-barry-zito-oakland-athletics-national-anthem-earth-day-videojpg-1-400x240.jpg 400w, https://www.backsportspage.com/wp-content/uploads/2020/03/tuesday-hot-clicks-barry-zito-oakland-athletics-national-anthem-earth-day-videojpg-1-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" />									<img width="80" height="80" src="https://www.backsportspage.com/wp-content/uploads/2020/03/tuesday-hot-clicks-barry-zito-oakland-athletics-national-anthem-earth-day-videojpg-1-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2020/03/tuesday-hot-clicks-barry-zito-oakland-athletics-national-anthem-earth-day-videojpg-1-80x80.jpg 80w, https://www.backsportspage.com/wp-content/uploads/2020/03/tuesday-hot-clicks-barry-zito-oakland-athletics-national-anthem-earth-day-videojpg-1-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																	</div><!--mvp-more-post-img-->
								</a>
														<div class="mvp-more-post-text left relative">
								<h2><a href="https://www.backsportspage.com/barry-zitos-autobiography-throws-his-audience-a-curveball/" rel="bookmark">Barry Zito’s Autobiography Throws His Audience a Curveball</a></h2>
								<p>In his brutally honest autobiography Curveball: How I Discovered True Fulfillment After Chasing Fortune...</p>
							</div><!--mvp-more-post-text-->
						</li>
									</ul>
			</section><!--mvp-more-post-wrap-->
											<div id="mvp-prev-next-wrap">
									<div id="mvp-prev-post-wrap">
						<div id="mvp-prev-post-arrow" class="relative">
							<span class="fa fa-angle-left fa-4" aria-hidden="true"></span>
						</div><!--mvp-prev-post-arrow-->
						<div class="mvp-prev-next-text">
							<a href="https://www.backsportspage.com/green-and-gold-report-oakland-as-offseason-news-december-week-three-winter-meetings-report/" rel="prev">Green And Gold Report: Oakland A’s Offseason News December Week Three, Winter Meetings Report</a>						</div><!--mvp-prev-post-text-->
					</div><!--mvp-prev-post-wrap-->
													<div id="mvp-next-post-wrap">
						<div id="mvp-next-post-arrow" class="relative">
							<span class="fa fa-angle-right fa-4 " aria-hidden="true"></span>
						</div><!--mvp-prev-post-arrow-->
						<div class="mvp-prev-next-text">
							<a href="https://www.backsportspage.com/spencer-dinwiddie-medical-update/" rel="next">SPENCER DINWIDDIE MEDICAL UPDATE</a>						</div><!--mvp-prev-next-text-->
					</div><!--mvp-next-post-wrap-->
							</div><!--mvp-prev-next-wrap-->
					</div><!--mvp-sec-pad-->
</article><!--mvp-article-wrap-->
				</div><!--mvp-main-body-->
			</div><!--mvp-main-box-cont-->
		</div><!--mvp-main-body-wrap-->
	</main><!--mvp-main-wrap-->
		<footer id="mvp-foot-wrap" class="left relative">
		<div id="mvp-foot-top" class="left relative">
			<div class="mvp-main-box-cont">
				<div id="mvp-foot-logo" class="left relative">
											<a href="https://www.backsportspage.com/"><img src="http://www.backsportspage.com/wp-content/uploads/2017/06/logo-footer.png" alt="Back Sports Page" data-rjs="2" /></a>
									</div><!--mvp-foot-logo-->
				<div id="mvp-foot-soc" class="left relative">
					<ul class="mvp-foot-soc-list left relative">
														<li><a href="https://www.facebook.com/backsportspage" target="_blank" class="fa fa-facebook-official fa-2"></a></li>
																			<li><a href="https://twitter.com/BackSportsPage" target="_blank" class="fa fa-twitter fa-2"></a></li>
																									<li><a href="https://www.instagram.com/backsportspage/" target="_blank" class="fa fa-instagram fa-2"></a></li>
																									<li><a href="https://www.youtube.com/user/BackSportsPage" target="_blank" class="fa fa-youtube-play fa-2"></a></li>
																							</ul>
				</div><!--mvp-foot-soc-->
			</div><!--mvp-main-box-cont-->
		</div><!--mvp-foot-top-->
		<div id="mvp-foot-bot" class="left relative">
			<div id="mvp-foot-menu-wrap" class="left relative">
				<div class="mvp-main-box-cont">
					<div id="mvp-foot-menu" class="left relative">
						<div class="menu-primary-menu-container"><ul id="menu-primary-menu-2" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-389"><a href="https://www.backsportspage.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-333"><a href="https://www.backsportspage.com/category/web-shows/">Web Shows</a>
<ul class="sub-menu">
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-336"><a href="https://www.backsportspage.com/category/web-shows/off-topic/">Off Topic</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-337"><a href="https://www.backsportspage.com/category/web-shows/seth-and-sean-sports/">Seth and Sean Sports</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3938"><a href="https://www.backsportspage.com/category/web-shows/weekend-recap/">The Weekend Recap</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5143"><a href="https://www.backsportspage.com/category/web-shows/hardwood-huddle/">Hardwood Huddle</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334"><a href="https://www.backsportspage.com/category/web-shows/60-minute-overtime/">60 Minute Overtime</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13815"><a href="https://www.backsportspage.com/category/web-shows/4th-and-long/">4th And Long</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-335"><a href="https://www.backsportspage.com/category/web-shows/new-york-groove/">New York Groove</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4865"><a href="https://www.backsportspage.com/category/web-shows/the-back-check/">The Back Check</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13485"><a href="https://www.backsportspage.com/category/web-shows/the-cut/">The Cut</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8917"><a href="https://www.backsportspage.com/category/web-shows/exit-velo/">Exit Velo</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4204"><a href="https://www.backsportspage.com/category/web-shows/the-wind-up/">The Wind Up</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8919"><a href="https://www.backsportspage.com/category/web-shows/ear-to-canvas/">Ear To Canvas</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5144"><a href="https://www.backsportspage.com/category/web-shows/zero-technique-podcast/">Zero Technique Podcast</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-338"><a href="https://www.backsportspage.com/category/web-shows/thats-what-she-said-sports/">Thats What She Said Sports</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8926"><a href="https://www.backsportspage.com/category/web-shows/the-trifecta/">The Trifecta</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8558"><a href="https://www.backsportspage.com/category/web-shows/deep-6-podcast/">Deep 6 Podcast</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-320"><a href="https://www.backsportspage.com/category/features/">Features</a>
<ul class="sub-menu">
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-321"><a href="https://www.backsportspage.com/category/features/beyond-the-athlete/">Beyond the Athlete</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-322"><a href="https://www.backsportspage.com/category/features/book-reviews/">Book Reviews</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-323"><a href="https://www.backsportspage.com/category/features/in-the-business/">In the Business</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-324"><a href="https://www.backsportspage.com/category/features/in-the-community/">In the Community</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3939"><a href="https://www.backsportspage.com/category/features/community-events/">Community Events</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-698"><a href="https://www.backsportspage.com/category/features/question-of-the-day/">Question of the Day</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5726"><a href="https://www.backsportspage.com/category/features/the-rundown-with-tmoney/">The Rundown w/T-Money</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-325"><a href="https://www.backsportspage.com/category/features/the-transition/">The Transition</a></li>
</ul>
</li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-330"><a href="https://www.backsportspage.com/category/nfl/">NFL</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-770"><a href="https://www.backsportspage.com/category/features/big-blue-report/">Big Blue Report</a></li>
</ul>
</li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-326"><a href="https://www.backsportspage.com/category/mlb/">MLB</a></li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-328"><a href="https://www.backsportspage.com/category/nba/">NBA</a></li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-331"><a href="https://www.backsportspage.com/category/nhl/">NHL</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4469"><a href="https://www.backsportspage.com/category/features/breaking-the-ice/">Breaking The Ice</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="https://www.backsportspage.com/category/other-sports/">•••</a>
<ul class="sub-menu">
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-327"><a href="https://www.backsportspage.com/category/mma/">MMA</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-318"><a href="https://www.backsportspage.com/category/other-sports/soccer/">Soccer</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317"><a href="https://www.backsportspage.com/category/other-sports/golf/">Golf</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-319"><a href="https://www.backsportspage.com/category/other-sports/wwe/">WWE</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13816"><a href="https://www.backsportspage.com/category/features/wrestling/">Wrestling</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8497"><a href="https://www.backsportspage.com/category/features/wnba/">WNBA</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10684"><a href="https://www.backsportspage.com/category/features/aew-wrestling/">AEW Wrestling</a></li>
	<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-329"><a href="https://www.backsportspage.com/category/ncaa/">NCAA</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7221"><a href="https://www.backsportspage.com/category/other-sports/xfl/">XFL</a></li>
</ul>
</li>
<li class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1098"><a href="https://www.backsportspage.com/category/photos/">BSP Photos</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-346"><a href="https://www.backsportspage.com/bsp-writers/">BSP Writers</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-341"><a href="#mailmunch-pop-509941">Subscribe</a></li>
</ul></div>					</div><!--mvp-foot-menu-->
				</div><!--mvp-main-box-cont-->
			</div><!--mvp-foot-menu-wrap-->
			<div id="mvp-foot-copy-wrap" class="left relative">
				<div class="mvp-main-box-cont">
					<div id="mvp-foot-copy" class="left relative">
						<p>Copyright © 2017 Back Sports Page, All rights reserved.</br>
Web design by Pixel Fisch Creative Solutions.</p>
					</div><!--mvp-foot-copy-->
				</div><!--mvp-main-box-cont-->
			</div><!--mvp-foot-copy-wrap-->
		</div><!--mvp-foot-bot-->
	</footer>
				<div id="mvp-mob-soc-wrap" class="left relative">
			<span class="mvp-mob-soc-share-but fa fa-share fa-2 mvp-mob-soc-click" aria-hidden="true"></span>
			<ul class="mvp-mob-soc-list left relative">
				<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/&amp;t=Rod Carew Shares Triumphs And Adversities In His Autobiography', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
				<li class="mvp-mob-soc-fb">
					<i class="fa fa-2 fa-facebook" aria-hidden="true"></i>
				</li>
				</a>
				<a href="#" onclick="window.open('http://twitter.com/share?text=Rod Carew Shares Triumphs And Adversities In His Autobiography -&amp;url=https://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
				<li class="mvp-mob-soc-twit">
					<i class="fa fa-2 fa-twitter" aria-hidden="true"></i>
				</li>
				</a>
				<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/&amp;media=https://www.backsportspage.com/wp-content/uploads/2020/12/Rod-Carew-Net-Worth-1000x600.jpg&amp;description=Rod Carew Shares Triumphs And Adversities In His Autobiography', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
				<li class="mvp-mob-soc-pin">
					<i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i>
				</li>
				</a>
				<a href="mailto:?subject=Rod Carew Shares Triumphs And Adversities In His Autobiography&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://www.backsportspage.com/rod-carew-shares-triumphs-and-adversities-in-his-autobiography/">
				<li class="mvp-mob-soc-email">
					<i class="fa fa-2 fa-envelope" aria-hidden="true"></i>
				</li>
				</a>
			</ul>
		</div><!--mvp-post-soc-wrap-->
		</div><!--mvp-site-->
												<div id="mvp-post-trend-wrap">
						<div class="mvp-main-box-cont relative">
							<ul class="mvp-post-trend-list left relative">
																	<li>
										<div class="mvp-post-trend-out relative">
																							<div class="mvp-post-trend-img left relative">
													<a href="https://www.backsportspage.com/the-boys-discuss-buffetts-vegas-vs-atlantic-city-and-tracey-murrey-joins-the-show/" rel="bookmark">
														<div class="mvp-trend-widget-img left relative">
															<img width="80" height="80" src="https://www.backsportspage.com/wp-content/uploads/2017/06/tracey_murrey-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2017/06/tracey_murrey-80x80.jpg 80w, https://www.backsportspage.com/wp-content/uploads/2017/06/tracey_murrey-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />														</div><!--mvp-trend-widget-img-->
													</a>
												</div><!--mvp-post-trend-img-->
																						<div class="mvp-post-trend-in">
												<div class="mvp-post-trend-text left relative">
													<h3>NBA</h3>
													<a href="https://www.backsportspage.com/the-boys-discuss-buffetts-vegas-vs-atlantic-city-and-tracey-murrey-joins-the-show/" rel="bookmark">Tracy Murray Joins Off Topic</a>
												</div><!--mvp-post-trend-text-->
											</div><!--mvp-post-trend-in-->
										</div><!--mvp-post-trend-out-->
									</li>
																	<li>
										<div class="mvp-post-trend-out relative">
																							<div class="mvp-post-trend-img left relative">
													<a href="https://www.backsportspage.com/r-truth-and-carmella-discuss-working-with-unicef-during-wrestlemania-week/" rel="bookmark">
														<div class="mvp-trend-widget-img left relative">
															<img width="80" height="80" src="https://www.backsportspage.com/wp-content/uploads/2019/04/thumbnail_IMG_1440-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2019/04/thumbnail_IMG_1440-80x80.jpg 80w, https://www.backsportspage.com/wp-content/uploads/2019/04/thumbnail_IMG_1440-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />														</div><!--mvp-trend-widget-img-->
													</a>
												</div><!--mvp-post-trend-img-->
																						<div class="mvp-post-trend-in">
												<div class="mvp-post-trend-text left relative">
													<h3>Community Events</h3>
													<a href="https://www.backsportspage.com/r-truth-and-carmella-discuss-working-with-unicef-during-wrestlemania-week/" rel="bookmark">R-Truth and Carmella Discuss Working With UNICEF During Wrestlemania Week</a>
												</div><!--mvp-post-trend-text-->
											</div><!--mvp-post-trend-in-->
										</div><!--mvp-post-trend-out-->
									</li>
																	<li>
										<div class="mvp-post-trend-out relative">
																							<div class="mvp-post-trend-img left relative">
													<a href="https://www.backsportspage.com/its-pre-season-but-the-lakers-are-looking-rather-dangerous/" rel="bookmark">
														<div class="mvp-trend-widget-img left relative">
															<img width="80" height="80" src="https://www.backsportspage.com/wp-content/uploads/2019/10/james-davis-2-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2019/10/james-davis-2-80x80.jpg 80w, https://www.backsportspage.com/wp-content/uploads/2019/10/james-davis-2-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />														</div><!--mvp-trend-widget-img-->
													</a>
												</div><!--mvp-post-trend-img-->
																						<div class="mvp-post-trend-in">
												<div class="mvp-post-trend-text left relative">
													<h3>NBA</h3>
													<a href="https://www.backsportspage.com/its-pre-season-but-the-lakers-are-looking-rather-dangerous/" rel="bookmark">It&#8217;s Pre-season, but the Lakers are Looking Rather Dangerous &#8230;</a>
												</div><!--mvp-post-trend-text-->
											</div><!--mvp-post-trend-in-->
										</div><!--mvp-post-trend-out-->
									</li>
																	<li>
										<div class="mvp-post-trend-out relative">
																							<div class="mvp-post-trend-img left relative">
													<a href="https://www.backsportspage.com/jared-greenberg-and-his-path-to-sports-broadcasting-success/" rel="bookmark">
														<div class="mvp-trend-widget-img left relative">
															<img width="80" height="80" src="https://www.backsportspage.com/wp-content/uploads/2017/06/Jared_greenberg-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.backsportspage.com/wp-content/uploads/2017/06/Jared_greenberg-80x80.jpg 80w, https://www.backsportspage.com/wp-content/uploads/2017/06/Jared_greenberg-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />														</div><!--mvp-trend-widget-img-->
													</a>
												</div><!--mvp-post-trend-img-->
																						<div class="mvp-post-trend-in">
												<div class="mvp-post-trend-text left relative">
													<h3>In the Business</h3>
													<a href="https://www.backsportspage.com/jared-greenberg-and-his-path-to-sports-broadcasting-success/" rel="bookmark">Jared Greenberg And His Path To Sports Broadcasting Success</a>
												</div><!--mvp-post-trend-text-->
											</div><!--mvp-post-trend-in-->
										</div><!--mvp-post-trend-out-->
									</li>
															</ul>
							<span class="mvp-post-trend-but fa fa-angle-down mvp-post-trend-but-click" aria-hidden="true"></span>
						</div><!--mvp-main-box-cont-->
					</div><!--mvp-post-trend-wrap-->
							<div class="mvp-fly-top back-to-top">
	<i class="fa fa-angle-up fa-3"></i>
</div><!--mvp-fly-top-->
<div class="mvp-fly-fade mvp-fly-but-click">
</div><!--mvp-fly-fade-->
		<div data-theiaStickySidebar-sidebarSelector='"#secondary, #sidebar, .sidebar, #primary"'
		     data-theiaStickySidebar-options='{"containerSelector":"","additionalMarginTop":0,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
		
<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf4N='a958be286141363df361b52384ec7ea9';
hf4V='b900ac60a8b296240578185060c9a8de';
cm4S="form[action='https://www.backsportspage.com/wp-comments-post.php']";
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, "+cm4S+", #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(e);return true;});$("#comment").attr({minlength:"15",maxlength:"15360"})});
/* ]]> */
</script> 
	<div style="display:none">
	<div class="grofile-hash-map-07b888ffd11d9348c672e4eb9fbe7129">
	</div>
	<div class="grofile-hash-map-f8fe62a4dc78c486e142fcf85c650d2b">
	</div>
	<div class="grofile-hash-map-8095b7c7fc24cdc9d92a34691c0034d3">
	</div>
	<div class="grofile-hash-map-0459ce4c628ae728ebfe2f028e65015b">
	</div>
	<div class="grofile-hash-map-467fba54a9a347aa869150cb49b4531c">
	</div>
	</div>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/plugins/mvp-scoreboard/js/score-script.js?ver=5.6' id='mvp-score-script-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/plugins/theia-sticky-sidebar/js/ResizeSensor.js?ver=1.7.0' id='theia-sticky-sidebar/ResizeSensor.js-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.7.0' id='theia-sticky-sidebar/theia-sticky-sidebar.js-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.7.0' id='theia-sticky-sidebar/main.js-js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=202053' id='grofiles-cards-js'></script>
<script type='text/javascript' id='wpgroho-js-extra'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=9.2.1' id='wpgroho-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/themes/the-league/js/mvpcustom.js?ver=5.6' id='mvp-custom-js'></script>
<script type='text/javascript' id='mvp-custom-js-after'>

	jQuery(document).ready(function($) {
	$(window).load(function(){
	var aboveHeight = $("#mvp-top-head-wrap").outerHeight();
	$(window).scroll(function(event){
	    	if ($(window).scrollTop() > aboveHeight){
	    		$("#mvp-top-head-wrap").addClass("mvp-score-up");
			$("#mvp-wallpaper").addClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").addClass("mvp-post-trend-down");
			$(".mvp-fly-top").addClass("mvp-to-top");
	    	} else {
	    		$("#mvp-top-head-wrap").removeClass("mvp-score-up");
			$("#mvp-wallpaper").removeClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").removeClass("mvp-post-trend-down");
	    		$(".mvp-fly-top").removeClass("mvp-to-top");
	    	}
	});
	});
	});
	

	jQuery(document).ready(function($) {
	// Main Menu Dropdown Toggle
	$(".menu-item-has-children a").click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$(".menu-item-has-children").click(function(){
    	  $(this).addClass("toggled");
    	  if($(".menu-item-has-children").hasClass("toggled"))
    	  {
    	  $(this).children("ul").toggle();
	  $(".mvp-fly-nav-menu").getNiceScroll().resize();
	  }
	  $(this).toggleClass("tog-minus");
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $(".mvp-fly-nav-menu").niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});
	});
	

	jQuery(document).ready(function($) {
	$(".infinite-content").infinitescroll({
	  navSelector: ".mvp-nav-links",
	  nextSelector: ".mvp-nav-links a:first",
	  itemSelector: ".infinite-post",
	  errorCallback: function(){ $(".mvp-inf-more-but").css("display", "none") }
	});
	$(window).unbind(".infscr");
	$(".mvp-inf-more-but").click(function(){
   		$(".infinite-content").infinitescroll("retrieve");
        	return false;
	});
	$(window).load(function(){
		if ($(".mvp-nav-links a").length) {
			$(".mvp-inf-more-but").css("display","inline-block");
		} else {
			$(".mvp-inf-more-but").css("display","none");
		}
	});
	});
	
</script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/themes/the-league/js/scripts.js?ver=5.6' id='clickmag-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/themes/the-league/js/retina.js?ver=5.6' id='retina-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/plugins/js_composer/assets/lib/bower/flexslider/jquery.flexslider-min.js?ver=5.1.1' id='flexslider-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/themes/the-league/js/jquery.infinitescroll.min.js?ver=5.6' id='infinitescroll-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-includes/js/comment-reply.min.js?ver=5.6' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/plugins/wp-spamshield/js/jscripts-ftr-min.js' id='wpss-jscripts-ftr-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=13.4.1.2' id='__ytprefsfitvids__-js'></script>
<script type='text/javascript' src='https://www.backsportspage.com/wp-includes/js/wp-embed.min.js?ver=5.6' id='wp-embed-js'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202053.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.2.1',blog:'161203849',post:'15917',tz:'-5',srv:'www.backsportspage.com'} ]);
	_stq.push([ 'clickTrackerInit', '161203849', '15917' ]);
</script>
</body>
<script>'undefined'=== typeof _trfq || (window._trfq = []);'undefined'=== typeof _trfd && (window._trfd=[]),_trfd.push({'tccl.baseHost':'secureserver.net'}),_trfd.push({'ap':'cpbh'},{'server':'a2plvcpnl218830'}) // Monitoring performance to make your website faster. If you want to opt-out, please contact web hosting support.</script><script src='https://img1.wsimg.com/tcc/tcc_l.combined.1.0.6.min.js'></script></html>